5,596,784 Members 48,471 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Fastboot Flash Command Hangs Device

Tip us?
 
kulm
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Sep 2007
Default [Q] Fastboot Flash Command Hangs Device

I just got my new tablet today... it automatically did all it's updates while it was charging - I unlocked it following the tutorials and some strange issues started happening where the recovery ROMs I flashed couldn't see the system partitions. I tried a few different recovery ROMs (TWRP, CWM) but both did the same.

The problem, now when I try and flash anything using the bootloader, my command prompt claims it finished successfully, but my tablet's green flashing box stops flashing and does nothing until I hold on the power button to hard boot it.

Any ideas? Here's the information I've been able to gather:

Code:
PS C:\android-sdk\platform-tools> .\fastboot.exe -i 0x0b05 getvar all
(bootloader) version-bootloader: 1.0
(bootloader) version-baseband: 2.0
(bootloader) version: 0.4
(bootloader) serialno: 0asdfghjklzxcvbnm
(bootloader) mid: 001
(bootloader) product: Cardhu
(bootloader) secure: yes
(bootloader) unlocked: no
(bootloader) uart-on: yes
(bootloader) partition-size:bootloader: 0x0000000000800000
(bootloader) partition-type:bootloader: basic
(bootloader) partition-size:recovery: 0x0000000000800000
(bootloader) partition-type:recovery: basic
(bootloader) partition-size:boot: 0x0000000000800000
(bootloader) partition-type:boot: basic
(bootloader) partition-size:system: 0x0000000030000000
(bootloader) partition-type:system: ext4
(bootloader) partition-size:cache: 0x000000001ac00000
(bootloader) partition-type:cache: ext4
(bootloader) partition-size:userdata: 0x00000006e5680000
(bootloader) partition-type:userdata: ext4
all:
finished. total time: 0.105s
PS C:\android-sdk\platform-tools> .\fastboot.exe -i 0x0b05 erase recovery
erasing 'recovery'...
OKAY [  1.237s]
finished. total time: 1.238s
PS C:\android-sdk\platform-tools> .\fastboot.exe -i 0x0b05 flash recovery openrecovery-twrp-2.4.3.0-tf300t-JB.blob
sending 'recovery' (7670 KB)...
OKAY [  2.099s]
writing 'recovery'...
OKAY [  2.694s]
finished. total time: 4.795s
PS C:\android-sdk\platform-tools>
I can erase and getvar all day, but flash makes it freeze up.
 
kulm
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Sep 2007
I forgot to include that once it locks up, the fastboot command does this:

Code:
PS C:\android-sdk\platform-tools> ./fastboot -i 0x0B05 devices
????????????    fastboot
PS C:\android-sdk\platform-tools> ./fastboot -i 0x0B05 getvar all
getvar:all FAILED (command write failed (Unknown error))
finished. total time: 0.592s
PS C:\android-sdk\platform-tools>
 
tobdaryl
Old
#3  
Senior Member
Thanks Meter 656
Posts: 1,220
Join Date: May 2010
[QUOTE=kulm;38852405]I just got my new tablet today... it automatically did all it's updates while it was charging - I unlocked it following the tutorials and some strange issues started happening where the recovery ROMs I flashed couldn't see the system partitions. I tried a few different recovery ROMs (TWRP, CWM) but both did the same.


(bootloader) unlocked: no
Have you unlocked? Your posted information says no. If you are on 4.2 I can't say but previous firmware disallowed use of fastboot prior to unlocking.
 
kulm
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Sep 2007
[QUOTE=tobdaryl;38872180]
Quote:
Originally Posted by kulm View Post
(bootloader) unlocked: no
Have you unlocked? Your posted information says no. If you are on 4.2 I can't say but previous firmware disallowed use of fastboot prior to unlocking.
I wondered the same thing - but I had TWRP working on it and it says on the top when I reboot "The device is unlocked"...
 
tobdaryl
Old
(Last edited by tobdaryl; 7th March 2013 at 11:44 PM.)
#5  
Senior Member
Thanks Meter 656
Posts: 1,220
Join Date: May 2010
[QUOTE=kulm;38876982]
Quote:
Originally Posted by tobdaryl View Post

I wondered the same thing - but I had TWRP working on it and it says on the top when I reboot "The device is unlocked"...
I have not seen this or read of this issue. Are you on the 4.2 version of software? If so you are in uncharted waters.
I didn't get the update and can't use the ota to install. I like many others are waiting for the asus firmware version.
I have read one reply where cwm didn't work on 4.2.
Something else I have never seen is the bootloader serial number displayed. You may wish to remove that line from your post. Just choose edit and delete that line, then save.
If on 4.2 this may indicate that cwm and twrp will require an update to work properly.
If you can use your tablet as is then I suggest doing so or flash stock JB firmware the most recent is 10.4.2.20 but for my use 10.4.2.18 has less lag and everything I need works properly.
I'll bookmark this thread and try to come back with some help after more research. Failing that maybe someone else will reply with a good suggestion.
Good Luck!
Please respond with your firmware version.

This is the standard method used to unlock the bootloader with fastboot. I can't use it since I'm not on 4.2 and won't suggest that you do; it is for information only at this point.
fastboot oem unlock
I suspect we would need to use the -i 0x0b05 as in fastboot -i 0x0b05 oem unlock.
 
kulm
Old
(Last edited by kulm; 8th March 2013 at 06:57 PM.)
#6  
Junior Member - OP
Thanks Meter 0
Posts: 4
Join Date: Sep 2007
[QUOTE=tobdaryl;38878812]
Quote:
Originally Posted by kulm View Post

I have not seen this or read of this issue. Are you on the 4.2 version of software? If so you are in uncharted waters.
I didn't get the update and can't use the ota to install. I like many others are waiting for the asus firmware version.
I have read one reply where cwm didn't work on 4.2.

If on 4.2 this may indicate that cwm and twrp will require an update to work properly.
If you can use your tablet as is then I suggest doing so or flash stock JB firmware the most recent is 10.4.2.20 but for my use 10.4.2.18 has less lag and everything I need works properly.
I'll bookmark this thread and try to come back with some help after more research. Failing that maybe someone else will reply with a good suggestion.
Good Luck!
Please respond with your firmware version.

This is the standard method used to unlock the bootloader with fastboot. I can't use it since I'm not on 4.2 and won't suggest that you do; it is for information only at this point.
fastboot oem unlock
I suspect we would need to use the -i 0x0b05 as in fastboot -i 0x0b05 oem unlock.

Thanks for the response - the SN is bogus.So, when I boot without pushing vol up/down it goes to the "ASUS" logo screen with "device unlocked" at the top and it just sits... I can get into APX with vol up and fastboot with vol down.

With vol down this comes up at the top:

Code:
Key driver not found.. Booting OS
Android cardhu-user bootloader <1.00 e> released by "US_epad-10.6.1.8-20130225" A03

Starting Fastboot USB download protocol
Then it has the typical RCK, Android and Wipe Data options.
When I choose RCK I get:
Code:
Booting Recovery kernel image
 Booting Failed
Unrecoverable bootloader error (0x00000000)
The device hangs until I power cycle from there.
 
tobdaryl
Old
(Last edited by tobdaryl; 8th March 2013 at 08:03 PM.)
#7  
Senior Member
Thanks Meter 656
Posts: 1,220
Join Date: May 2010
[QUOTE=kulm;38911365]
Quote:
Originally Posted by tobdaryl View Post


Thanks for the response - the SN is bogus.So, when I boot without pushing vol up/down it goes to the "ASUS" logo screen with "device unlocked" at the top and it just sits... I can get into APX with vol up and fastboot with vol down.

With vol down this comes up at the top:

Code:
Key driver not found.. Booting OS
Android cardhu-user bootloader <1.00 e> released by "US_epad-1.6.1.8-20130225" A03

Starting Fastboot USB download protocol
Then it has the typical RCK, Android and Wipe Data options.
When I choose RCK I get:
Code:
Booting Recovery kernel image
 Booting Failed
Unrecoverable bootloader error (0x00000000)
The device hangs until I power cycle from there.
I am completely lost, if this is 4.2 that might be why. If you will give me your version I'll try to help you search and get an answer. Go to settings/about tablet/ and tell me what you have for build# and android version.
The serial# is not your tablet serial# but bootloader serial#. This may be in response to our recent petition to asus for the ability to unlock the bootloader in addition to the tablet unlock we now have.
If so this should allow nvflash for people on the JB bootloader.
Note: If you are on 4.2 you might look at settings and see if encryption is turned on, at least two have mentioned that it is on by default and it will cause various issues with fastboot and cwm or twrp.
Now that I think about it even on 4.1 encryption has caused some strange results.
 
mistyv
Old
#8  
Junior Member
Thanks Meter 3
Posts: 17
Join Date: Jan 2013
Location: Detroit, MI
[QUOTE=tobdaryl;38911909]
Quote:
Originally Posted by kulm View Post

I am completely lost, if this is 4.2 that might be why. If you will give me your version I'll try to help you search and get an answer. Go to settings/about tablet/ and tell me what you have for build# and android version.
The serial# is not your tablet serial# but bootloader serial#. This may be in response to our recent petition to asus for the ability to unlock the bootloader in addition to the tablet unlock we now have.
If so this should allow nvflash for people on the JB bootloader.
Note: If you are on 4.2 you might look at settings and see if encryption is turned on, at least two have mentioned that it is on by default and it will cause various issues with fastboot and cwm or twrp.
Now that I think about it even on 4.1 encryption has caused some strange results.
I am on 4.2.1 and am having the same issue. I just checked and encryption is turned off on mine.
 
tobdaryl
Old
(Last edited by tobdaryl; 9th March 2013 at 02:46 AM.)
#9  
Senior Member
Thanks Meter 656
Posts: 1,220
Join Date: May 2010
[QUOTE=mistyv;38915313]
Quote:
Originally Posted by tobdaryl View Post

I am on 4.2.1 and am having the same issue. I just checked and encryption is turned off on mine.
Thanks for the update. I'll start searching also and report when I have some news.
Good Luck!

I'm finding several with fastboot issues as well as cwm and twrp issues but no resolutions yet.
I'll try to keep you posted if I get something positive.
 
ryuken11221
Old
#10  
ryuken11221's Avatar
Senior Member
Thanks Meter 18
Posts: 333
Join Date: Dec 2010
Location: Alexandria

 
DONATE TO ME
Default Re: [Q] Fastboot Flash Command Hangs Device

My device is doin the same thing i would go into fastboot mode and the green box would just freeze up but when i push the recovery it says that is was successful b ut the device doesnt take the recovery then when i tried to push it again it fails can anyone help

Sent from my ASUS Transformer Pad TF300T using XDA Premium HD app
My Touch 4g > Samsung Epic4g > Motorola Photon 4g > HTC Amaze 4g > Samsung Galaxy S II > Samsung Galaxy Nexus > Samsung Galaxy S III

If i helped you help me buy my son a bottle of milk.....13 months and still growing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes