5,600,664 Members 37,331 Now Online
XDA Developers Android and Mobile Development Forum

Hot to prevent Google Maps from updating?

Tip us?
 
alpinems
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
Default Hot to prevent Google Maps from updating?

I really don't like the 7.0 version of Google Maps, so much so that I rooted my phone (HTC One) to install the 6.x version. I use the Navigation app all the time in my car. My problem is that no matter what I do, it keeps getting updated to the 7.x version every few days. I have it detached from the Market with TiBackup Pro, and turned off all Market updates for all apps on the phone. It doesn't matter, in a couple of days I'll jump into my car, hit the Navigation button from the Car menu screen and get "welcome to 7.0!". I can restore it from my backup in about 5 minutes, but who want to do that everytime I get in the car. Any ideas?
 
Aldo101t
Old
#2  
Aldo101t's Avatar
Senior Member
Thanks Meter 1115
Posts: 2,671
Join Date: Mar 2012
Location: Pittsburgh
Quote:
Originally Posted by alpinems View Post
I really don't like the 7.0 version of Google Maps, so much so that I rooted my phone (HTC One) to install the 6.x version. I use the Navigation app all the time in my car. My problem is that no matter what I do, it keeps getting updated to the 7.x version every few days. I have it detached from the Market with TiBackup Pro, and turned off all Market updates for all apps on the phone. It doesn't matter, in a couple of days I'll jump into my car, hit the Navigation button from the Car menu screen and get "welcome to 7.0!". I can restore it from my backup in about 5 minutes, but who want to do that everytime I get in the car. Any ideas?
Playstore>settings>do not auto update, that's it.
 
elvisypi
Old
#3  
elvisypi's Avatar
Senior Member
Thanks Meter 1243
Posts: 2,225
Join Date: Nov 2010
Location: Durres

 
DONATE TO ME
Why did you go into so much trouble. I find 7.0 a major improvement. Anyways, just uncheck the auto update for Maps in the three dot menu

Sent from my HTCONE using Tapatalk
if you like my post
Devices:
HTC One
ROM : InsertCoin 7.1-4

HTC Sensation
ROM : ViperS 5.0 Sense 5
The Following User Says Thank You to elvisypi For This Useful Post: [ Click to Expand ]
 
alpinems
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
Quote:
Originally Posted by Aldo101t View Post
Playstore>settings>do not auto update, that's it.
Already done, didn't stop it.
Attached Thumbnails
Click image for larger version

Name:	2013-12-13 23.50.58.jpg
Views:	59
Size:	152.6 KB
ID:	2453220  
 
alpinems
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
Quote:
Originally Posted by elvisypi View Post
Why did you go into so much trouble. I find 7.0 a major improvement. Anyways, just uncheck the auto update for Maps in the three dot menu

Sent from my HTCONE using Tapatalk
What can I say, but I (and lots of other) have a different opinion. But anyway, I don't see any auto update available. And it has been detached using TiBackup.
Attached Thumbnails
Click image for larger version

Name:	2013-12-13 23.51.47.jpg
Views:	60
Size:	118.1 KB
ID:	2453231   Click image for larger version

Name:	2013-12-13 23.51.36.png
Views:	57
Size:	198.7 KB
ID:	2453232  
 
Aldo101t
Old
#6  
Aldo101t's Avatar
Senior Member
Thanks Meter 1115
Posts: 2,671
Join Date: Mar 2012
Location: Pittsburgh
Quote:
Originally Posted by alpinems View Post
Already done, didn't stop it.
what can i say, i works for me????? don't know why it doesn't for you.
 
tdcokefiend
Old
#7  
Member
Thanks Meter 4
Posts: 37
Join Date: Jul 2010
Location: Garland
Quote:
Originally Posted by alpinems View Post
I really don't like the 7.0 version of Google Maps, so much so that I rooted my phone (HTC One) to install the 6.x version. I use the Navigation app all the time in my car. My problem is that no matter what I do, it keeps getting updated to the 7.x version every few days. I have it detached from the Market with TiBackup Pro, and turned off all Market updates for all apps on the phone. It doesn't matter, in a couple of days I'll jump into my car, hit the Navigation button from the Car menu screen and get "welcome to 7.0!". I can restore it from my backup in about 5 minutes, but who want to do that everytime I get in the car. Any ideas?
when you go in the playstore and you click inside of the Maps application,
if you hit the menu button next to the share button, make sure the "Auto update" box is also unchecked,
not just the one in play store settings. That's how I got my snapchat to stop updating.

Hope that helps!

HTC One (InsertCoin 4.3/5.5) >EVO 4G LTE & Nook Color >Evo 3D >T-Mobile G2 >Samsung Moment
 
alpinems
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
Quote:
Originally Posted by tdcokefiend View Post
when you go in the playstore and you click inside of the Maps application,
if you hit the menu button next to the share button, make sure the "Auto update" box is also unchecked,
not just the one in play store settings. That's how I got my snapchat to stop updating.

Hope that helps!
Nope, when I do that, it goes to the same setttings page as the store, which is already set to 'do not update', nothing specifically for that application. I"m running 4.3, maybe that's different.
 
subhumanderelict
Old
#9  
Senior Member
Thanks Meter 70
Posts: 228
Join Date: Dec 2007
Location: Chicago, Il
Quote:
Originally Posted by alpinems View Post
I really don't like the 7.0 version of Google Maps, so much so that I rooted my phone (HTC One) to install the 6.x version. I use the Navigation app all the time in my car. My problem is that no matter what I do, it keeps getting updated to the 7.x version every few days. I have it detached from the Market with TiBackup Pro, and turned off all Market updates for all apps on the phone. It doesn't matter, in a couple of days I'll jump into my car, hit the Navigation button from the Car menu screen and get "welcome to 7.0!". I can restore it from my backup in about 5 minutes, but who want to do that everytime I get in the car. Any ideas?
I had this issue with another app. The solution was to re-sign the app so that the Play store didn't recognize it. Check out this link and let us know if it works for you:

http://android.stackexchange.com/que...rom-market-doe

Good luck!

Sent from my Nexus 7 using Tapatalk
 
alpinems
Old
#10  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
Quote:
Originally Posted by subhumanderelict View Post
I had this issue with another app. The solution was to re-sign the app so that the Play store didn't recognize it. Check out this link and let us know if it works for you:

<link deleted because I don't have rights yet >

Good luck!

Sent from my Nexus 7 using Tapatalk
Thanks! that looks a good solution to try.

- Cris

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes