5,600,664 Members 35,732 Now Online
XDA Developers Android and Mobile Development Forum

[Q] 4.2.2 breaks Wi-Fi

Tip us?
 
Nutcake
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 11
Join Date: Dec 2013
Question [Q] 4.2.2 breaks Wi-Fi

So after having a lot of troubles with 4.3.x on this phone I decided to go back to 4.2.2 until 4.4 is finally stable for us;
Only problem is, whenever I flash any kind of 4.2.2 ROM, my phone decides to get stuck on "Obtaining IP Address..." when trying to log in to my Wi-Fi, while it works perfectly after flashing 4.3 again.
I also tried multiple different Kernels but no difference at all.

Anyone got any idea what might be causing this? I really want to go back to 4.2.2 since on 4.3 I get problems like my phone taking ages to wake up from stand-by or not waking up at all and having immense battery drain caused by wlan_rx_wake.

I'm thankful for any help.
 
Flying_Bear
Old
#2  
Flying_Bear's Avatar
Senior Member
Thanks Meter 593
Posts: 1,545
Join Date: Jan 2011
Quote:
Originally Posted by Nutcake View Post
So after having a lot of troubles with 4.3.x on this phone I decided to go back to 4.2.2 until 4.4 is finally stable for us;
Only problem is, whenever I flash any kind of 4.2.2 ROM, my phone decides to get stuck on "Obtaining IP Address..." when trying to log in to my Wi-Fi, while it works perfectly after flashing 4.3 again.
I also tried multiple different Kernels but no difference at all.

Anyone got any idea what might be causing this? I really want to go back to 4.2.2 since on 4.3 I get problems like my phone taking ages to wake up from stand-by or not waking up at all and having immense battery drain caused by wlan_rx_wake.

I'm thankful for any help.
dont know what rom you're using, but try a different one
To install custom roms on O4x:

1. upgrade to jb
2. root
3. unlock bootloader
4. flash custom recovery (cwm)
5. flash roms
6. if you encounter any issues, search, they've been answered already.

Got issues with RIL/IMEI/BASEBAND on custom 4.2, 4.3 or 4.4 ROMs on p880? Click me for possible solution!
The Following User Says Thank You to Flying_Bear For This Useful Post: [ Click to Expand ]
 
Nutcake
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 11
Join Date: Dec 2013
Quote:
Originally Posted by Flying_Bear View Post
dont know what rom you're using, but try a different one
As I've said, any 4.2.2 ROM I tried, which is about 5 different ones, has the same issue.
The Following User Says Thank You to Nutcake For This Useful Post: [ Click to Expand ]
 
Flying_Bear
Old
#4  
Flying_Bear's Avatar
Senior Member
Thanks Meter 593
Posts: 1,545
Join Date: Jan 2011
Quote:
Originally Posted by Nutcake View Post
As I've said, any 4.2.2 ROM I tried, which is about 5 different ones, has the same issue.
sorry, misread ><

could it be a problem with your home network? can you try another network around you?

i had this issue with custom 4.1.2 roms such as zaiben, but haven't read that anyone had this issue on any 4.2.2 roms.
To install custom roms on O4x:

1. upgrade to jb
2. root
3. unlock bootloader
4. flash custom recovery (cwm)
5. flash roms
6. if you encounter any issues, search, they've been answered already.

Got issues with RIL/IMEI/BASEBAND on custom 4.2, 4.3 or 4.4 ROMs on p880? Click me for possible solution!
The Following User Says Thank You to Flying_Bear For This Useful Post: [ Click to Expand ]
 
dimi89
Old
#5  
dimi89's Avatar
Senior Member
Thanks Meter 153
Posts: 607
Join Date: Mar 2009
Some roms cant connect to the WEP networks (or other ones i forgot witch is exactly ) Try changing your network securiti.

Sent from my LG-P880 using Tapatalk
****LG 4x -Experimenting with different roms- ****

P.S.If someone help you it is polite to say "Thank you" (in this case hit "Thank you" button
The Following User Says Thank You to dimi89 For This Useful Post: [ Click to Expand ]
 
Nutcake
Old
#6  
Junior Member - OP
Thanks Meter 1
Posts: 11
Join Date: Dec 2013
Quote:
Originally Posted by Flying_Bear View Post
sorry, misread ><

could it be a problem with your home network? can you try another network around you?

i had this issue with custom 4.1.2 roms such as zaiben, but haven't read that anyone had this issue on any 4.2.2 roms.
Just tried a different AP but, sadly, no difference. :c

Quote:
Originally Posted by dimi89 View Post
Some roms cant connect to the WEP networks (or other ones i forgot witch is exactly ) Try changing your network securiti.

Sent from my LG-P880 using Tapatalk
Both networks I tried connecting to were WPA2 with WEP disabled.
 
dimi89
Old
#7  
dimi89's Avatar
Senior Member
Thanks Meter 153
Posts: 607
Join Date: Mar 2009
Hmmmm....Did you try liquidsmooth 4.2.2 rom maybe ? I ama asking for specific rom since i know it is 99% working.

Sent from my LG-P880 using Tapatalk
****LG 4x -Experimenting with different roms- ****

P.S.If someone help you it is polite to say "Thank you" (in this case hit "Thank you" button
The Following User Says Thank You to dimi89 For This Useful Post: [ Click to Expand ]
 
Nutcake
Old
#8  
Junior Member - OP
Thanks Meter 1
Posts: 11
Join Date: Dec 2013
Quote:
Originally Posted by dimi89 View Post
Hmmmm....Did you try liquidsmooth 4.2.2 rom maybe ? I ama asking for specific rom since i know it is 99% working.

Sent from my LG-P880 using Tapatalk
Liquidsmooth was actually the first one I tried, followed by XenonHD, CARBON, various CM 10.1 releases and ReVolt, all with the same issue.
 
dimi89
Old
#9  
dimi89's Avatar
Senior Member
Thanks Meter 153
Posts: 607
Join Date: Mar 2009
For the love of God....Try MIUI 4.2.2 it is 5 min to flesh it and i am very curious what can couse this problem...BTW do you format / system before flashing new rom ?

Sent from my LG-P880 using Tapatalk
****LG 4x -Experimenting with different roms- ****

P.S.If someone help you it is polite to say "Thank you" (in this case hit "Thank you" button
The Following User Says Thank You to dimi89 For This Useful Post: [ Click to Expand ]
 
Nutcake
Old
#10  
Junior Member - OP
Thanks Meter 1
Posts: 11
Join Date: Dec 2013
Quote:
Originally Posted by dimi89 View Post
For the love of God....Try MIUI 4.2.2 it is 5 min to flesh it and i am very curious what can couse this problem...BTW do you format / system before flashing new rom ?

Sent from my LG-P880 using Tapatalk
Alright, I'll try MIUI, also I always format /data, cache and dalvik.
There is no option in my recovery to format system but it says it does that automatically, when flashing a new ROM

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes