5,595,067 Members 40,800 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Large battery drain from "Android OS"

Tip us?
 
andomar
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Nov 2012
Plug [Q] Large battery drain from "Android OS"

Android OS uses by far the most battery on my phone:



The phone is awake for more than 50% of the time.

BetterBatteryStats or Wakelock Detector get no further than pointing at Android OS.

Any tips on how I might troubleshoot this issue would be welcome!
 
pinsb
Old
#2  
Senior Member
Thanks Meter 41
Posts: 407
Join Date: Sep 2011
Location: London, UK
Search is your friend.....

Turn off location services and see the difference.

Sent from TabbyOne
The Following User Says Thank You to pinsb For This Useful Post: [ Click to Expand ]
 
andomar
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Nov 2012
Quote:
Originally Posted by pinsb View Post
Search is your friend.....

Turn off location services and see the difference.

Sent from TabbyOne
Thanks, I did search quite a bit, but ruled out Location Services because my GPS is always off.

I'll turn off Location Services on top of that and see if it helps!
 
radicalisto
Old
#4  
radicalisto's Avatar
Senior Member
Thanks Meter 1178
Posts: 2,975
Join Date: Nov 2013
Location: York

 
DONATE TO ME
Quote:
Originally Posted by andomar View Post
Thanks, I did search quite a bit, but ruled out Location Services because my GPS is always off.

I'll turn off Location Services on top of that and see if it helps!
I had a similar problem last 48hours, I put it down to a launcher I was using (KitKat one from Play store) - sure enough that's what it was for me. so switched back to TW
// Nexus 5 (D821) // Liquid // UBER //
// Note 3 (SM-N9005) // AOSP ROM of variety // Lean or temasek's Kernel // - Dumped. No more Samsung
 
vndnguyen
Old
#5  
vndnguyen's Avatar
Senior Member
Thanks Meter 443
Posts: 1,076
Join Date: Sep 2009

 
DONATE TO ME
Just restart your phone and see if it makes difference?
 
MACHEK
Old
#6  
MACHEK's Avatar
Senior Member
Thanks Meter 46
Posts: 282
Join Date: Oct 2009
Try clearing cache partition in recovery

Sent from my SM-N900V using xda app-developers app
The Following User Says Thank You to MACHEK For This Useful Post: [ Click to Expand ]
 
MACHEK
Old
#7  
MACHEK's Avatar
Senior Member
Thanks Meter 46
Posts: 282
Join Date: Oct 2009
Glad it worked

Sent from my SM-N900V using xda app-developers app
 
yolopants
Old
#8  
Junior Member
Thanks Meter 1
Posts: 3
Join Date: Dec 2013
I had the same problem and it was only fixed temporary by restarts. Since i turned off the advanced wi-fi option "keep wi-fi on during sleep", everything works like a charm. It seems there is a problem with the (deep) sleep states. I am on the newest firmware (rooted, knox 0x0) btw and Android OS went from 60% to 10% battery usage!

So in case the problem returns, try it... You might have a little bit more mobile traffic depending on your apps and configuration, but hopefully this will get sorted out with a new firmware.
 
EnterLordVader
Old
#9  
EnterLordVader's Avatar
Member
Thanks Meter 11
Posts: 56
Join Date: Jan 2013
I've had the same problem for some time.
curiously enough, I found that turning location services ON fixed the problem.
 
odeccacccp
Old
#10  
odeccacccp's Avatar
Senior Member
Thanks Meter 242
Posts: 1,569
Join Date: Dec 2011
Location: Bradford West Gwillimbury
It can be many things, u need a wakelock detector app or bbs app to oin point the problem.

Sent from my SM-N900W8 using XDA Premium 4 mobile app
I work for the Government, don't mess with me!

If you know how to ask, you should know how to click "Thanks"

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes