5,599,677 Members 45,794 Now Online
XDA Developers Android and Mobile Development Forum

D800 Will not send SMS! Only receives!

Tip us?
 
IrocD
Old
#1  
Member - OP
Thanks Meter 1
Posts: 49
Join Date: Dec 2012
Default D800 Will not send SMS! Only receives!

Hello everyone. I would like to thank anyone who helps in advance, and also to the devs who work so hard.

Anyhow, the problem first surfaced on CM11 with a recent nightly. All of a sudden, my SMSes would not send. So I tried different apps, hangouts, stock SMS, gosms, etc. Nothing works, the message just times out.

Next I tried restoring my known good working rooted stock nandroid. It all of a sudden would not send SMS with that either! Then I tried wiping my entire device, and doing a clean flash of only the 12/17 CM11 and the newest PA Gapps, and I did not restore anything. Still not sending!!! Please help, did I break my device??
 
kimtyson
Old
#2  
Senior Member
Thanks Meter 526
Posts: 1,505
Join Date: Oct 2006
Location: York, Pa
I doubt that you broke it so relax. Check your APN settings. Maybe restore original stock ROM and then reflash whatever you want. Before you wiped it all I would have tried Textra. Good luck.
Please use search before posting your question.
Be kind to the devs! Without them, XDA is just a bunch of jerks bickering.
 
xxxrichievxxx
Old
(Last edited by xxxrichievxxx; 17th December 2013 at 08:46 PM.)
#3  
Senior Member
Thanks Meter 76
Posts: 426
Join Date: Jul 2010
Location: Notting Hill, London
This happened to me about two days ago, I was installing and reinstalling Paranoid Android on my AT&T LG G2 to the point where somehow I was unable to send SMS.

The funny thing is I could receive Texts & Picture messages from others, and I could send Picture messages BUT NOT send texts or reply to texts.

I tried other 3rd party messaging apps - I even went back to stock but my text messages wouldn't send! I went to my local AT&T store and they replaced my SIM card for free and everything was normal, even now it's working just great.

I even tried imputing the SMSC number again but i'd get an update error message.

Trust me I've tried everything and I couldn't get it to work, but I went to the AT&T store and all they did was switch my SIM card for a new one and everything was back to normal.
The Following User Says Thank You to xxxrichievxxx For This Useful Post: [ Click to Expand ]
 
xdafoundingmember
Old
#4  
Account currently disabled
Thanks Meter 34
Posts: 213
Join Date: Aug 2013
Yea I have experienced dead Sims before and this is the symptom

Sent from my LG-D803 using XDA Premium 4 mobile app
 
SysAdmNj
Old
#5  
SysAdmNj's Avatar
Senior Member
Thanks Meter 179
Posts: 1,908
Join Date: Jun 2010
Quote:
Originally Posted by xdafoundingmember View Post
Yea I have experienced dead Sims before and this is the symptom

Sent from my LG-D803 using XDA Premium 4 mobile app
Dead sims, would also mean no signal to make a call as well maybe?
 
xxxrichievxxx
Old
(Last edited by xxxrichievxxx; 17th December 2013 at 09:06 PM.)
#6  
Senior Member
Thanks Meter 76
Posts: 426
Join Date: Jul 2010
Location: Notting Hill, London
Quote:
Originally Posted by SysAdmNj View Post
Dead sims, would also mean no signal to make a call as well maybe?
Yes, calls did come in and I could make calls. Data worked as well (still connected to LTE). Everything worked except mysteriously texts wouldn't send.

I wonder if it's something to do with flashing ROMS so many times to the point where we don't let the ROM settle or maybe certain ROMS 'embed' some file that confuses the SIM card to cause it to malfunction?
 
Steamer86
Old
#7  
Steamer86's Avatar
Senior Member
Thanks Meter 126
Posts: 706
Join Date: May 2012
Location: Baltimore
EFS
 
IrocD
Old
#8  
Member - OP
Thanks Meter 1
Posts: 49
Join Date: Dec 2012
Quote:
Originally Posted by Steamer86 View Post
EFS
I really hope that it is the SIM and not my EFS, because when I restored to my known good Rooted stock Nandroid, EFS was included in that and it still didn't work. I have contacted AIO for a SIM but it's gonna be a few days. I wanted to get one anyway because I feel my cut-down SIM was negatively affecting my signal reception. I could be completely wrong in that, but still. I can do EVERYTHING except send SMS. So weird!

Sent from my LG-D800 using XDA Premium 4 mobile app
 
IrocD
Old
#9  
Member - OP
Thanks Meter 1
Posts: 49
Join Date: Dec 2012
Quote:
Originally Posted by xxxrichievxxx View Post
I even tried imputing the SMSC number again but i'd get an update error message.
Is my SMSC supposed to have those extra numbers at the end? I even had AIO "refresh/provision" me to no avail. And while I was on the line with her, she wanted me to remove the 3 extra numbers. But they persist! I have included a photo so you can see what I mean.

Further (and less importantly), is anyone else having an issue with KK where the '*#*#4636#*#*' menu takes forever to show up after entering the code?

Thanks again to anyone who's made suggestions!

Sent from my LG-D800 using XDA Premium 4 mobile app
Attached Thumbnails
Click image for larger version

Name:	1387331517688.jpg
Views:	19
Size:	29.2 KB
ID:	2460935  
 
Steamer86
Old
#10  
Steamer86's Avatar
Senior Member
Thanks Meter 126
Posts: 706
Join Date: May 2012
Location: Baltimore
Ahh, good point, just saw calls worked anyhow, ignore that. And no clue.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes