Info 2 [Q] UID system Inconsistent- Solved

Hi Forum,

I was running Indie ROM 4.3, v19. I did the 3 wipes and installed Indie ROM, v20. After installation,

I got this message( "UIDs on the system are inconsistent, you need to wipe your data partition or your device will be unstable."
with a button that stays "I'm Feeling Lucky).

I research XDA , some stated to reflash the ROM using TWRP, and then fix permission. I am using Phil Touch CWM, which has fix permission. However, I still get the same message.

The phone is usable, but certain Google app wont install.

Anyone has an idea how to fix this? Would flashing a ROM from another Dev fix this problem?

Thank you for looking, and then some.... for your helpful suggestion.

OK, I got tired to flashing. Used TWRP to repartition the whole drive. This fixed all the issue.

I solved the problem. I install TWRP, wipes and fix permission. However, TWRP reported that fix permission has failed. I let the phone reboot. ROM start up with out problem. Guess I will be using TWRP from now on.

I spoke to soon. I was not able to install many of Google apps. Reinstall ROM again and now getting the the same message ...UID..

Anyone have any idea?