5,596,179 Members 33,981 Now Online
XDA Developers Android and Mobile Development Forum

[Q] m919nuvuemk5 HELP!

Tip us?
 
Jimcisme
Old
(Last edited by Jimcisme; 23rd December 2013 at 08:43 PM.) Reason: add question
#1  
Junior Member - OP
Thanks Meter 0
Posts: 16
Join Date: Feb 2008
Default [Q] m919nuvuemk5 HELP!

Ok, I am not new to flashing but its not somthing I do on a regular basis...I got in a hurry and screwed up my phone.
I have been running cyanogenmod 10.2 and my wife has the same phone that I left stock. They are T-Mobile Galaxy S4 SGH-M919. Yesterday I poked around a bit and found the most up to date rom I could, it was m919nuvuemk5. What I failed to notice was that this rom is for Metro PCS which may be owned by t-mobile , but is definitly not t-mobile.... I flashed and it boots all the way to the Metro PCS splash screen and thats where it stops. SO...I started looking around a bit more and found the thread - [GUIDE][HOW-TO] Return device back to stock 'Official'!
at :
http://forum.xda-developers.com/show....php?t=2336392

So the short version is that right now the rom I have flashed is m919nuvuamdb but my base band is still m919nuvuemk5 and my knox fuse is popped 0x1 The phone works fine but I have no wifi I did factory resets and wiped everything trying to get the wifi working but sofar no joy. I can root with CF-Auto-Root via ODIN with no problem. I can apply custom recoveries like CWM with no problem.
So all is not lost.

My questions are:

1. It is my understanding that at this time there is no way to remove the Knox 0x1 that says my phone is trash for corporate use. Is this true?

2. My boot times are very long, (2m 10s) it seems to hang on the "Samsung Galaxy S4" screen where it says " kernel is not seandroid enforcing set warrenty bit: kernel" Is there a way to make the warning go away? How about a shorter boot time? I think if t-mobile comes out with a m919nuvuemk5 rom I should be ok and the warnings will go away atleast. Is this right?

3. How do I make my wifi work?

I could really use some help with this, I have been reading allover these boards for a day. Please save your chastising for your children, know I screwed up. Just lead me in the right direction.
 
baseballfanz
Old
#2  
baseballfanz's Avatar
Senior Member
Thanks Meter 1708
Posts: 6,684
Join Date: Oct 2010
Location: Sugar Land TX
Try flashing the mk2 modem.
If that don't work you might have to Odin flashed the whole 4.3 firmware.

☞ Sent from here☜🙈🙉🙊
**************
The Following User Says Thank You to baseballfanz For This Useful Post: [ Click to Expand ]
 
Jimcisme
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 16
Join Date: Feb 2008
Quote:
Originally Posted by baseballfanz View Post
Try flashing the mk2 modem.
If that don't work you might have to Odin flashed the whole 4.3 firmware.

☞ Sent from here☜������
Where can I find just the modem?
 
Android_Monsters
Old
#4  
Android_Monsters's Avatar
Senior Member
Thanks Meter 746
Posts: 2,731
Join Date: Feb 2012
Location: Los Angeles
This is how I did that: the file is in the op. http://forum.xda-developers.com/show....php?t=2544612

Sent from my SGH-M919 using XDA Premium 4 mobile app
 
Jimcisme
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 16
Join Date: Feb 2008
Quote:
Originally Posted by Android_Monsters View Post
This is how I did that: the file is in the op. http://forum.xda-developers.com/show....php?t=2544612

Sent from my SGH-M919 using XDA Premium 4 mobile app
Went there , did that , did'ent work. It did improve my boot times significantlly though. so Thanks!

Think Ill flash : ROM|TW|4.3|MK2] Modified Stock M919UVUEMK2 V1.4 [CIQ|KNOX-FREE][12/10/2013]
and see how that works...
 
Jimcisme
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 16
Join Date: Feb 2008
Default still no luck

Ok so I have flashed the above rom and even went back to cyanogenmod but Im still having problems. My wifi works fine now , but my phone has no sound...at all, I cannot make or recieve calls.
 
Misterjunky
Old
(Last edited by Misterjunky; 24th December 2013 at 07:01 AM.)
#7  
Misterjunky's Avatar
Senior Member
Thanks Meter 1865
Posts: 3,927
Join Date: Jan 2011
Location: Bakersfield, California

 
DONATE TO ME
Thumbs up re: modem.bin

Quote:
Originally Posted by Jimcisme View Post
Ok so I have flashed the above rom and even went back to cyanogenmod but Im still having problems. My wifi works fine now , but my phone has no sound...at all, I cannot make or recieve calls.
Why not try this easy to follow step by step instructions. This is how I done it myself.

#1: Manually power down the phone by using the power button only.
#2: Start ODIN and put the MODEM.BIN file into ODIN'S PHONE slot.
#3: Put the phone into download mode by using the volume down and power button only.
#4: Plug the USB cable into the phone and into the computer.
#5: Make sure that ODIN'S [COM:xx] lights up.
#6: Un-Check the Auto-Reboot in ODIN and click START.
#7: After its done flashing unplug the usb cable.
#8: Manually power off the phone using the power button.
#9: Wait 20 or so seconds before you power on the phone.

After doing this the MK2 baseband should show up in About Device.

Once you have done this successfully you will no longer have
audio or wifi issues.

Here is the direct download link for the 4.3 MK2 modem.bin:
http://www.mediafire.com/download/1g...l89x/modem.bin

Also if you have never Odin flashed the new full stock
4.3 MK2 Galaxy S4 TW Jellybean firmware/rom then
you don't have knox and you don't need to worry about
it unless you odin flashed the full firmware/rom.

You cannot get KNOX by simply odin flashing the MK2 MODEM.BIN file.

Good luck!
Have a great day, enjoy!

Don't forget it takes less time to click the "THANKS" button than to type "thank you".
(unless you type very fast).



The Following User Says Thank You to Misterjunky For This Useful Post: [ Click to Expand ]
 
baseballfanz
Old
#8  
baseballfanz's Avatar
Senior Member
Thanks Meter 1708
Posts: 6,684
Join Date: Oct 2010
Location: Sugar Land TX
Quote:
Originally Posted by Jimcisme View Post
Ok so I have flashed the above rom and even went back to cyanogenmod but Im still having problems. My wifi works fine now , but my phone has no sound...at all, I cannot make or recieve calls.
You need to get the correct modem on your phone. Flashing ROM will not change the modem so you will continue to have problems.

☞ Sent from here☜🙈🙉🙊
**************
 
Jimcisme
Old
#9  
Junior Member - OP
Thanks Meter 0
Posts: 16
Join Date: Feb 2008
Thumbs up FIXED

Quote:
Originally Posted by baseballfanz View Post
You need to get the correct modem on your phone. Flashing ROM will not change the modem so you will continue to have problems.

☞ Sent from here☜������
Hi, I did manage to get it straightened out.

1. Rooted the Phone with CF-Auto-Root via ODIN Thanks to Chainfire http://forum.xda-developers.com/show....php?t=2294005
2. Did factory reset in recovery.
3. Flashed the 4.3 MK2 modems (plural) from http://www.mediafire.com/download/1g...l89x/modem.bin from the link Misterjunky provided.
4. Flashed this ROM- Build Date: 16.11.2013 -> Region: TMB (USA (T-Mobile)) PDA: M919UVUEMK2 Changelist: 2015522 Android: 4.3
From this page : http://forum.xda-developers.com/show....php?t=2267895 Thanks to AdamLange

It is possible that I did not need to flash the modems as when I flashed the rom it loaded a modem.bin file. But I figured better safe than sorry. This is a rom from samsung as far as I can tell, It took much longer to flash than all the others I flashed. It got rid of the "Kernel is not seandroid enforcing " message I had at the boot loader too. Everything works good so far! I may try to root again later.

Thanks too all for all your help!
 
baseballfanz
Old
#10  
baseballfanz's Avatar
Senior Member
Thanks Meter 1708
Posts: 6,684
Join Date: Oct 2010
Location: Sugar Land TX
Quote:
Originally Posted by Jimcisme View Post

It is possible that I did not need to flash the modems as when I flashed the rom it loaded a modem.bin file. But I figured better safe than sorry. This is a rom from samsung as far as I can tell, It took much longer to flash than all the others I flashed. It got rid of the "Kernel is not seandroid enforcing " message I had at the boot loader too. Everything works good so far! I may try to root again later.

Thanks too all for all your help!
Yes if you use Odin to flash the full firmware it will also flash the modem. If you flash ROM via custom recovery it will not change modem.

☞ Sent from here☜🙈🙉🙊
**************

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes