5,606,253 Members 31,710 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] adb list of devices attached

Tip us?
 
Thermaltake868
Old
(Last edited by Thermaltake868; 6th January 2014 at 01:33 PM.)
#1  
Thermaltake868's Avatar
Senior Member - OP
Thanks Meter 75
Posts: 693
Join Date: Oct 2009
Default [SOLVED] adb list of devices attached

Hi I am trying to flash elitekernel from bootloader fastboot but adb is keep saying that "device not found" when I tried to enter adb devices but he said "list of devices attached", I tried adb kill-server and adb start-server I tried disconnect and connect my device from USB, but nothing helped. Can someone help me what am I doing wrong ?
 
droids@m
Old
#2  
droids@m's Avatar
Senior Member
Thanks Meter 183
Posts: 418
Join Date: Dec 2012
Location: Bangalore
Quote:
Originally Posted by Thermaltake868 View Post
Hi I am trying to flash elitekernel from bootloader fastboot but adb is keep saying that "device not found" when I tried to enter adb devices but he said "list of devices attached", I tried adb kill-server and adb start-server I tried disconnect and connect my device from USB, but nothing helped. Can someone help me what am I doing wrong ?
The device never gets recognized so easily on "adb" whereas in fastboot u would not have any issues.....

since u r going to flash the kernel try "fastboot devices" u ll be able to see ur device

The adb issue will be solved by restarting the PC or by trying to re-install the HTC drivers
Hitting the THANKS can really Help me
The Following User Says Thank You to droids@m For This Useful Post: [ Click to Expand ]
 
Thermaltake868
Old
(Last edited by Thermaltake868; 6th January 2014 at 10:39 AM.)
#3  
Thermaltake868's Avatar
Senior Member - OP
Thanks Meter 75
Posts: 693
Join Date: Oct 2009
Quote:
Originally Posted by droids@m View Post
The device never gets recognized so easily on "adb" whereas in fastboot u would not have any issues.....

since u r going to flash the kernel try "fastboot devices" u ll be able to see ur device

The adb issue will be solved by restarting the PC or by trying to re-install the HTC drivers
I tried fastboot devices and enter but it's just blank nothing

I tried restart PC didn't help, I tried to restart the phone too, and reinstalling drivers nothing.


Even WinDroid HTC One X+ Toolkit won't recognized him when he is in fastboot, but when he is in windows he said Online on status. I really have no idea where did I go wrong I usually always get him into fastboot flash normal.
 
droids@m
Old
#4  
droids@m's Avatar
Senior Member
Thanks Meter 183
Posts: 418
Join Date: Dec 2012
Location: Bangalore
Quote:
Originally Posted by Thermaltake868 View Post
I tried fastboot devices and enter but it's just blank nothing

I tried restart PC didn't help, I tried to restart the phone too, and reinstalling drivers nothing.


Even WinDroid HTC One X+ Toolkit won't recognized him when he is in fastboot, but when he is in windows he said Online on status. I really have no idea where did I go wrong I usually always get him into fastboot flash normal.

I always had the device shown as BLANK on "adb" when using windows

whereas on fastboot I never had that issue.....

can u try this
In windows install this MInimal ADB and Fastboot give a try on"fastboot devices" using this

if not working re install the drivers and try the MInimal ADB and Fastboot again

I am suggesting this because it had worked flawlessly for me with proper drivers and MInimal ADB and Fastboot.......
Hitting the THANKS can really Help me
The Following User Says Thank You to droids@m For This Useful Post: [ Click to Expand ]
 
Thermaltake868
Old
(Last edited by Thermaltake868; 6th January 2014 at 11:22 AM.)
#5  
Thermaltake868's Avatar
Senior Member - OP
Thanks Meter 75
Posts: 693
Join Date: Oct 2009
I never had to install drivers I just installed some adb universal drivers from WinDroid HTC One X+ Toolkit 3.0 it always worked without installing any other drivers, but all of the sudden it's not. I tried now using that MInimal ADB still blank, I will try now to reinstall or uninstall completely that adb universal drivers, and try again.
 
droids@m
Old
#6  
droids@m's Avatar
Senior Member
Thanks Meter 183
Posts: 418
Join Date: Dec 2012
Location: Bangalore
Quote:
Originally Posted by Thermaltake868 View Post
I never had to install drivers I just installed some adb universal drivers from WinDroid HTC One X+ Toolkit 3.0 it always worked without installing any other drivers, but all of the sudden it's not. I tried now using that MInimal ADB still blank, I will try now to reinstall or uninstall completely that adb universal drivers, and try again.
Dude try this USB drivers if nothing works
Hitting the THANKS can really Help me
 
Thermaltake868
Old
(Last edited by Thermaltake868; 6th January 2014 at 11:56 AM.)
#7  
Thermaltake868's Avatar
Senior Member - OP
Thanks Meter 75
Posts: 693
Join Date: Oct 2009
Quote:
Originally Posted by droids@m View Post
Dude try this USB drivers if nothing works
Installation won't start on this one that you gave me. I run it but nothing happends.

P.S
I download AdbDriverInstaller he said that I already have installed adb drivers, don't know how when I uninstall it all.

EDIT:
I manage to get device ID on adb devices in windows, but when I enter bootloader in fastboot he can't recognized him on command "fastboot devices" he said "device not found", and I can't flash kernel becouse he needs to be in fastboot.
 
droids@m
Old
#8  
droids@m's Avatar
Senior Member
Thanks Meter 183
Posts: 418
Join Date: Dec 2012
Location: Bangalore
Quote:
Originally Posted by Thermaltake868 View Post
Installation won't start on this one that you gave me. I run it but nothing happends.

P.S
I download AdbDriverInstaller he said that I already have installed adb drivers, don't know how when I uninstall it all.
Weird I just installed this and Minimal ADB on my PC and checked....


all good here can see the Device on the adb and fastboot..

try again as administrator or something...might help not sure
Hitting the THANKS can really Help me
 
Thermaltake868
Old
#9  
Thermaltake868's Avatar
Senior Member - OP
Thanks Meter 75
Posts: 693
Join Date: Oct 2009
I was thinking all the time that I'm doing something wrong, but every time I did it before it went well, but now I have no idea whats happening, why he won't recognized phone in fastboot, it said fastboot usb, and when I connect him he is always "waiting for device" or "device not found"
 
droids@m
Old
#10  
droids@m's Avatar
Senior Member
Thanks Meter 183
Posts: 418
Join Date: Dec 2012
Location: Bangalore
Quote:
Originally Posted by Thermaltake868 View Post
I was thinking all the time that I'm doing something wrong, but every time I did it before it went well, but now I have no idea whats happening, why he won't recognized phone in fastboot, it said fastboot usb, and when I connect him he is always "waiting for device" or "device not found"
thats sad......but it happens
can u confirm using which u r trying to get the phone on fastboot....android sdk kit or Minimal ADB

and can u see these files in the fastboot folder

ADBWinApi.dll ADB link library for Windows
ADBWinUsbApi.dll ADB link library for Windows

please confirm this....
Hitting the THANKS can really Help me

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes