Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[ROM][4.2.2][CM10.1]ZTE Blade G

OP CCVader13

30th December 2013, 04:49 PM   |  #1  
CCVader13's Avatar
OP Senior Member
Flag Karlovac
Thanks Meter: 137
 
194 posts
Join Date:Joined: Mar 2012
Donate to Me
More
I have decided to make my own port of CM10.1 for the ZTE Blade G but will not fully release it until it starts performing well. Until that moment you can still use the hungariandroid one from this thread.


Linkies with required files:
THIS CWM recovery is required to flash the ROM correctly:
Linky 1

Format /system, /data, /cache partitions and wipe the dalvik cache before proceeding!

CyanogenMod 10.1 for the ZTE Blade G - default english language instead of hungarian
Linky 2

Gapps JB 4.2.2
Linky 3

Touch input fix (flash after flashing the ROM; gapps flashing order is not of importance here)
Linky 4

Known bugs:
Camcorder
Mobile data

Minor bugs (solvable):
Bug: WIFI doesn't work on first start.
Solution: Reboot phone after initial setup.

Bug: I can't touch input doesn't work properly, I see some white pointer dot?
Solution: Flash the fix from linky 4.
Last edited by CCVader13; 3rd January 2014 at 06:59 PM.
The Following 6 Users Say Thank You to CCVader13 For This Useful Post: [ View ]
3rd January 2014, 04:38 PM   |  #2  
KiaTheKing's Avatar
Senior Member
Flag Belgrade
Thanks Meter: 143
 
344 posts
Join Date:Joined: Jun 2013
Donate to Me
More
Quote:
Originally Posted by CCVader13

CyanogenMod 10.1 for the ZTE Blade G



So the guys over there at the hungarian android forums ported CM10.1 for the ZTE Blade G and all credit goes to them.


Disclaimer: I am not responsible for any damage you may inflict to your phone by doing anything using the information from this thread, neither are the devs who originally made this port.

Linkies with required files:
THIS CWM recovery is required to flash the ROM correctly:
Linky 1

Format /system, /data, /cache partitions and wipe the dalvik cache before proceeding!

CyanogenMod 10.1 for the ZTE Blade G - default english language instead of hungarian
Linky 2

Gapps JB 4.2.2
Linky 3

Touch input fix (flash after flashing the ROM; gapps flashing order is not of importance here)
Linky 4

Known bugs:
Camcorder - probably encoding problems; might work using a third party app called "Videocam Illusion".
Mobile data - I don't really understand why this won't work. Several APN settings have been tried but the phone doesn't even bother to send connection requests to the service providers' servers. I am suspecting that it has to do something with our phone showing its baseband as unknown, despite the IMEI being recognized, but I can't get the hang of it

Minor bugs (solvable):
Bug: WIFI doesn't work on first start.
Solution: Reboot phone after initial setup.

Bug: I can't touch input doesn't work properly, I see some white pointer dot?
Solution: Flash the fix from linky 4.

Currently the main problem is the data connection not working and it would be great if a more skilled dev could give me some insight on this problem.

Oh and enjoy!

Hvala tebra!
The Following 6 Users Say Thank You to KiaTheKing For This Useful Post: [ View ]
4th January 2014, 08:50 PM   |  #3  
Junior Member
Flag belgrade
Thanks Meter: 0
 
16 posts
Join Date:Joined: Jan 2013
More
Phone user
Thanks for 4.2.2 rom!! Only i have problem with camera and green screen, everything work good! good job!! Hvala
4th January 2014, 09:20 PM   |  #4  
CCVader13's Avatar
OP Senior Member
Flag Karlovac
Thanks Meter: 137
 
194 posts
Join Date:Joined: Mar 2012
Donate to Me
More
I managed to fix mobile data, but I wont release it here until I come up with some kind of a camcorder fix.

Sent from my ZTE BLADE G using Tapatalk
The Following 2 Users Say Thank You to CCVader13 For This Useful Post: [ View ]
7th January 2014, 04:26 PM   |  #5  
Member
Thanks Meter: 12
 
62 posts
Join Date:Joined: Mar 2011
I'm guessing this won't work on the blade V? I know its a stupid question but i had to ask
8th January 2014, 03:12 AM   |  #6  
CCVader13's Avatar
OP Senior Member
Flag Karlovac
Thanks Meter: 137
 
194 posts
Join Date:Joined: Mar 2012
Donate to Me
More
Nope. Blade V has a different chipset and thus a different kernel. This port is made to work with the stock kernel for blade G.

But I am actually pretty suprised that there are no custom ROMs for the Blade V considering the fact that ZTE has released its kernel sources (as opposed to the blade G, damn them).

Sent from my ZTE BLADE G using Tapatalk
The Following 2 Users Say Thank You to CCVader13 For This Useful Post: [ View ]
15th January 2014, 09:07 PM   |  #7  
szezso's Avatar
Recognized Contributor / Recognized Developer
Flag Budakalász
Thanks Meter: 12,313
 
2,003 posts
Join Date:Joined: May 2012
Donate to Me
More
Dear OP!
I wanna report something. Your work also appreciated, but in fact, you aren't the developer of this ROM. My friend has been working on it for a long time now, and he was, who got CM10.1 working on this device. In the attachments, I included a screenshot. As you can see there, the build place is keeperv85's PC, the person, who made this ROM: http://mobilarena.hu/tag/keeperv85.html So, instead of setting this ROM up as your work, you should give a credit at least for this guy.

Thanks for your understanding!
Attached Thumbnails
Click image for larger version

Name:	Képerny?kép.png
Views:	579
Size:	253.0 KB
ID:	2518038  
16th January 2014, 11:31 AM   |  #8  
CCVader13's Avatar
OP Senior Member
Flag Karlovac
Thanks Meter: 137
 
194 posts
Join Date:Joined: Mar 2012
Donate to Me
More
I believe I've given appropriate credit in the original post and linked to his ROM. I am working on my own build but I never said that this is a ROM made by me and have specificaly stated that this is the version from hungariandroid, so I don't really understand what you want from me?

Sent from my ZTE BLADE G using Tapatalk
18th January 2014, 07:45 PM   |  #9  
szezso's Avatar
Recognized Contributor / Recognized Developer
Flag Budakalász
Thanks Meter: 12,313
 
2,003 posts
Join Date:Joined: May 2012
Donate to Me
More
Quote:
Originally Posted by CCVader13

I believe I've given appropriate credit in the original post and linked to his ROM. I am working on my own build but I never said that this is a ROM made by me and have specificaly stated that this is the version from hungariandroid, so I don't really understand what you want from me?

Sent from my ZTE BLADE G using Tapatalk

I just wanted to say, that you should gave a credit for the original poster. But no matter, this is your decision, but naming this ROM as your "own port" is a bit more, than enough in my opinion.
19th January 2014, 12:59 AM   |  #10  
CCVader13's Avatar
OP Senior Member
Flag Karlovac
Thanks Meter: 137
 
194 posts
Join Date:Joined: Mar 2012
Donate to Me
More
Oh I see. You misunderstood my statement. I said that I started working on my own port, not that this is my own port. If you have just read the sentence to its end, you would've realized that I am actually pointing out that the ROM in this thread is the hungariandroid forums one, bulit by keeperv85

Sent from my ZTE BLADE G using Tapatalk

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes