5,594,386 Members 34,825 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Package File Signature Error help

Tip us?
 
SeanFreund
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
Default [Q] Package File Signature Error help

Hello my name is Sean and I have recently rooted my phone (captivate glide) and installed a custom ROM. Whenever I try to update apps like the AT&T Code Scanner, Qik Video Lite, Andoid Keyboard, or even Google Play itself I receive this error message:

"Package file was not signed correctly. Uninstall the previous copy of the app and try again."

Also when I run certain apps like Spot Hero or Clash of Clans I get the following message:

"Google Play services, which some of your applications rely on, is not supported by your device. Please contact the manufacturer for assistance."

I have searched the forums and found a few instances with similar problems, but the issue was either never resolved or didn't match the problem I was experiencing. I've Googled the problem and a few folks suggested using Titanium Back Up to uninstall the app in question and then re-install, but I have read some users say that they are then unable to re-install the app. I don't want to lose any functionality, so I haven't tried that.

Here is a step-by-step of what I did to my phone:
1) Shutdown my phone and rebooted into download mode with Odin 3.04 running
2) Flash CLOCKWORK MOD RECOVERY 6.0.1.2 (found here)
3) Reboot in download mode
4) Flash stock ICS ROM (found here)
5) Flash Superuser 3.2-RC3-arm-signed.zip (following the instructions found here)
5) Flash GApps.zip for 4.0.4 (found here)
6) Reboot and the phone says it's upgrading Android and optimizing applications
7) Once the phone is booted up and the SD card is done scanning I run into the problem described above

Has anyone encountered this problem before? If so, please share your insights.

Thanks for reading and if you have any suggestions I would welcome the help.
 
claan
Old
#2  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Aug 2007
hello

i remember i had same problem when i was using ics, i think you shoulr flash anotherics gapps from diferent source. I do not remember where i downloaded mine
 
SeanFreund
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
I tried some different gapps and I got some apps like Hangouts to update, but now I receive this message when I try to install Google Play Services:

"Incompatible with other application(s) using the same shared user ID."
 
SeanFreund
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
I did some further looking into this and found that if I wiped my /system data and reflashed my gapps.zipp that seems to work. I installed Youtube first (since it requires Google Play Services) and that took care of everything.

Unfortunately I have lost any progress I may have made in my game apps and have to download/update everything from scratch and reset my ring tones and such, but at least I have a fully functional, rooted phone.
 
SeanFreund
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
Actually I take that back. Google Play Services seems to be cooperating, but now I'm getting the package file signature problem again.
 
SeanFreund
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 5
Join Date: Dec 2013
I resolved the issue by starting over and following Rawr0w0's guide half way down this thread.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes