Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,073 Members 40,623 Now Online
XDA Developers Android and Mobile Development Forum

[MOD][KK] Enable H and H+ icons

Tip us?
 
ilovetorresmo
Old
(Last edited by ilovetorresmo; 7th January 2014 at 09:57 PM.)
#1  
ilovetorresmo's Avatar
Member - OP
Thanks Meter 21
Posts: 34
Join Date: Dec 2013
Default [MOD][KK] Enable H and H+ icons

This mod will enable HSPA and HSPA+ data icons on status bar of Stock US 4.4.2 or UK 4.4.2.
Instructions: Backup your systemui.apk and systemui.odex on /system/priv-app/. Move systemui.apk to /system/priv-app/ and set permissions to rw-r--r--

Screenshots



Hit thanks if useful!
Attached Files
File Type: apk SystemUI.apk - [Click for QR Code] (1.52 MB, 948 views)
The Following 11 Users Say Thank You to ilovetorresmo For This Useful Post: [ Click to Expand ]
 
monchee
Old
#2  
monchee's Avatar
Senior Member
Thanks Meter 38
Posts: 251
Join Date: Jun 2012
Location: Angeles City
Does this fix the bug where in you flash the US Moto G Kitkat Rom to the international Moto G wherein it only shows 3G?


Moto G | XT1032 - 174.44.1.falcon_umts.Retail.en.US - Rooted
HTC One X | SOLD (Gonna miss my HOX.)
Nexus 7 2012 | CM11 KitKat
 
a4t
Old
#3  
a4t's Avatar
Member
Thanks Meter 10
Posts: 60
Join Date: Oct 2009
I just tried this MOD, since my motoG already upgraded to KK 4.4.2, but using repackaged ROM from josalaito.. but it's force closed all the time 😪

Luckily I already made systemUI backup and reflash back that zip to restore and everything's back to normal.

Is this MOD compatible with josalaito custom ROM or not?

sent from motoG kitkat 4.4.2
--
 
plmiller0905
Old
#4  
plmiller0905's Avatar
Senior Member
Thanks Meter 240
Posts: 5,034
Join Date: Apr 2010
Location: Janesville,Wisconsin
So how do one revert back to the stock 3G icon if they so wish?

sent from my little big Moto G
 
ilovetorresmo
Old
#5  
ilovetorresmo's Avatar
Member - OP
Thanks Meter 21
Posts: 34
Join Date: Dec 2013
Oh, forgot to add a line on updater-script to delete systemui.odex. Will udpate as soon as I get home. I use josalaito's rom and it works.

Just extract the apk and move to /system/priv-app/, set permissions to rw-r--r-- and delete systemui.odex
 
a4t
Old
#6  
a4t's Avatar
Member
Thanks Meter 10
Posts: 60
Join Date: Oct 2009
Still not working.. FCing all the time, even odex already removed.

sent from motoG kitkat 4.4.2
--
 
mangusmeister
Old
#7  
Member
Thanks Meter 21
Posts: 64
Join Date: Feb 2012
Same for me. Using 4.4.2 us on UK 16gig moto, boot loader unlocked n rooted. Force close system ui every time.
 
ilovetorresmo
Old
#8  
ilovetorresmo's Avatar
Member - OP
Thanks Meter 21
Posts: 34
Join Date: Dec 2013
Did you guys tried to wipe dalvik cache and reboot? It works fine on mine and on my friend Lucas' Moto G
 
jmoore4294
Old
#9  
Member
Thanks Meter 22
Posts: 66
Join Date: Mar 2009
Location: South Carolina
Worked perfectly for me. Just flashed and rebooted. Didn't need to wipe anything.
 
kykemejia
Old
(Last edited by kykemejia; 9th January 2014 at 04:00 AM.) Reason: Correction
#10  
Senior Member
Thanks Meter 37
Posts: 444
Join Date: Apr 2012
Location: Bogotá
Worked for me, but not change 3G to H+, now only show H+.

Obviously is better now. Thanks.
2014-> Motorola Moto G (16 Gb) XT1032 - CyanogenMod 11 having all!!
2013-> Sony Xperia P LT22I (Sold)
2012-> Samsung Young GT-S5360L(Sold)


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes