Post Reply
Question

[Q] I747 WIFI not working after auto/restart.

26th January 2014, 04:53 PM   |  #1  
Native7i's Avatar
OP Senior Member
Flag Kegalla
Thanks Meter: 10
 
106 posts
Join Date:Joined: Dec 2011
Donate to Me
More
I can flash any custom ROM and everything working correctly.
WIFI connected and working too.

Doing customizations and installing few apps and after a restart (probably need restart) wifi not working.
If I leaved WIFI on state before restart it shows saved networks and won't connect.
Turning on after restart not happening. I had to go back and re-enter to WIFI menu . Then it shows"searching..." WPS, WIFI direct nothing works.
After failed scan it shows saves connections and touching on connection says" Failed to connect to WIFI network." Or WPS failed, Try again in few minutes."

Hard reset or flashing again will workout, but one restart and it all messed up. And tried without doing nothing and restart, it's same.
I collected few logs and attached. And link to short video that exactly happening.
Tried every other ROM and kernels, same result. On stock, it's perfectly fine and working. Aftre bootloader update(yeah, thought it would help) same thing happens. But not with stock ROM; KNOX fear eh. http://forum.xda-developers.com/images/icons/icon10.gif

Living through past two weeks for solution and I'm ended up here.

https://plus.google.com/u/0/photos/1...79839076602088

Rooted
MJB: both bootloader and modem
Beanstalk: current rom





Here how I solved the problem.

First download SQLite debugger from store

From app, navigate to Setting storage & open Setting.db


Click on Global, Name.
From the list choose WiFI Display on.

Click on UPDATE? > value... > 0 from the list or enter value.
If choose to enter the value manually it's same thing, type 0 where cursor blink.
Then click on arrow head on top right so the new popup saying Commit the change and confirm it.

Restart the device and you're good to go with WiFi again without a problem.



Attached Files
File Type: zip logcat.zip - [Click for QR Code] (215.7 KB, 27 views)
Last edited by Native7i; 20th April 2014 at 09:16 AM.
27th January 2014, 04:29 PM   |  #2  
Junior Member
Thanks Meter: 1
 
17 posts
Join Date:Joined: Mar 2013
Try different kernal.
27th January 2014, 09:32 PM   |  #3  
winosxbuntu's Avatar
Senior Member
Flag LA
Thanks Meter: 25
 
200 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by Native7i

I can flash any custom ROM and everything working correctly.
WIFI connected and working too.

Doing customizations and installing few apps and after a restart (probably need restart) wifi not working.
If I leaved WIFI on state before restart it shows saved networks and won't connect.
Turning on after restart not happening. I had to go back and re-enter to WIFI menu . Then it shows"searching..." WPS, WIFI direct nothing works.
After failed scan it shows saves connections and touching on connection says" Failed to connect to WIFI network." Or WPS failed, Try again in few minutes."

Hard reset or flashing again will workout, but one restart and it all messed up. And tried without doing nothing and restart, it's same.
I collected few logs and attached. And link to short video that exactly happening.
Tried every other ROM and kernels, same result. On stock, it's perfectly fine and working. Aftre bootloader update(yeah, thought it would help) same thing happens. But not with stock ROM; KNOX fear eh. http://forum.xda-developers.com/images/icons/icon10.gif

Living through past two weeks for solution and I'm ended up here.

https://plus.google.com/u/0/photos/1...79839076602088

Rooted
MJB: both bootloader and modem
Beanstalk: current rom

trying wiping everything go back to stock 4.3 then reload a 4.4 kitkat rom (A DIFFERENT ROM) and see if that helps
27th January 2014, 11:58 PM   |  #4  
Native7i's Avatar
OP Senior Member
Flag Kegalla
Thanks Meter: 10
 
106 posts
Join Date:Joined: Dec 2011
Donate to Me
More
I tried different ROMs already. No luck there.
Definitely looking for stock now.
For the reason of Knox I'm not sure what stock ROM needed to downloaded on my current state.


Sent from my SAMSUNG-SGH-I747 using Tapatalk

Update:

Seems like no body knows the reason. And answer for this trouble. Thanks anyway.
Last edited by Native7i; 28th January 2014 at 03:29 PM. Reason: Update.
28th January 2014, 05:07 PM   |  #5  
Junior Member
Thanks Meter: 1
 
5 posts
Join Date:Joined: Sep 2011
I am in the exact same boat. I installed the cyanogenmod v11, with kernal 3.4.74-cyanogenmod-gd298491. Wiped data, restored rom, etc. I've reset this phone so many times, I can't remember what all I've done. I did see a thread where users bring up a terminal emulator and type in some lines of commands, and wifi works, until the do a restart. I tried that and it didnt work for me. Luckily I have unlimited data, so I can download over LTE network. I just got a text from ATT saying I am pushing 5GB, and that I may be throttled soon. D@%& you technology!
28th January 2014, 05:31 PM   |  #6  
Native7i's Avatar
OP Senior Member
Flag Kegalla
Thanks Meter: 10
 
106 posts
Join Date:Joined: Dec 2011
Donate to Me
More
Quote:
Originally Posted by jasons239

I am in the exact same boat. I installed the cyanogenmod v11, with kernal 3.4.74-cyanogenmod-gd298491. Wiped data, restored rom, etc. I've reset this phone so many times, I can't remember what all I've done. I did see a thread where users bring up a terminal emulator and type in some lines of commands, and wifi works, until the do a restart. I tried that and it didnt work for me. Luckily I have unlimited data, so I can download over LTE network. I just got a text from ATT saying I am pushing 5GB, and that I may be throttled soon. D@%& you technology!

I couldn't find such thread. Still I'm trying myself figuring out what's going on. Hope myself to find that post soon.

For anyone interested in, another 2 logs here.
Attached Files
File Type: zip Last_kmsg.zip - [Click for QR Code] (42.7 KB, 5 views)
Last edited by Native7i; 28th January 2014 at 06:57 PM. Reason: New logs
29th January 2014, 01:04 AM   |  #7  
Junior Member
Thanks Meter: 1
 
5 posts
Join Date:Joined: Sep 2011
Sorry, I couldn't hunt anything down at work....no wifi on my phone....

Here is the thread I was reading before. Again, its worked for some, but not others. Good luck!

http://forum.xda-developers.com/show...php?p=44742265
29th January 2014, 01:14 AM   |  #8  
theramsey3's Avatar
Senior Member
Thanks Meter: 151
 
353 posts
Join Date:Joined: Jun 2012
You're on 4.3 correct? I had a problem similar to this with wifi I used a different kernel and it fixed it.


Confirm 4.3 and I will give you a link to the one I used.


Sent from my SAMSUNG-SGH-I747 using xda app-developers app
29th January 2014, 04:13 PM   |  #9  
Native7i's Avatar
OP Senior Member
Flag Kegalla
Thanks Meter: 10
 
106 posts
Join Date:Joined: Dec 2011
Donate to Me
More
Quote:
Originally Posted by jasons239

Sorry, I couldn't hunt anything down at work....no wifi on my phone....

Here is the thread I was reading before. Again, its worked for some, but not others. Good luck!

http://forum.xda-developers.com/show...php?p=44742265

Thanks. I'll check it out.

Checked it out, weren't that a i9300? It's worth trying.

Quote:
Originally Posted by theramsey3

You're on 4.3 correct? I had a problem similar to this with wifi I used a different kernel and it fixed it.


Confirm 4.3 and I will give you a link to the one I used.


Sent from my SAMSUNG-SGH-I747 using xda app-developers app

I'd never at official 4.3. Only through customs. Last stock was 4.1.2
Last edited by Native7i; 29th January 2014 at 04:19 PM.
29th January 2014, 04:56 PM   |  #10  
theramsey3's Avatar
Senior Member
Thanks Meter: 151
 
353 posts
Join Date:Joined: Jun 2012
So what is your bootloader version? 4.3 will run on mj2 and mjb one will allow you to use Odin in the future and the other will brick your phone if you use Odin. If you have root access download root checker from play store it will show you which one you have.

Sent from my SAMSUNG-SGH-I747 using xda app-developers app

Post Reply Subscribe to Thread

Tags
bootloader, custom, wifi
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes