5,814,863 Members 48,770 Now Online
XDA Developers Android and Mobile Development Forum

[Solved] Google Sync Error

Tip us?
 
bgumble
Old
(Last edited by bgumble; 18th July 2014 at 11:52 AM.)
#1  
bgumble's Avatar
Senior Member - OP
Thanks Meter 39
Posts: 443
Join Date: Dec 2008
Default [Solved] Google Sync Error

Out of nothing my contact and calendar from google account didn't sync.
  • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

In the sync settings of my google account an error appeared, something like


Sync is currently experiencing problems, it will be back shortly


first: it took me some hours to figure it out
  • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



finally ...



this is the solution / workaround that fixed it for me:
  1. open google calendar

  2. click in menu settings

    (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)



  3. in setting click on your existing gmail account



  4. in the settings of your existing account tab on add account



  5. on the following screen select google



  6. enter now your login and password of your (existing) google account



  7. Open your account in settings, hit menu and sync now

  8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):




Quote:
good to hear it worked

I'd like to ask you to hit the 'thanks' button, as just a 'thanks' is the only honor I get. You'd be the 2nd person after >21.000 views of this thread. Thank you.
Google sync error? CLICK HERE

Device: ..Motorola RAZR HD
ROM: .....cyanogenmod 11.0 nightly
Bootloader: unlocked

Device: ..hTC Desire (hTC Bravo)
ROM: .....Stock Gingerbread (3.14.405.1) ROOT
Kernel: ..snq sense kernel 111118
Radio: ...32.54.00.32U_5.14.05.23
HBoot: ...stock hboot

Retired: hTC Touch HD
(Windows Mobile 6.1)


Sync your files from handy (Pics, MP3, What'sApp ...) online and across computers with dropbox.

click here than you & me get 500MB extra space!
The Following 10 Users Say Thank You to bgumble For This Useful Post: [ Click to Expand ]
 
IMadeYouReadThiso.o
Old
(Last edited by IMadeYouReadThiso.o; 22nd March 2014 at 01:18 PM.) Reason: spelling, add extra writing
#2  
Junior Member
Thanks Meter 4
Posts: 1
Join Date: Mar 2014
Default Sync is currently experiencing problems, it will be back shortly ~FIX~

~For Root Users ~

-First clear Google Play cache and data
-Open Root Explorer or a another similar file explorer
-Find the file named "ect" and open
-For Root Explorer change Mount R/W to Mount R/O
-Long press on the "hosts" file and tap "open in text editor"
-See the IP address xxx.x.x.x Localhost
-Add a "#" before the IP address, e.g - #xxx.x.x.x localhost
-Save and reboot your device
-tested on a Nexus 7 2013 running stock 4.4.2 build KOT49H with ElementalX kernel
-I may have no responsibility if you device becomes bricked, do this at your own risk x.x

I hope this helped ^-^
The Following 4 Users Say Thank You to IMadeYouReadThiso.o For This Useful Post: [ Click to Expand ]
 
amirsh77
Old
#3  
amirsh77's Avatar
Senior Member
Thanks Meter 168
Posts: 401
Join Date: Apr 2011
Location: Kerman
Quote:
Originally Posted by bgumble View Post
Out of nothing my contact and calendar from google account didn't sync.
  • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

In the sync settings of my google account an error appeared, something like


Sync is currently experiencing problems, it will be back shortly


first: it took me some hours to figure it out
  • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



finally ...



this is the solution / workaround that fixed it for me:
  1. open google calendar

  2. click in menu settings

    (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)



  3. in setting click on your existing gmail account



  4. in the settings of your existing account tab on add account



  5. on the following screen select google



  6. enter now your login and password of your (existing) google account



  7. Open your account in settings, hit menu and sync now

  8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):



Quote:
Originally Posted by IMadeYouReadThiso.o View Post
~For Root Users ~

-First clear Google Play cache and data
-Open Root Explorer or a another similar file explorer
-Find the file named "ect" and open
-For Root Explorer change Mount R/W to Mount R/O
-Long press on the "hosts" file and tap "open in text editor"
-See the IP address xxx.x.x.x Localhost
-Add a "#" before the IP address, e.g - #xxx.x.x.x localhost
-Save and reboot your device
-tested on a Nexus 7 2013 running stock 4.4.2 build KOT49H with ElementalX kernel
-I may have no responsibility if you device becomes bricked, do this at your own risk x.x

I hope this helped ^-^
NOT Helped ...
The Following User Says Thank You to amirsh77 For This Useful Post: [ Click to Expand ]
 
bgumble
Old
#4  
bgumble's Avatar
Senior Member - OP
Thanks Meter 39
Posts: 443
Join Date: Dec 2008
Quote:
Originally Posted by amirsh77 View Post
NOT Helped ...
Can you specify? Like your android version, your error, what you did ...
Google sync error? CLICK HERE

Device: ..Motorola RAZR HD
ROM: .....cyanogenmod 11.0 nightly
Bootloader: unlocked

Device: ..hTC Desire (hTC Bravo)
ROM: .....Stock Gingerbread (3.14.405.1) ROOT
Kernel: ..snq sense kernel 111118
Radio: ...32.54.00.32U_5.14.05.23
HBoot: ...stock hboot

Retired: hTC Touch HD
(Windows Mobile 6.1)


Sync your files from handy (Pics, MP3, What'sApp ...) online and across computers with dropbox.

click here than you & me get 500MB extra space!
The Following 2 Users Say Thank You to bgumble For This Useful Post: [ Click to Expand ]
 
amirsh77
Old
#5  
amirsh77's Avatar
Senior Member
Thanks Meter 168
Posts: 401
Join Date: Apr 2011
Location: Kerman
Quote:
Originally Posted by bgumble View Post
Can you specify? Like your android version, your error, what you did ...
I'm on 4.4.3 Nexus 5, I got error "Sync is currently experiencing problems. It will be back shortly! " when I want to sync just google contacts, other google options like calendar and keep are synching fine.
 
bgumble
Old
#6  
bgumble's Avatar
Senior Member - OP
Thanks Meter 39
Posts: 443
Join Date: Dec 2008
Quote:
Originally Posted by amirsh77 View Post
I'm on 4.4.3 Nexus 5, I got error "Sync is currently experiencing problems. It will be back shortly! " when I want to sync just google contacts, other google options like calendar and keep are synching fine.
If I were you I would remove the whole google account from the phone and delete all contacts. Boot into recovery, wipe cache, reboot and add google account.

But first of all I would make a nandroid backup!

Good luck
Google sync error? CLICK HERE

Device: ..Motorola RAZR HD
ROM: .....cyanogenmod 11.0 nightly
Bootloader: unlocked

Device: ..hTC Desire (hTC Bravo)
ROM: .....Stock Gingerbread (3.14.405.1) ROOT
Kernel: ..snq sense kernel 111118
Radio: ...32.54.00.32U_5.14.05.23
HBoot: ...stock hboot

Retired: hTC Touch HD
(Windows Mobile 6.1)


Sync your files from handy (Pics, MP3, What'sApp ...) online and across computers with dropbox.

click here than you & me get 500MB extra space!
The Following 2 Users Say Thank You to bgumble For This Useful Post: [ Click to Expand ]
 
avraum
Old
#7  
Junior Member
Thanks Meter 1
Posts: 9
Join Date: Feb 2011
thanx mannnnnn!!! your solution workd for me.

Quote:
Originally Posted by bgumble View Post
Out of nothing my contact and calendar from google account didn't sync.
  • (I reconfigured some time ago my google talk / hangouts, but I'm not sure that this was the reason for this google sync error)

In the sync settings of my google account an error appeared, something like


Sync is currently experiencing problems, it will be back shortly


first: it took me some hours to figure it out
  • nothing in this forum mentioned before helped like deleting account and google apps, wiping cache, rebooting etc.



finally ...



this is the solution / workaround that fixed it for me:
  1. open google calendar

  2. click in menu settings

    (here are only screenshots from my german android 4.1.2, but you should be able to follow the steps)



  3. in setting click on your existing gmail account



  4. in the settings of your existing account tab on add account



  5. on the following screen select google



  6. enter now your login and password of your (existing) google account



  7. Open your account in settings, hit menu and sync now

  8. enjoy and hit THANKS (or even better click on link in my signature to join dropbox) if it helped and looks like this (in settings / google):



 
amirsh77
Old
#8  
amirsh77's Avatar
Senior Member
Thanks Meter 168
Posts: 401
Join Date: Apr 2011
Location: Kerman
Quote:
Originally Posted by bgumble View Post
If I were you I would remove the whole google account from the phone and delete all contacts. Boot into recovery, wipe cache, reboot and add google account.

But first of all I would make a nandroid backup!

Good luck
Thanks, It is working now!!! but still a question : what kind of bug this is ?!!
 
bgumble
Old
#9  
bgumble's Avatar
Senior Member - OP
Thanks Meter 39
Posts: 443
Join Date: Dec 2008
Quote:
Originally Posted by amirsh77 View Post
Thanks, It is working now!!! but still a question : what kind of bug this is ?!!
Great that it helped

Maybe it's an error in the database on the phone, but that's speculative.
Google sync error? CLICK HERE

Device: ..Motorola RAZR HD
ROM: .....cyanogenmod 11.0 nightly
Bootloader: unlocked

Device: ..hTC Desire (hTC Bravo)
ROM: .....Stock Gingerbread (3.14.405.1) ROOT
Kernel: ..snq sense kernel 111118
Radio: ...32.54.00.32U_5.14.05.23
HBoot: ...stock hboot

Retired: hTC Touch HD
(Windows Mobile 6.1)


Sync your files from handy (Pics, MP3, What'sApp ...) online and across computers with dropbox.

click here than you & me get 500MB extra space!
 
CoNsPiRiSiZe
Old
#10  
CoNsPiRiSiZe's Avatar
Senior Member
Thanks Meter 265
Posts: 1,714
Join Date: Jul 2010
Location: Roseville
Finally someone has posted a solution to this problem. I just tried this on my stock non rooted AT&T S4 and although I went through the steps when I go to login to my account it says
"couldn't sign in
There was a problem connecting to the Google servers.
Please try again later"

But - it no longer gives the sync errors instead looks to be syncing on my Google contacts. It says "cancel sync" where it is usually says sync now. Hopefully it does sync. If not.... what other options do I have?!

---------- Post added at 06:24 PM ---------- Previous post was at 05:30 PM ----------

Correction to my previous post - the fix does not work on my phone running ATT Touchwiz 4.4.2


Anyone know how to fix that wont wipe the contacts not synced yet? @bgumble
Did someone reply to your post? Does it matter if they're right? No! They volunteered their time to try to help, it's a community, hit the thanks button for them!



Tags
google, google account, google sync error, sync
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes