Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,768,845 Members 50,785 Now Online
XDA Developers Android and Mobile Development Forum

Error 927, And All Potential Solutions Have Failed...

Tip us?
 
abarax
Old
#1  
Member - OP
Thanks Meter 3
Posts: 76
Join Date: Jan 2012
Default Error 927, And All Potential Solutions Have Failed...

Here it is in a nutshell: Error 927 on ANY download, any app, any game, be it paid or free, on my Nexus 7 (2013) FHD. I've done the following:

- Cleared the data and cache for the Google Play Store, Download Manager, and Google Services Framework.

- Uninstalled updates for the Google Play Store and Google Services Framework.

- Deleted and re-added my Google account.

- Rebooted.

- Hard reset.

- Downgraded to 4.3 and re-upgraded to 4.4.2.

- Tried to download the apps and games from the Google Play website, and get "An unexpected error has occured. Please try again later."

- Changed the filter and proxy settings on my Cisco router.

- Switched to LTE, and... same thing.

- Created another Google account, and it worked, but I will NOT be forced to re-purchase the apps I've spent nearly $80.00 on over the years, or upload my music collection to Google Music again.

- Reached out to Google for help, and... crickets.

I'm at the end of my rope. If this isn't resolved soon, I'm returning the Nexus to Wal-Mart. I've NEVER had this sort of issue before, even with my first-generation Nexus 7. I've had Android tablets since my Motorola Xoom awhile back. I've ALWAYS had Android tablets. I'd hate to have to abandon Android because of this idiocy, but I may have to do so. I don't want to have to go with Apple for both my smartphone and tablet, but it's starting to look that way.

If anyone has any suggestions that aren't listed above, please, help me out. I love my Nexus 7, but without apps and games, it's pretty worthless.

Thanks in advance.
 
Pandae
Old
#2  
Pandae's Avatar
Senior Member
Thanks Meter 45
Posts: 184
Join Date: Dec 2013
Normally deleting and adding back the Google account is a solution for Play Store problems, but as you said, you tried that. Some have reported that error 927 is because of a network connection error. How is web browsing? YouTube?

Quote:
Originally Posted by abarax View Post
- Downgraded to 4.3 and re-upgraded to 4.4.2.
How did you do that? Did you download the 4.3 ROM to flash it? Did you unlock and flash a custom recovery?

When all else fails, flash the stock ROM, especially with your downgrading and upgrading. Google's files include a "flash-all.bat" within that will wipe everything and flash the stock ROM and recovery.

https://developers.google.com/androi...s/images#razor
 
abarax
Old
#3  
Member - OP
Thanks Meter 3
Posts: 76
Join Date: Jan 2012
Quote:
Originally Posted by Pandae View Post
Normally deleting and adding back the Google account is a solution for Play Store problems, but as you said, you tried that. Some have reported that error 927 is because of a network connection error. How is web browsing? YouTube?

All web browsing and pre-installed apps work just fine. Just any attempts to update those apps, or install any other apps from Google Play, fail with error 927.

How did you do that? Did you download the 4.3 ROM to flash it? Did you unlock and flash a custom recovery?



When all else fails, flash the stock ROM, especially with your downgrading and upgrading. Google's files include a "flash-all.bat" within that will wipe everything and flash the stock ROM and recovery.



https://developers.google.com/androi...s/images#razor
I actually have flashed the stock ROMs, from the original 4.3 to 4.4.2, with the exact same results. I've also made certain not to unlock the bootloader and to not root as to recreate the OOB experience as well. At this point, my options are exhausted.
 
Dexxon
Old
#4  
Dexxon's Avatar
Member
Thanks Meter 17
Posts: 83
Join Date: Mar 2013
Location: Dörentrup
Quote:
Originally Posted by abarax View Post
I actually have flashed the stock ROMs, from the original 4.3 to 4.4.2, with the exact same results. I've also made certain not to unlock the bootloader and to not root as to recreate the OOB experience as well. At this point, my options are exhausted.
Are you able to install apps on another device with the same account? If not it may be a problem with your account...
Trust me, I'm an engineer.
The Following User Says Thank You to Dexxon For This Useful Post: [ Click to Expand ]
 
zombieguy85
Old
#5  
zombieguy85's Avatar
Senior Member
Thanks Meter 43
Posts: 278
Join Date: Feb 2011
Location: Waco ,tx
Quote:
Originally Posted by Dexxon View Post
Are you able to install apps on another device with the same account? If not it may be a problem with your account...
I know his pain I have flashed reflashed installed stock and im using a atrix 2 with ics 4.0.4

im hoping its a google server problem and it will be fixed
 
parmend
Old
#6  
parmend's Avatar
Senior Member
Thanks Meter 58
Posts: 840
Join Date: Apr 2010
Location: Fort Worth
I was having the same problem for the last two days and I went to settings/Google account and noticed there was a sync error with sound search for Google play and I manually synced it and now apps download .

Sent from my Nexus 5 using Tapatalk
 
zombieguy85
Old
#7  
zombieguy85's Avatar
Senior Member
Thanks Meter 43
Posts: 278
Join Date: Feb 2011
Location: Waco ,tx
I went into my account removed my devices from it on the web and signed in on my phone now it works

Sent from my MB865 using Tapatalk
 
dawiseguy77
Old
#8  
dawiseguy77's Avatar
Senior Member
Thanks Meter 134
Posts: 856
Join Date: Dec 2010
I've been having the exact same issue for 4 days. Regardless of rom, phone, or gmail account I use. I've done every wipe format imaginable even Odin as I have a Samsung phone same issue. Now I cant even get any Google apps to connect at all. Such as Google plus play store YouTube etc...Google says never heard of it before sorry.
 
mightykc
Old
#9  
Senior Member
Thanks Meter 99
Posts: 635
Join Date: May 2007
Location: Fort Worth, TX
Quote:
Originally Posted by dawiseguy77 View Post
I've been having the exact same issue for 4 days. Regardless of rom, phone, or gmail account I use. I've done every wipe format imaginable even Odin as I have a Samsung phone same issue. Now I cant even get any Google apps to connect at all. Such as Google plus play store YouTube etc...Google says never heard of it before sorry.
I'm having the exact same problem now for a few days. I called Google support and they are aware of the problem and had no resolution. I was told too bad basically.

Out of curiosity, for those having this issue, did you upgrade to a 4.4.2 ROM?
 
dawiseguy77
Old
#10  
dawiseguy77's Avatar
Senior Member
Thanks Meter 134
Posts: 856
Join Date: Dec 2010
I updated to stock rooted 4.3 galaxy note 2 Verizon and it happens on all of my gmail accounts too

Sent from my SCH-I605 using Tapatalk

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Intel Partners with Unity to Support Android on Intel-Based Devices

Intel, largely known for their long-standing reputation as the king of … more

Device Review: Samsung Gear Live

Recently, Google announced Android Wear to the world. Android Wear is the Android-based initiative from … more

Forums Added for the Nvidia Shield Tablet and Sharp Aquos Crystal

Just a few days ago, wetook an in depth look at theNvidia Shield Tabletand … more

[OTA Captured] Android 4.4.3 Lands on European HTC One M7

The secound release of the Android L Developer Previewmay be the new hotness for … more