Default [Q] AT&T E970 Internal Storage Read-only

After updating my AT&T E970 to 4.1.2 via OTA, the internal storage of my phone became read-only. Also the camera stopped working. From my research, it seems the only way to fix this is via rooting the device. However, I've tried frameroot and ZV9-ZVB-Universal-Root.zip but did not have any lock. With ZV9, I know the issue is the /sdcard folder is not accessible. I also tried to run mount from Terminal Emulator, it seems the internal storage is not mounted at all.

Finally, after running out of ideas, I put my phone into download mode and flash teenybin in LGNPST. I got into a reboot loop so I had to flashed it back to stock 20j.

Found this post on how to fix the camera issue: http://forum.xda-developers.com/show....php?t=2146816
But I was not able to flashing 11c rom (bootup is stuck at AT&T screen). Had to revert back to stock 20j.
I also tried using adb to reboot into bootloader and fastboot mode, but the phone just reboot itself without going into bootloader mode.


I would really appreciate if someone can shed some light on how to solve this. Much obliged.


Baseboard version - APQ8064/MDM9x15M
Kernal version 3.4.0
Build Number JZO54K
Software Version E97020j