Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,775 Members 40,818 Now Online
XDA Developers Android and Mobile Development Forum

WI-FI hotspot tethering not working

Tip us?
 
fakhri
Old
(Last edited by fakhri; 15th February 2012 at 09:20 AM.)
#1  
Senior Member - OP
Thanks Meter 25
Posts: 138
Join Date: Aug 2007
Default WI-FI hotspot tethering not working

Hi, I'm using an unlocked Samsung i777 outside the US. But the fact that wifi tethering is not working. Every time when I try to enable it, it says "mobile data not available or invalid sim".

3G/HSDPA connecton fine and SIMcard has a data plan and I can even use usb tethering.
How can I make it work? Phone is rooted.
I am using hellraised stock Rom XWLA4. When was UCKH7 also not working.
In system/app have 3 app wifi 1.0, wifi sharing 1.0, wifi sharing manager 1.0. I tried to freeze them, no luck.
Thanks.
 
Entropy512
Old
#2  
Senior Recognized Developer
Thanks Meter 24112
Posts: 13,135
Join Date: Aug 2007
Location: Owego, NY

 
DONATE TO ME
Either wifi tethering is broken on XWLA4 (I haven't played with it myself yet), or something about the CSC or apns-conf.xml doesn't work with your carrier.

Hellraiser is designed under the assumption that only AT&T customers would subject themselves to the carrier-mangling of the I777 and as such, includes an AT&T-tuned CSC. There's a possibility that you need to remove all of the CSC files from the Hellraiser zip and wipe/reflash. It's either that or XWLA4 is busted.
*so much sig updating needed*

My Github profile - Some Android stuff, some AVR stuff

An excellent post on "noobs vs. developers"

A few opinions on kernel development "good practices"

Note: I have chosen not to use XDA's "friends" feature - I will reject all incoming "friend" requests.

Code:
<MikeyMike01> Smali is a spawn of hell
<shoman94> ^^^ +!
Code:
<Entropy512> gotta be careful not to step on each other's work.  :)
<Bumble-Bee> thats true
<jerdog> compeete for donations
The Following User Says Thank You to Entropy512 For This Useful Post: [ Click to Expand ]
 
gireeshtty9
Old
#3  
gireeshtty9's Avatar
Senior Member
Thanks Meter 45
Posts: 165
Join Date: Jan 2011
Location: Bangalore
Hahah lol...dud even I had exactly the same concern. Its not a big problem Jus download FoxFi from Android Market and voila! It will take away ur pain It enables the WiFi hotspot tethering like a charm without any problem. Its free..Jus type the above name in Android market and install. Then open the app and touch on Activate WiFi hotspot. Its done. Let me know bout it. TC.

---------- Post added at 03:06 PM ---------- Previous post was at 03:00 PM ----------

Quote:
Originally Posted by Entropy512 View Post
Either wifi tethering is broken on XWLA4 (I haven't played with it myself yet), or something about the CSC or apns-conf.xml doesn't work with your carrier.

Hellraiser is designed under the assumption that only AT&T customers would subject themselves to the carrier-mangling of the I777 and as such, includes an AT&T-tuned CSC. There's a possibility that you need to remove all of the CSC files from the Hellraiser zip and wipe/reflash. It's either that or XWLA4 is busted.
You are making it more complicated for him. Its jus an app away bro. He is trying to go in his phones Settings->Wireless And Networks->Tethering and portable hotspot and then trying to enable it. Its not working. But by using FoxFi app its enabled and works perfectly
The Following 2 Users Say Thank You to gireeshtty9 For This Useful Post: [ Click to Expand ]
 
fakhri
Old
#4  
Senior Member - OP
Thanks Meter 25
Posts: 138
Join Date: Aug 2007
Quote:
Originally Posted by gireeshtty9 View Post
[/COLOR]

You are making it more complicated for him. Its jus an app away bro. He is trying to go in his phones Settings->Wireless And Networks->Tethering and portable hotspot and then trying to enable it. Its not working. But by using FoxFi app its enabled and works perfectly
Sory, not working! Showing "Fail to start Hotspot. Your phone is not yet supported by FoxFi".
 
fakhri
Old
#5  
Senior Member - OP
Thanks Meter 25
Posts: 138
Join Date: Aug 2007
Quote:
Originally Posted by Entropy512 View Post
Either wifi tethering is broken on XWLA4 (I haven't played with it myself yet), or something about the CSC or apns-conf.xml doesn't work with your carrier.

Hellraiser is designed under the assumption that only AT&T customers would subject themselves to the carrier-mangling of the I777 and as such, includes an AT&T-tuned CSC. There's a possibility that you need to remove all of the CSC files from the Hellraiser zip and wipe/reflash. It's either that or XWLA4 is busted.
You are the best!!! Thank You!!! Working fine!!!
 
Entropy512
Old
#6  
Senior Recognized Developer
Thanks Meter 24112
Posts: 13,135
Join Date: Aug 2007
Location: Owego, NY

 
DONATE TO ME
Quote:
Originally Posted by gireeshtty9 View Post
Hahah lol...dud even I had exactly the same concern. Its not a big problem Jus download FoxFi from Android Market and voila! It will take away ur pain It enables the WiFi hotspot tethering like a charm without any problem. Its free..Jus type the above name in Android market and install. Then open the app and touch on Activate WiFi hotspot. Its done. Let me know bout it. TC.

---------- Post added at 03:06 PM ---------- Previous post was at 03:00 PM ----------



You are making it more complicated for him. Its jus an app away bro. He is trying to go in his phones Settings->Wireless And Networks->Tethering and portable hotspot and then trying to enable it. Its not working. But by using FoxFi app its enabled and works perfectly
Third-party tethering apps are not a solution unless there is no way to fix native tethering. Most of not all of them put the device into adhoc mode, which is incompatible with many devices.
*so much sig updating needed*

My Github profile - Some Android stuff, some AVR stuff

An excellent post on "noobs vs. developers"

A few opinions on kernel development "good practices"

Note: I have chosen not to use XDA's "friends" feature - I will reject all incoming "friend" requests.

Code:
<MikeyMike01> Smali is a spawn of hell
<shoman94> ^^^ +!
Code:
<Entropy512> gotta be careful not to step on each other's work.  :)
<Bumble-Bee> thats true
<jerdog> compeete for donations
 
gorgy76
Old
(Last edited by gorgy76; 24th July 2012 at 10:51 AM.)
#7  
gorgy76's Avatar
Senior Member
Thanks Meter 39
Posts: 266
Join Date: Nov 2010
Quote:
Originally Posted by Entropy512 View Post
Third-party tethering apps are not a solution unless there is no way to fix native tethering. Most of not all of them put the device into adhoc mode, which is incompatible with many devices.

I do agree, I have tried foxfi before but it will hang and force close uninstalled and reinstalled the app with same results. I have uninstalled tethering provision app on rooted stock ics but then again when I start the native wifi hotspot it just hang for several seconds the force close saying the application setting has stopped. Now I just remember installing this foxfi app again upon reading this thread and am now happy it works and I can now tether thru wifi hotspot with my phone. Having a solution to the native phone wifi hotspot though is pretty sweet. I don't know if the uninstalling of the tethering provision app has help but at least I have a functional wifi hotspot now.
Shostock Rom with Katoonz...just awesome..........
SGS4 i337
 
Stackman1
Old
#8  
Member
Thanks Meter 4
Posts: 58
Join Date: Apr 2012
Quote:
Originally Posted by gorgy76 View Post
I do agree, I have tried foxfi before but it will hang and force close uninstalled and reinstalled the app with same results. I have uninstalled tethering provision app on rooted stock ics but then again when I start the native wifi hotspot it just hang for several seconds the force close saying the application setting has stopped. Now I just remember installing this foxfi app again upon reading this thread and am now happy it works and I can now tether thru wifi hotspot with my phone. Having a solution to the native phone wifi hotspot though is pretty sweet. I don't know if the uninstalling of the tethering provision app has help but at least I have a functional wifi hotspot now.
I was searching for answers for my HotSpot problem and found this thread.....I'm piggy backing because it remains open even though maybe resolved - hope that is ok?

I couldn't seem to get my Hotspot to work and so I downloaded FoxFi. It seems to send a signal fine, and my iPad sees the SSID fine. My phone shows Connected: my mac address- duration - ipad's ip address but when I try to go to a web site my ipad show the following error dialog:

Cannot Open Page
Safari cannot open the page because it is not connected to the internet


Thoughts anyone?
Phone: ATT Samsung Galaxy S2 I777
Android version: 4.1.2
Kernel version: 3.0.31-Jeboo_Kernel_v2.3a+none @ubuntu #67
Baseband version: I777UCLL6
Build number: XWLSN-SHOstock-v3.0.2
 
Phalanx7621
Old
#9  
Phalanx7621's Avatar
Senior Member
Thanks Meter 2046
Posts: 4,452
Join Date: Jul 2011
Location: Delaware
Yer not asking us to help you trouble shoot something that isn't even running the Android operating system are you? Cause obviously that'd be silly to do in a forum like this. Does the tethering work with your computer? If so its a problem with the Apple product you're talking about and should be addressed in their forums.

Sent from my SAMSUNG-SGH-I777 using Tapatalk 2

Phones: Samsung Galaxy S II, Motorola Atrix[retired]
 
Stackman1
Old
#10  
Member
Thanks Meter 4
Posts: 58
Join Date: Apr 2012
Quote:
Originally Posted by Phalanx7621 View Post
Yer not asking us to help you trouble shoot something that isn't even running the Android operating system are you? Cause obviously that'd be silly to do in a forum like this. Does the tethering work with your computer? If so its a problem with the Apple product you're talking about and should be addressed in their forums.

Sent from my SAMSUNG-SGH-I777 using Tapatalk 2
Well, when i use my native Android Wi-Fi Hotspot the phone says it is an active hotspot and my iPad does connect, but I get the same error message when I try and browse the net:

Cannot Open Page
Safari cannot open the page because it is not connected to the internet


I would naturally prefer to use the native mode.....any help with that?
Thanks in advance
Phone: ATT Samsung Galaxy S2 I777
Android version: 4.1.2
Kernel version: 3.0.31-Jeboo_Kernel_v2.3a+none @ubuntu #67
Baseband version: I777UCLL6
Build number: XWLSN-SHOstock-v3.0.2

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes