Post Reply

Question New ROM building error.

OP bgiesing

14th September 2013, 03:04 PM   |  #1  
bgiesing's Avatar
OP Senior Member
Flag Union, MO
Thanks Meter: 413
 
359 posts
Join Date:Joined: Nov 2010
Donate to Me
More
I am trying to build my own custom ROM based on PAC-man. However, I am running into a few build issues.

Here is the error:
Code:
make: *** No rule to make target `/home/brandon/WORKING_FAMIGO/out/target/common/obj/JAVA_LIBRARIES/android_stubs_current_intermediates/classes.jar', needed by `/home/brandon/WORKING_FAMIGO/out/target/common/obj/APPS/Calculator_intermediates/classes-full-debug.jar'.  Stop.
And attached below is the full terminal output.

Also here is the code itself: https://github.com/FamigoROM/android
Last edited by bgiesing; 15th December 2013 at 10:08 PM.
1st January 2014, 06:37 PM   |  #2  
espmartin's Avatar
Senior Member
Flag Central Valley, CA
Thanks Meter: 927
 
575 posts
Join Date:Joined: Apr 2012
Donate to Me
More
Quote:
Originally Posted by dotmaniac

I am trying to build my own custom ROM based on PAC-man. However, I am running into a few build issues.

Here is the error:

Code:
make: *** No rule to make target `/home/brandon/WORKING_FAMIGO/out/target/common/obj/JAVA_LIBRARIES/android_stubs_current_intermediates/classes.jar', needed by `/home/brandon/WORKING_FAMIGO/out/target/common/obj/APPS/Calculator_intermediates/classes-full-debug.jar'.  Stop.
And attached below is the full terminal output.

Also here is the code itself: https://github.com/FamigoROM/android

Hey Dotmaniac,
Did you ever resolve this? I'm having this same error building AOKP on my HTC Desire HD (ace)
1st January 2014, 07:52 PM   |  #3  
bgiesing's Avatar
OP Senior Member
Flag Union, MO
Thanks Meter: 413
 
359 posts
Join Date:Joined: Nov 2010
Donate to Me
More
Quote:
Originally Posted by espmartin

Hey Dotmaniac,
Did you ever resolve this? I'm having this same error building AOKP on my HTC Desire HD (ace)

Nope...

Sent from my Nexus 7 using Tapatalk
1st January 2014, 08:16 PM   |  #4  
espmartin's Avatar
Senior Member
Flag Central Valley, CA
Thanks Meter: 927
 
575 posts
Join Date:Joined: Apr 2012
Donate to Me
More
Google search suggests java version issues, but I've verified I'm running it as recommended... Frustrating!

Android 4.2.2/AOKP built from source
1st January 2014, 11:44 PM   |  #5  
SMillerNL's Avatar
Recognized Contributor
Flag Lisse
Thanks Meter: 1,053
 
3,245 posts
Join Date:Joined: Sep 2011
Donate to Me
More
Can you post the full log?
2nd January 2014, 05:13 AM   |  #6  
espmartin's Avatar
Senior Member
Flag Central Valley, CA
Thanks Meter: 927
 
575 posts
Join Date:Joined: Apr 2012
Donate to Me
More
Quote:
Originally Posted by SMillerNL

Can you post the full log?

I'll post on pastbin asap.

FYI: I get this same exact error when I build just the calc module as such:
mmm packages/apps/Calculator

Android 4.2.2/AOKP built from source

---------- Post added at 09:13 PM ---------- Previous post was at 08:55 PM ----------

Here's the full build log:
http://pastebin.com/ScKDbeej

And here's the full error when just building Calc module (pastbin too):
Code:
                 
  1. martin@martin-desktop:~/SchutzhundAOKP$ . build/envsetup.sh && lunch aokp_ace-userdebug && mmm packages/apps/Calculator including device/htc/ace/vendorsetup.sh including vendor/aokp/vendorsetup.sh including sdk/bash_completion/adb.bash ============================================ PLATFORM_VERSION_CODENAME=REL PLATFORM_VERSION=4.4.2 TARGET_PRODUCT=aokp_ace TARGET_BUILD_VARIANT=userdebug TARGET_BUILD_TYPE=release TARGET_BUILD_APPS= TARGET_ARCH=arm TARGET_ARCH_VARIANT=armv7-a-neon TARGET_CPU_VARIANT=cortex-a8 HOST_ARCH=x86 HOST_OS=linux HOST_OS_EXTRA=Linux-3.8.0-35-generic-x86_64-with-Ubuntu-13.10-saucy HOST_BUILD_TYPE=release BUILD_ID=KOT49H OUT_DIR=/home/martin/SchutzhundAOKP/out ============================================ ============================================ PLATFORM_VERSION_CODENAME=REL PLATFORM_VERSION=4.4.2 TARGET_PRODUCT=aokp_ace TARGET_BUILD_VARIANT=userdebug TARGET_BUILD_TYPE=release TARGET_BUILD_APPS= TARGET_ARCH=arm TARGET_ARCH_VARIANT=armv7-a-neon TARGET_CPU_VARIANT=cortex-a8 HOST_ARCH=x86 HOST_OS=linux HOST_OS_EXTRA=Linux-3.8.0-35-generic-x86_64-with-Ubuntu-13.10-saucy HOST_BUILD_TYPE=release BUILD_ID=KOT49H OUT_DIR=/home/martin/SchutzhundAOKP/out ============================================ make: Entering directory `/home/martin/SchutzhundAOKP' build/core/Makefile:43: warning: overriding commands for target `/home/martin/SchutzhundAOKP/out/target/product/ace/system/etc/permissions/android.software.live_wallpaper.xml' build/core/Makefile:43: warning: ignoring old commands for target `/home/martin/SchutzhundAOKP/out/target/product/ace/system/etc/permissions/android.software.live_wallpaper.xml' PRODUCT_COPY_FILES device/htc/ace/keylayout/keylayout/AVRCP.kl:system/usr/keylayout/AVRCP.kl ignored. PRODUCT_COPY_FILES device/htc/ace/keylayout/keylayout/qwerty.kl:system/usr/keylayout/qwerty.kl ignored. build/core/Makefile:43: warning: overriding commands for target `/home/martin/SchutzhundAOKP/out/target/product/ace/system/etc/AudioBTID.csv' build/core/Makefile:43: warning: ignoring old commands for target `/home/martin/SchutzhundAOKP/out/target/product/ace/system/etc/AudioBTID.csv' PRODUCT_COPY_FILES vendor/aokp/prebuilt/bootanimation/bootanimation_480_800.zip:system/media/bootanimation.zip ignored. No private recovery resources for TARGET_DEVICE ace make: *** No rule to make target `/home/martin/SchutzhundAOKP/out/target/common/obj/JAVA_LIBRARIES/android_stubs_current_intermediates/classes.jar', needed by `/home/martin/SchutzhundAOKP/out/target/common/obj/APPS/Calculator_intermediates/classes-full-debug.jar'. Stop. make: Leaving directory `/home/martin/SchutzhundAOKP' martin@martin-desktop:~/SchutzhundAOKP$
31st January 2014, 01:54 AM   |  #7  
black@pirate's Avatar
Senior Member
Thanks Meter: 200
 
337 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by espmartin

Google search suggests java version issues, but I've verified I'm running it as recommended... Frustrating!

Android 4.2.2/AOKP built from source

I'm also having exactly this error. And it is really frustrating
31st January 2014, 02:21 AM   |  #8  
espmartin's Avatar
Senior Member
Flag Central Valley, CA
Thanks Meter: 927
 
575 posts
Join Date:Joined: Apr 2012
Donate to Me
More
Quote:
Originally Posted by black@pirate

I'm also having exactly this error. And it is really frustrating

My fix was to use different repos.

Using my own Android Open Kang Project - (4.4.2 Kitkat) build
31st January 2014, 02:26 AM   |  #9  
black@pirate's Avatar
Senior Member
Thanks Meter: 200
 
337 posts
Join Date:Joined: Aug 2013
Quote:
Originally Posted by espmartin

My fix was to use different repos.

Using my own Android Open Kang Project - (4.4.2 Kitkat) build

What do you mean by different repos? Device? Kernel? or Just Packages app?
31st January 2014, 03:08 AM   |  #10  
espmartin's Avatar
Senior Member
Flag Central Valley, CA
Thanks Meter: 927
 
575 posts
Join Date:Joined: Apr 2012
Donate to Me
More
I've kept the same device/kernels

Using my own Android Open Kang Project - (4.4.2 Kitkat) build

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Android by ThreadRank