Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,798 Members 50,003 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Wrong Song Art in Music Player

Tip us?
 
ASKnASK
Old
#1  
ASKnASK's Avatar
Senior Member - OP
Thanks Meter 9
Posts: 150
Join Date: Apr 2011
Location: Islamabad
Unhappy [Q] Wrong Song Art in Music Player

Guys, I'm obsessed with keeping a well-organized music library.
I add album art, lyrics and all details to each and every song I download.
I use TagNRaname to achieve this.

Now the problem. On both the Music Player and UberMusic (or any other player), some of my songs display incorrect album art. Like there one of two images that are repeated on several songs, even though those songs have separate embedded album art!

Please help. How do I solve this!
 
Lunchbox115
Old
#2  
Lunchbox115's Avatar
Senior Member
Thanks Meter 127
Posts: 670
Join Date: Jan 2011
Location: Salzburg, Austria

 
DONATE TO ME
Try 'mp3tag' to add song details.

http://www.mp3tag.de/en/


Klick to get 2,25GB for your new Dropbox-account! http://db.tt/ky8ig4I


Please press the 'THANKS'-button if this article helped you!
 
ASKnASK
Old
#3  
ASKnASK's Avatar
Senior Member - OP
Thanks Meter 9
Posts: 150
Join Date: Apr 2011
Location: Islamabad
The details are added fine!

Its the phone that messes them up!

I have copied the same music to my iPod and the song art is fine there.
 
lycan_codex
Old
#4  
lycan_codex's Avatar
Senior Member
Thanks Meter 36
Posts: 308
Join Date: Apr 2010
Location: Bangalore
Quote:
Originally Posted by ASKnASK View Post
The details are added fine!

Its the phone that messes them up!

I have copied the same music to my iPod and the song art is fine there.
if you are on windows, go to view tab on folder options and check the first one, i.e. Always show icons, never thumbnails.

after selecting this, copy the songs again to your phone, it will show the correct album art.

i had many situations when windows messed up the album art.
Samsung Galaxy S, Samsung Nexus S, Samsung Galaxy Note II, Samsung Galaxy Nexus, Samsung Galaxy S4, Lumia 1520, Sony Xperia Z2, Oppo Find 7a
 
darckengel
Old
#5  
Senior Member
Thanks Meter 228
Posts: 714
Join Date: Apr 2011
Take back the song to your computer and check if the picture is correct.
Also try to wipe the thumbnail database.
 
ASKnASK
Old
#6  
ASKnASK's Avatar
Senior Member - OP
Thanks Meter 9
Posts: 150
Join Date: Apr 2011
Location: Islamabad
Wiping cache didn't help.

This is so weird. Read.

When I copy the song with the messed up art to PC, it has the art embedded, but it doesn't show it. However, when I switch to Large Icons view mode, the art shows. Then, if I go back to Medium Icons, it shows it.

I suppose the problem above is due to the Windows Thumbnail cache. But... why the device? Why is it not showing the art correctly? And what criteria is it using in choosing the random art that it does show in place of the correct art?
 
lycan_codex
Old
#7  
lycan_codex's Avatar
Senior Member
Thanks Meter 36
Posts: 308
Join Date: Apr 2010
Location: Bangalore
did you select the option i have mentioned? did it work?

i believe windows chooses the album art of whichever song you play first in a folder and applies it to all songs which doesnt have any album art.
Samsung Galaxy S, Samsung Nexus S, Samsung Galaxy Note II, Samsung Galaxy Nexus, Samsung Galaxy S4, Lumia 1520, Sony Xperia Z2, Oppo Find 7a
 
ASKnASK
Old
#8  
ASKnASK's Avatar
Senior Member - OP
Thanks Meter 9
Posts: 150
Join Date: Apr 2011
Location: Islamabad
I even changed the SD Card today lol

And the Windows thing.. No that I don't use. I delete all the album art files created by Windows. I myself embed art into the mp3 files using a software. That way, the song itself has the art embedded in it.

My music library displays correct artwork in my iPod. The problem only exists on the Galaxy, and that too only in some songs.
 
lycan_codex
Old
#9  
lycan_codex's Avatar
Senior Member
Thanks Meter 36
Posts: 308
Join Date: Apr 2010
Location: Bangalore
Quote:
Originally Posted by ASKnASK View Post
I even changed the SD Card today lol

And the Windows thing.. No that I don't use. I delete all the album art files created by Windows. I myself embed art into the mp3 files using a software. That way, the song itself has the art embedded in it.

My music library displays correct artwork in my iPod. The problem only exists on the Galaxy, and that too only in some songs.
Windows is definitely messy with the album art. even if you delete the album art, it still shows up messed when you play it with windows player.

for me, selecting the Always show icons, never thumbnails in folder options did the trick.

If you use your Ipod, why dont you try adding album art in Itunes and copy it back to windows and check.
Samsung Galaxy S, Samsung Nexus S, Samsung Galaxy Note II, Samsung Galaxy Nexus, Samsung Galaxy S4, Lumia 1520, Sony Xperia Z2, Oppo Find 7a
 
spacebar2011
Old
#10  
spacebar2011's Avatar
Senior Member
Thanks Meter 555
Posts: 1,370
Join Date: Jan 2011
Location: Bangalore/London
I have the exact same issue. Being a professional DJ, I have to keep my music well organised, well tagged and I also make sure each track has its own album art embedded in it.
I use Media Monkey to tag.
Now, on my Galaxy S, no matter what player I use, some tracks show album art of another track and its just 2 or 3 pictures that show repeatedly on these tracks that are messed up. Its about 30% of the music that shows messed up embedded album art. Some tracks do not show a picture at all despite being tagged with album art. When I mount my SD on the PC and launch Media Monkey, all album art shows up nice and correct. Also, in Windows thumbnail view, all the art shows up correctly too.
I tried clearing Media storage data under applications but no luck. This is so utterly annoying!

What the hell is it with Android and embedded album art?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes