FORUMS

PSA: You Can Optimize Your Note 4’s Recents Menu & RAM

The Note 4 never had the fastest Recents Menu, and despite its 3GB of RAM, … more

XDA Picks: Best Apps of the Week (July 25 – Aug 1)

Apps are at the front and center of any smartphone experience, and with over a … more

Voices Of XDA: Orbiting The Earth With Android

Editor’s note: This week’s feature has been written by forum … more

CloudPlayer: DIY HiFi Music Streaming Solution

In our Helpful Guide to Music Streaming Services, we mentioned several different services … more

Brightness control solution.

449 posts
Thanks Meter: 18
 
By mtechfan, Senior Member on 18th April 2011, 02:41 PM
Post Reply Subscribe to Thread Email Thread
As some of you are like me and find the auto brightness flicker annoying.

I did notice if you manually set the brightness level (display settings) the flicker stops, sadly the built in widget is really lacking in control.

I used this widget on my X10 and tried it on my Arc, it works brilliantly!

http://curvefish.com/widgets/brightness-level.htm

Hope you find it useful as I do.

(What it looks like, from curvefish website)


I run mine at 75% all the time unless I am checking stuff just before bed, then I turn it all the way down. Battery life is very good using this widget.
Last edited by mtechfan; 18th April 2011 at 02:45 PM.
The Following 2 Users Say Thank You to mtechfan For This Useful Post: [ View ]
 
 
18th April 2011, 08:56 PM |#2  
Mano1982's Avatar
Senior Member
Flag Oslo
Thanks Meter: 131
 
More
Extended Control can do job also Thanks mtechfan for a useful thread
The Following User Says Thank You to Mano1982 For This Useful Post: [ View ]
18th April 2011, 09:31 PM |#3  
mtechfan's Avatar
OP Senior Member
Flag Ístersund
Thanks Meter: 18
 
More
Quote:
Originally Posted by Mano1982

Extended Control can do job also Thanks mtechfan for a useful thread

Yep, extended controls work as well. Never bothered trying it as it wasn't free here in Sweden, but it is not that expensive either :)
They sure look nice though.
Last edited by mtechfan; 18th April 2011 at 10:21 PM.
The Following User Says Thank You to mtechfan For This Useful Post: [ View ]
18th April 2011, 11:26 PM |#4  
Step666's Avatar
Retired Forum Moderator
Thanks Meter: 1,065
 
More
The Widgetsoid brightness control also seems to override the automated system.

edit: scratch this, the automatic brightness seems to have come back again...



Also, if you set it to LED flash control to 'method 2' in the global preferences, it works as a flashlight/torch.
Last edited by Step666; 20th April 2011 at 10:05 PM.
28th April 2011, 08:36 AM |#5  
Blagus's Avatar
Recognized Developer
Thanks Meter: 1,054
 
Donate to Me
More
Hi guys! In this post you can find hw_config for X8 with disabled light sensor. You can compare it to yours to find out how to disable light sensor.
Also, you can upload your hw_config here (/system/etc) and give me a chance to try it

Update: Found the possible solution!
This'll work only if you have similar light sensor.
Open /system/etc/hw_config.sh in text editor.
Search for these two (or similar) lines:
Code:
# lm3530 LMU configuration
...
...
echo 128 > /sys/devices/platform/i2c-adapter/i2c-0/0-0036/als::avg-t     # 32, 63, 128, 256, 512, 1024, 2048, 4096
echo i2c > /sys/devices/platform/i2c-adapter/i2c-0/0-0036/mode    # i2c, pwm, i2c_pwm, als, pwm_als, i2c_pwm_als, i2_als
Change echo 128 to echo 1024
Change echo i2c* to echo i2c_pwm
Save it and chmod to 777 if needed (if you edited file in Windows).
I recommend using Notepad++ for editing on PC.
Last edited by Blagus; 28th April 2011 at 08:55 AM.
28th April 2011, 05:59 PM |#6  
Junior Member
Thanks Meter: 1
 
More
I tried I could not.
Upload files to the link below.
ttp://db.tt/XX9Fsnb
Thank you please.

I use Google translation.
Sent from my LT15i using XDA App
The Following User Says Thank You to nex10v9w32h0041 For This Useful Post: [ View ]
28th April 2011, 09:22 PM |#7  
Blagus's Avatar
Recognized Developer
Thanks Meter: 1,054
 
Donate to Me
More
Try this. Upload to /system/etc and chmod 777.
Attached Files
File Type: zip hw_config.zip - [Click for QR Code] (1.9 KB, 43 views)
29th April 2011, 12:48 AM |#8  
Junior Member
Thanks Meter: 1
 
More
I appreciate your job.
I tried right away, had to disable the auto brightness.

Sent from my LT15i using XDA App
29th April 2011, 04:13 AM |#9  
Senior Member
Flag Taipei , Taiwan
Thanks Meter: 46
 
More
Quote:
Originally Posted by blagus

Try this. Upload to /system/etc and chmod 777.


Hi ~ blagus

sorry for my poor english

I compare this file with my one

is only "Line 31" is different ?

Code:
echo 0 > $dev/lcd-backlight/als/enable  #Sensor on/off. 1 = on, reg 90h
Code:
echo 1 > $dev/lcd-backlight/als/enable  #Sensor on/off. 1 = on, reg 90h
after Upload to /system/etc and chmod 777...then reboot

auto brightness still functional


update..... auto brightness become no-step(smooth) Conversion
Last edited by maxx228; 29th April 2011 at 09:33 AM.
29th April 2011, 06:23 PM |#10  
Junior Member
Thanks Meter: 1
 
More
I'm sorry,,,
I might uploaded files that I was already rewritten.

Change echo 1 to echo 0,
I succeeded to disable auto brightness!

Thanks, blagus!

Edit: When I lock the screen, auto brightness is back. X-<

Sent from my LT15i using XDA App
Last edited by nex10v9w32h0041; 29th April 2011 at 08:09 PM.
29th April 2011, 06:32 PM |#11  
mtechfan's Avatar
OP Senior Member
Flag Ístersund
Thanks Meter: 18
 
More
Maybe my phone is special, but the widget is all I need? It just works!

What gives

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes