5,599,337 Members 38,098 Now Online
XDA Developers Android and Mobile Development Forum

Can't flash ANY RUU.exe

Tip us?
 
markjo
Old
(Last edited by markjo; 11th October 2013 at 08:31 PM.)
#1  
Senior Member - OP
Thanks Meter 15
Posts: 168
Join Date: Sep 2010
Default Can't flash ANY RUU.exe

Hello,

I have an AT&T HTC One. Here's the info:

Quote:
*** RELOCKED ***
M7_UL PVT SHIP S-OFF RH
CID - 11111111
HBOOT - 1.54.0000
RADIO - 4A.20.3263.16
OpenDSP - v32.120.274.0909
OS - 3.22.1540.1
eMMc - boot 2048MB
Jun 22, 2013, 03:43:23:0
I recently flashed the following ROM, including the firmware "for AT&T Phones with S-OFF" listed at the bottom of the post:

[ROM][9/27] - Stock Rooted De-Odex 3.22.1504.1 - Official Dev Phone Android 4.3 OTA!
http://forum.xda-developers.com/show....php?t=2460031

I am unable to successfully run any RUU.exe and end up with Error 155. I have tried running the RUUs with the phone booted up, in RUU mode (fastboot oem rebootRUU), and from fastboot/bootloader itself to no avail. I have TWRP installed and it works fine.

I downloaded the latest 4.3 RUU from here and it fails. I have also tried using other stock AT&T RUUs and none of them work, all giving me the same error : 155.

Can anybody help? I've searched extensively and perhaps may still have missed something, but I don't know what I could be doing wrong. I am S-OFF, have relocked the bootloader, and have the universal CID.

I've been reading that 1.54 prevents possible S-OFF for a device that is S-ON, but I am already S-OFF and was even before I flashed said firmware/rom mentioned earlier. Is this because I am 1.54? Do I still need to downgrade to 1.44 or some other previous HBOOT somehow? Based on research, the answer seems to be no. But I don't get why I can't successfully run any RUUs.

I have yet to try another USB cable aside from the one I received with the phone, and though I doubt that to be the cause of the error, I will try when I have a chance.
 
markjo
Old
#2  
Senior Member - OP
Thanks Meter 15
Posts: 168
Join Date: Sep 2010
Thumbs up SOLVED

Just answered my own question, go figure.

I downloaded the following:
Quote:
ATT 4.3 Leak 3.10.502.2 Firmware (Boot.img removed) ---> http://d-h.st/euh
from [RADIO & FIRMWARE]HTC One Radio's | Firmware | Other Useful Files | Updated 10/9/13

I renamed the file to firmware.zip, placed it in my fastboot folder and flashed it through RUU mode:

Quote:
fastboot oem rebootRUU
fastboot flash zip firmware.zip
I THEN ran the 4.3 RUU.exe I mentioned earlier and success

So it seems all I needed to do to fix the issue of not being able to run any RUU.exe was to downgrade my firmware so that it was lower than 3.17.502.3. I don't quite understand why, but hey it worked.

Hope this helps others that may run into the same issue of Error 155.
 
ictrew
Old
#3  
Junior Member
Thanks Meter 1
Posts: 2
Join Date: Dec 2013
Location: Marietta
Quote:
Originally Posted by markjo View Post
Just answered my own question, go figure.

I downloaded the following:

from [RADIO & FIRMWARE]HTC One Radio's | Firmware | Other Useful Files | Updated 10/9/13

I renamed the file to firmware.zip, placed it in my fastboot folder and flashed it through RUU mode:



I THEN ran the 4.3 RUU.exe I mentioned earlier and success

So it seems all I needed to do to fix the issue of not being able to run any RUU.exe was to downgrade my firmware so that it was lower than 3.17.502.3. I don't quite understand why, but hey it worked.

Hope this helps others that may run into the same issue of Error 155.
Yeah, thanks for the info. As it turned out I figured that out after stumbling around all day yesterday and got it to work. Seems a good solution though like you, I have no understanding why.

Thanks E. J.
The Following User Says Thank You to ictrew For This Useful Post: [ Click to Expand ]
 
lSuperuserl
Old
#4  
lSuperuserl's Avatar
Member
Thanks Meter 1
Posts: 41
Join Date: Apr 2012
Question help me !!!

Quote:
Originally Posted by markjo View Post
Just answered my own question, go figure.

I downloaded the following:

from [RADIO & FIRMWARE]HTC One Radio's | Firmware | Other Useful Files | Updated 10/9/13

I renamed the file to firmware.zip, placed it in my fastboot folder and flashed it through RUU mode:



I THEN ran the 4.3 RUU.exe I mentioned earlier and success

So it seems all I needed to do to fix the issue of not being able to run any RUU.exe was to downgrade my firmware so that it was lower than 3.17.502.3. I don't quite understand why, but hey it worked.

Hope this helps others that may run into the same issue of Error 155.
im having the same problem I have bootloader and recovery only and im stuck I get error 155 trying to do the ruu haven't had any luck and ideas .
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Multiboot in Progress for the Sony Xperia Z1

As we’ve mentioned quite a few times in the past, multiboot is quite the interesting … more

Samsung EFS Tool Updated to V5, Brings Universal Device Support

You may recall that we’ve talked about XDA Recognized Contributor … more

Say Goodbye to Holo Blue Once and for All

When Google released Android 4.4 KitKat back in October of last year, they changed quite a bit … more

Sony Z Ultra Google Play Edition Receives Bluetooth Certification for Android 4.4.3

You may recall that a few days ago, Sprint jumped the gun … more