FORUMS

Swappa’s New App Helps You Value Your Device

There comes a sad time in everyone’s life where you must part ways with your … more

Xiaomi Sold 34.7 Million Phones In 6 Months

2015 has been a phenomenal year for Xiaomi so far. With a stellar rise in 2014, 2015 saw … more

Sprint Reacts To Jab From T-Mobile

America’s cellular network space has always been a battle of the big four: Verizon, AT&T, … more

Floating Apps with Rovers – XDA App Review

There are a lot of great launchers to help customize your phone. Some Launchers allow … more

Can't flash ANY RUU.exe

169 posts
Thanks Meter: 15
 
By markjo, Senior Member on 11th October 2013, 08:18 PM
Post Reply Subscribe to Thread Email Thread
Hello,

I have an AT&T HTC One. Here's the info:

Quote:

*** RELOCKED ***
M7_UL PVT SHIP S-OFF RH
CID - 11111111
HBOOT - 1.54.0000
RADIO - 4A.20.3263.16
OpenDSP - v32.120.274.0909
OS - 3.22.1540.1
eMMc - boot 2048MB
Jun 22, 2013, 03:43:23:0

I recently flashed the following ROM, including the firmware "for AT&T Phones with S-OFF" listed at the bottom of the post:

[ROM][9/27] - Stock Rooted De-Odex 3.22.1504.1 - Official Dev Phone Android 4.3 OTA!
http://forum.xda-developers.com/show....php?t=2460031

I am unable to successfully run any RUU.exe and end up with Error 155. I have tried running the RUUs with the phone booted up, in RUU mode (fastboot oem rebootRUU), and from fastboot/bootloader itself to no avail. I have TWRP installed and it works fine.

I downloaded the latest 4.3 RUU from here and it fails. I have also tried using other stock AT&T RUUs and none of them work, all giving me the same error : 155.

Can anybody help? I've searched extensively and perhaps may still have missed something, but I don't know what I could be doing wrong. I am S-OFF, have relocked the bootloader, and have the universal CID.

I've been reading that 1.54 prevents possible S-OFF for a device that is S-ON, but I am already S-OFF and was even before I flashed said firmware/rom mentioned earlier. Is this because I am 1.54? Do I still need to downgrade to 1.44 or some other previous HBOOT somehow? Based on research, the answer seems to be no. But I don't get why I can't successfully run any RUUs.

I have yet to try another USB cable aside from the one I received with the phone, and though I doubt that to be the cause of the error, I will try when I have a chance.
Last edited by markjo; 11th October 2013 at 08:31 PM.
 
 
11th October 2013, 08:43 PM |#2  
OP Senior Member
Thanks Meter: 15
 
More
Thumbs up SOLVED
Just answered my own question, go figure.

I downloaded the following:
Quote:

ATT 4.3 Leak 3.10.502.2 Firmware (Boot.img removed) ---> http://d-h.st/euh

from [RADIO & FIRMWARE]HTC One Radio's | Firmware | Other Useful Files | Updated 10/9/13

I renamed the file to firmware.zip, placed it in my fastboot folder and flashed it through RUU mode:

Quote:

fastboot oem rebootRUU
fastboot flash zip firmware.zip

I THEN ran the 4.3 RUU.exe I mentioned earlier and success

So it seems all I needed to do to fix the issue of not being able to run any RUU.exe was to downgrade my firmware so that it was lower than 3.17.502.3. I don't quite understand why, but hey it worked.

Hope this helps others that may run into the same issue of Error 155.
9th December 2013, 03:08 PM |#3  
Junior Member
Flag Marietta
Thanks Meter: 1
 
More
Quote:
Originally Posted by markjo

Just answered my own question, go figure.

I downloaded the following:

from [RADIO & FIRMWARE]HTC One Radio's | Firmware | Other Useful Files | Updated 10/9/13

I renamed the file to firmware.zip, placed it in my fastboot folder and flashed it through RUU mode:



I THEN ran the 4.3 RUU.exe I mentioned earlier and success

So it seems all I needed to do to fix the issue of not being able to run any RUU.exe was to downgrade my firmware so that it was lower than 3.17.502.3. I don't quite understand why, but hey it worked.

Hope this helps others that may run into the same issue of Error 155.

Yeah, thanks for the info. As it turned out I figured that out after stumbling around all day yesterday and got it to work. Seems a good solution though like you, I have no understanding why.

Thanks E. J.
The Following User Says Thank You to ictrew For This Useful Post: [ View ]
8th February 2014, 07:16 AM |#4  
lSuperuserl's Avatar
Member
Thanks Meter: 1
 
More
Question help me !!!
Quote:
Originally Posted by markjo

Just answered my own question, go figure.

I downloaded the following:

from [RADIO & FIRMWARE]HTC One Radio's | Firmware | Other Useful Files | Updated 10/9/13

I renamed the file to firmware.zip, placed it in my fastboot folder and flashed it through RUU mode:



I THEN ran the 4.3 RUU.exe I mentioned earlier and success

So it seems all I needed to do to fix the issue of not being able to run any RUU.exe was to downgrade my firmware so that it was lower than 3.17.502.3. I don't quite understand why, but hey it worked.

Hope this helps others that may run into the same issue of Error 155.

im having the same problem I have bootloader and recovery only and im stuck I get error 155 trying to do the ruu haven't had any luck and ideas .
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes