FORUMS

Two New Moto X and New Moto G Announced, Details Inside

Today’s Moto event just ended and now we have a clear look at all of … more

How Strong Is Your Connection? – XDA Xposed Tuesday

Everyone is always talking about their bars. How many bars of WiFi do they … more

OnePlus 2 Announced: Specs, Price and Details

The OnePlus 2 has just had its Virtual Reality Launch event, and at the XDA Office we all … more

A Helpful Guide to Music Streaming Services

With the launch of Apple Music, music streaming services have recently gained a lot of … more

Works with Telcel, not with Movistar

12 posts
Thanks Meter: 0
 
By Vatofeo, Junior Member on 2nd February 2014, 10:16 AM
Post Reply Subscribe to Thread Email Thread
Ok, so I've been searching all over the forum about the issue I'm having but I'm still not sure of what I can do.

I got this T999L recently, the phone is apparently unlocked (or so I was told and I don't know what method was used) and able to be used in Mexico with Telcel and Movistar. The phone has baseband UVUBMK4 however no IMEI (if I enter *#06# I get " /02").
Now, when I put a Telcel SIM it works fine right away, calls, msg, 4g data, BUT if I put a Movistar SIM it looks like it reads it as I get the carrier SIM services app and I get full bars, but there's no network, no 4g, no calls (not registered on network) and if I go to the mobile network settings I get "Insert sim card to access network services".
Does this make any sense? is there anything I can do?

I'm sorry if I asked something that was posted before, I really tried hard finding an answer in the forums but couldn't find any.

Thanks in advance
 
 
2nd February 2014, 05:41 PM |#2  
OP Junior Member
Thanks Meter: 0
 
More
Could replacing the SIM fix the issue or does it sound like nothing to do with that?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes