Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

SUDDEN/UNTIMELY Death of my Xperia Z1

OP ermond012

26th December 2013, 07:47 AM   |  #1  
ermond012's Avatar
OP Senior Member
Thanks Meter: 36
 
473 posts
Join Date:Joined: Jul 2013
It looks like my phone is dead. I had it checked on repair store and they tried to reprogram and sort of downgrade the OS but unfortunately they weren't able to. Same thing happened. The second repair store said that the back panel has to be opened to check the internal of the phone but I didn't agree to do that.

I'm still trying to charge it today when I got home but still the same no LED light while charging. This is very frustrating as I spent a lot money to have this phone and didn't last for 2 months. Very disappointed. I will never, ever buy from an OL shop again. The warranty is void when I upgraded the OS as per the retailer so no replacement happened. Now I don't have enough money to buy a new one. Have to save up again and will take a couple of months to buy one.

Disappointment.
26th December 2013, 08:16 AM   |  #2  
Junior Member
Flag Tartu
Thanks Meter: 0
 
24 posts
Join Date:Joined: Feb 2012
More
Quote:
Originally Posted by ermond012

It looks like my phone is dead. I had it checked on repair store and they tried to reprogram and sort of downgrade the OS but unfortunately they weren't able to. Same thing happened. The second repair store said that the back panel has to be opened to check the internal of the phone but I didn't agree to do that.

I'm still trying to charge it today when I got home but still the same no LED light while charging. This is very frustrating as I spent a lot money to have this phone and didn't last for 2 months. Very disappointed. I will never, ever buy from an OL shop again. The warranty is void when I upgraded the OS as per the retailer so no replacement happened. Now I don't have enough money to buy a new one. Have to save up again and will take a couple of months to buy one.

Disappointment.

Sorry to read that.

Same happened to me yesterday. I was flashing new firmware and after unplugging from computer phone did not start anymore. Charged overnight, but no. It seems completely dead.
26th December 2013, 08:19 AM   |  #3  
Member
Thanks Meter: 8
 
66 posts
Join Date:Joined: Nov 2013
Quote:
Originally Posted by matikl

Sorry to read that.

Same happened to me yesterday. I was flashing new firmware and after unplugging from computer phone did not start anymore. Charged overnight, but no. It seems completely dead.

Tons of XZ1 dead and sony dont care they simply want our monney thats all i think its time to say goodbye to sony after over 10 years SE fan boy !
26th December 2013, 08:20 AM   |  #4  
ermond012's Avatar
OP Senior Member
Thanks Meter: 36
 
473 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by matikl

Sorry to read that.

Same happened to me yesterday. I was flashing new firmware and after unplugging from computer phone did not start anymore. Charged overnight, but no. It seems completely dead.

Thanks for taking your time in reading this post. Disappointed right? Huge amount of money spent for this but then this is what we get. Though I'm still somehow hoping that it will still get revived. Did Sony let us down?
26th December 2013, 08:23 AM   |  #5  
ermond012's Avatar
OP Senior Member
Thanks Meter: 36
 
473 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by Meni30

Tons of XZ1 dead and sony dont care they simply want our monney thats all i think its time to say goodbye to sony after over 10 years SE fan boy !

My mistake is I bought mine from an OL shop here in the Philippines, not from a Sony or Xperia store. I still love Sony, I still want a Z1 but to be honest right now I'm not that 100% sure if I'm gonna buy another one. Though there's no other option out there for me outside Sony aside from Apple (I guess).
The Following User Says Thank You to ermond012 For This Useful Post: [ View ]
26th December 2013, 08:28 AM   |  #6  
Just2Cause's Avatar
Senior Member
Flag Doha, Qatar
Thanks Meter: 84
 
274 posts
Join Date:Joined: Oct 2013
Donate to Me
More
Quote:
Originally Posted by ermond012

Did Sony let us down?

Try Sony forum, they might be able to help you.



Regards,
~J2C
The Following User Says Thank You to Just2Cause For This Useful Post: [ View ]
26th December 2013, 08:30 AM   |  #7  
ermond012's Avatar
OP Senior Member
Thanks Meter: 36
 
473 posts
Join Date:Joined: Jul 2013
Quote:
Originally Posted by Just2Cause

Try Sony forum, they might be able to help you.



Regards,
~J2C

Thanks for that. I will post there. Hope they could somehow help me on this.
26th December 2013, 10:33 AM   |  #8  
Senior Member
Flag Nové Zámky
Thanks Meter: 10
 
140 posts
Join Date:Joined: Jan 2010
More
You guys experimenting with different firmwares, and if you brick your phones you blame it on Sony ? I don´t know if is something like that there for Qualcomm chips but I liked on my Tegra devices that I could restore even a hard bricked device with Nvflash...
26th December 2013, 10:36 AM   |  #9  
omegahanggara's Avatar
Senior Member
Flag Jakarta
Thanks Meter: 152
 
494 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by ermond012

Thanks for that. I will post there. Hope they could somehow help me on this.

Looks like your boot partition has been wiped. That's where kernel is stored. Without kernel, your device won't boot, neither recognize any plugged in cable (USB to computer either Charger).

They're two ways to solve this.
Claim your warranty to change your motherboard.
Find someone who know to revive dead Xperia Z1.

Hope this help.
26th December 2013, 01:31 PM   |  #10  
Rui Oliveira 21's Avatar
Senior Member
Flag Braga
Thanks Meter: 15
 
233 posts
Join Date:Joined: Apr 2012
More
good luck bro

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes