Post Reply

Unhappy [Q] Shutting down all the time.

OP rudysloup

13th February 2014, 06:31 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: May 2010
More
I have a sprint evo 4g lte the screen cracked and I replaced it. At first it seemed everything was OK but then it started shutting down. THe battery says it is full but it will just power off. Can anyone tell me what is the most likely problem? I will probably have to open the phone up and I am concerned one of the connectors is probably a culprit. Which connections would be the most likely cause of this?
14th February 2014, 05:39 AM   |  #2  
wolfclan68's Avatar
Senior Member
Flag Chula Vista, Ca
Thanks Meter: 82
 
173 posts
Join Date:Joined: Aug 2010
More
Quote:
Originally Posted by rudysloup

I have a sprint evo 4g lte the screen cracked and I replaced it. At first it seemed everything was OK but then it started shutting down. THe battery says it is full but it will just power off. Can anyone tell me what is the most likely problem? I will probably have to open the phone up and I am concerned one of the connectors is probably a culprit. Which connections would be the most likely cause of this?

You need to give more info. What firmware, what ROM, custom kernel, S-off. It may be a connector or it may be software related. If it was connector related to the screen I would think the screen would simply black out, unless it's causing a short. Though I find that unlikely, those screen connectors are fairly simple.
14th February 2014, 06:04 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: May 2010
More
Quote:
Originally Posted by wolfclan68

You need to give more info. What firmware, what ROM, custom kernel, S-off. It may be a connector or it may be software related. If it was connector related to the screen I would think the screen would simply black out, unless it's causing a short. Though I find that unlikely, those screen connectors are fairly simple.

It was all stock, no custom roms, it should have been updated to whatever the latest update was.
14th February 2014, 09:58 PM   |  #4  
Valsorim's Avatar
Member
Flag Saint Louis
Thanks Meter: 12
 
43 posts
Join Date:Joined: Apr 2013
More
Quote:
Originally Posted by rudysloup

It was all stock, no custom roms, it should have been updated to whatever the latest update was.

Maybe take it in to a Sprint store that repairs phones, have them take a look at it. They've always been good to me and not charged me anything. Last time I had a loose USB port, they checked it out, and got a refurb that looks brand new for $50. I didn't have insurance either. Same phone a couple days later when putting on screen protector w soapy water, got under screen, I went back in and they swapped the screen out from one going back and didn't charge me for that either.
14th February 2014, 10:09 PM   |  #5  
Magnum_Enforcer's Avatar
Recognized Contributor
Flag Birmingham, AL
Thanks Meter: 1,943
 
3,630 posts
Join Date:Joined: Jul 2012
Donate to Me
More
I agree with what's posted above. If the phone is stock, I'd take it in and let Sprint take a look at it. Sounds like a hardware issue of some sort.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes