Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Insignia Flex

OP klowdhaus

29th November 2013, 11:52 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
12 posts
Join Date:Joined: Oct 2013
Anybody have one? It's Best Buy's brand tablet.

insigniaproducts.com/products/computer-speakers-accessories/NS-14T002.html
(can't post a link...)

Just picked up a Flex 8 on Black Friday. Not bad for $80. Not sure if I'd pay full price for it though.
It seems good for the price so far, except I'm having a rough time trying to root it.

Anyone have one and root it?
30th November 2013, 03:50 AM   |  #2  
Member
Thanks Meter: 24
 
99 posts
Join Date:Joined: Dec 2012
Employee here and I had to pouch one up as well for the price of $80. Now to figure out root.

Sent from my SPH-L710 using xda app-developers app
30th November 2013, 07:23 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
12 posts
Join Date:Joined: Oct 2013
Let us know if you get it.

I've tried Bin4ry, doomlord, tpsparky, played around with it myself a bit. Still not luck. Closest I got is normal on Bin4ry. Just when it reboots, it has no root privaledges. su is in /data/local/tmp but it fails to do anything...
30th November 2013, 09:20 AM   |  #4  
Member
Thanks Meter: 24
 
99 posts
Join Date:Joined: Dec 2012
I haven't messed around with it until this very moment. I will admit that the price is killer but initial impression with the device could be better. I was impressed and I mean really impressed with its quadrant score. I'll root this device later today. Black Friday sales and I am tired.

---------- Post added at 01:20 AM ---------- Previous post was at 01:18 AM ----------

I found a link to root this device on both ICS and jellybean. I will personally look into it tomorrow but I will post it if you would like to go ahead. The guide itself was written for ICS but later down the thread you will find another link to a working root for jellybean.

http://androidforums.com/insignia-fl...gnia-flex.html

Please root at your own discresion and I sure hope you purchased a protection plan (GSP) for your tablet.
30th November 2013, 02:37 PM   |  #5  
eflamenco's Avatar
Member
Flag CALIFORNIA
Thanks Meter: 2
 
98 posts
Join Date:Joined: Oct 2006
More
also picked this up at my BB, was surprised when i walked in at 3pm and they still had about 10. i want to root too
30th November 2013, 06:56 PM   |  #6  
Member
Thanks Meter: 24
 
99 posts
Join Date:Joined: Dec 2012
We had a large quantity to sell as well and they all went. It is honestly not half bad. And I would really recommend getting the GSP for the tablet in case of anything. Will report back after rooting.
1st December 2013, 04:20 AM   |  #7  
OP Junior Member
Thanks Meter: 1
 
12 posts
Join Date:Joined: Oct 2013
Let us know if you have any luck. I found the link you posted before which led me to try Bin4ry. The script seems to be updated for JB in general but still had no luck. I'm on a Mac and haven't tried any of the windows rooting apps, like posted at the bottom of that thread. I do have a windows partition and would be willing to try that method if needed. That chinese one at the bottom seems shady regardless though.. I hope there is an alternative to that
8th December 2013, 06:29 AM   |  #8  
Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Jan 2012
Is there a way to flash clockworkmod onto this tablet?
Last edited by rekagear20; 8th December 2013 at 04:07 PM.
15th January 2014, 11:44 AM   |  #9  
bhiga's Avatar
Recognized Contributor
Thanks Meter: 882
 
2,248 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by rekagear20

Is there a way to flash clockworkmod onto this tablet?

I managed to get the CX-803 version of CWM for Rockchip 3066 from AndroTab.info to work by replacing its kernel with ours by unpacking and repacking with RK3xxx-Firmware-Tools by Sergio.

Note: This is for the Insignia NS-14T002 (aka iRiver NS-14T002) tablet that shipped with Android 4.2.2
Be EXTREMELY careful! Highly recommend you dump your current kernel and recovery partitions and save them somewhere before flashing anything.

If for some reason the recovery doesn't work, you can flash your stock recovery back as long as you can get back into root shell. But, if it fails to boot normally, I have no idea how to fix it. I have not been able to get any of the Rockchip flashing utilities to recognize the tablet so far, in bootloader mode (these devices have no fastboot) or otherwise. So don't blame me if you somehow brick your tablet.
You have been warned!!

CWM Recovery for NS-14T002
Stock Recovery for NS-14T002 (if for some reason you can't back up your own, but again highly recommend backing up your existing recovery in case it's different from mine)

You need root, and you need to do the install from root shell (don't forget to su) as described here.
I used /data/local instead of /dev - anywhere writable should be okay.

To boot into recovery:
  1. adb reboot recovery
  2. power off tablet, disconnect USB, press and hold Vol+ and Power until recovery comes up.
    USB disconnect is not a strict requirement, but the battery status thing tends to get in the way.
    In stock recovery, push Vol+ and Vol- simultaneously to bring up the menu. CWM menu should be visible at launch.
  3. install petrus's Reboot App and use it to Reboot into recovery

Note: In CWM recovery you can swipe up for Vol+ (move up), swipe down for Vol- (move down), swipe left for Power (select), and swipe right for Back.
Last edited by bhiga; 17th January 2014 at 03:58 PM.
2nd February 2014, 04:38 PM   |  #10  
cramamarshall's Avatar
Member
Flag Tampa Bay
Thanks Meter: 10
 
64 posts
Join Date:Joined: Jan 2011
More
Tablet Re:Insignia Flex Tablet
I actually just purchased one of these last night. It was on sale at Best Buy for $99! I have successfully rooted it and it actually works great! I used Kingo Root to root but first I installed pda net first to install the necessary drivers. I have used this program to root several Android devices and haven't had a problem thus far!


http://www.kingoapp.com/
Last edited by cramamarshall; 2nd February 2014 at 07:20 PM.

Post Reply Subscribe to Thread

Tags
insignia flex 8, recovery
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes