Battery Charged in 30 Seconds? Maybe in 2016

Phones and tablets are getting more and more power hungry with each passing generation. Their … more

ZArchive Manages Your File Archives

Today smartphones are quite powerful devices that can handle multiple processes at once. In fact, some of … more

Regain Double Tap to Wake Functionality on the Nexus 6

A few months ago, Google announced its newest flagship device, the Nexus 6, alongside … more

Clean Your Recent Apps – XDA Xposed Tuesday

In this day and age, you have quite a few apps installed and running on your Android … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Thumbs up [MOD][4.0.4] NoSimIcon for Galaxy S Duos

OP MufcTK

8th April 2014, 11:51 AM   |  #1  
MufcTK's Avatar
OP Senior Member
Thanks Meter: 32
 
182 posts
Join Date:Joined: Feb 2012
More
Hello Guys! Today i present to you a mod that i made. A lot of users had been complaining about the Sim Icon in the status bar of Galaxy S duos.
Well this mod is made to remove that.
So lets get to the guide straight away.
WARNING
This has been made on my device running XXBMD4 i have not tested this on any other version so install on your own risk.
This is based on the STOCK XXBDM4
I am not responsible if anything happens to your device after installing this.
This is similar to what has been implemented in cosmic ROM but i have not stolen it from there.
INSTRUCTIONS
Step 1:
Go to http://d-h.st/WWx and download the SystemUI.apk
Step 2:
Transfer the file to your S duos.
Step 3:
Using and file manger (i prefer root browser) move the file to /system
Step 4:
Edit the permissions to rw-r--r-- (as shown below)
Step 5:
After the permissions have been changed move the file to /system/app
Step 6:
Reboot.
Enjoy and hit thanks if i helped you
Special thanks to
@abhi922 (for helping me with apkmultitool)
@Dev Jaskirat
PS in the photos i am using an xposed mod called tinted status bar. But this mod works even without the module.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-04-08-14-59-29[1].png
Views:	270
Size:	155.7 KB
ID:	2674782   Click image for larger version

Name:	Screenshot_2014-04-08-14-59-10[1].png
Views:	279
Size:	56.6 KB
ID:	2674783   Click image for larger version

Name:	Screenshot_2014-04-08-14-58-56[1].png
Views:	312
Size:	187.3 KB
ID:	2674784   Click image for larger version

Name:	Screenshot_2014-04-08-15-15-39[1].png
Views:	228
Size:	69.9 KB
ID:	2674785  
Last edited by MufcTK; 8th April 2014 at 12:20 PM.
The Following User Says Thank You to MufcTK For This Useful Post: [ View ]
8th April 2014, 11:55 AM   |  #2  
MufcTK's Avatar
OP Senior Member
Thanks Meter: 32
 
182 posts
Join Date:Joined: Feb 2012
More
Saved for later use
8th April 2014, 12:38 PM   |  #3  
abhi922's Avatar
Recognized Contributor
Flag punjab
Thanks Meter: 3,748
 
1,187 posts
Join Date:Joined: Jul 2012
Donate to Me
More
Smile
nice ......good work.
The Following User Says Thank You to abhi922 For This Useful Post: [ View ]
maxb2000
9th June 2014, 09:53 AM   |  #4  
Guest
Thanks Meter: 0
 
n/a posts
@MufcTK

I moved the file and set the correct permisions but the status bar after restart don't show up....any solution ?

Thanks!
12th June 2014, 07:19 PM   |  #5  
MufcTK's Avatar
OP Senior Member
Thanks Meter: 32
 
182 posts
Join Date:Joined: Feb 2012
More
That is because you are using a different firmware/ROM than this is meant for.
Reflash the ROM or if you have a backup of the original systemui then use that!


Sent from my XT1033 using XDA Free mobile app
Post Reply Subscribe to Thread

Tags
galaxy s duos, s duos, s duos mod
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes