Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,035 Members 40,796 Now Online
XDA Developers Android and Mobile Development Forum

TWRP Recovery & Possible ROM Issues

Tip us?
 
Ilia Goro
Old
(Last edited by Ilia Goro; 26th March 2013 at 06:26 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Mar 2013
Unhappy TWRP Recovery & Possible ROM Issues

I rooted my kindle fire using kfu 9.8. As of this moment when I install roms they do not boot up and they stay at the boot logo. I dont know if it has to do with TWRP or the roms, but I have tried 2 cm10 roms and one AOSP 4.2.2 rom. I will tell you exactly what I did.

1. Rooted with kfu
2. went straight to recovery, flashed the aosp rom + google apps
3. Booted up and it stayed at the boot screen
4. Tried another rom, put it onto the device through usb mounting with twrp
5. Still stuck at boot logo
6. Tried the last rom but still stuck!!

After that I tried to flash back to stock using this
(doesnt let me post a link if requested I will pm)
But twrp gave an error and it did not install, it said somewhere an error doesnt matter and you would boot up fine but I didnt

Between installing all Roms I wiped cache, dalvik, and factory reset.

Thanks in advnce!

EDIT

Used this to try to bring to stock
theunlockr DOT com/2012/10/29/how-to-unroot-the-amazon-kindle-fire

Used these roms (all on xda)

/showthread.php?t=2100963
/showthread.php?t=2041694
cant find the third rom

EDIT

I have no problem using adb or fastboot so feel free to try and fix my problem with those.
 
soupmagnet
Old
#2  
soupmagnet's Avatar
Retired Forum Moderator
Thanks Meter 2,386
Posts: 4,021
Join Date: Jan 2012
Location: Austin, TX
Default Re: TWRP Recovery & Possible ROM Issues

Quote:
Originally Posted by Ilia Goro View Post
But twrp gave an error and it did not install it said somewhere an error doesnt matter and you would boot up fine but I didn't
It would be very helpful to know exactly what error you are receiving.
The Following User Says Thank You to soupmagnet For This Useful Post: [ Click to Expand ]
 
Ilia Goro
Old
(Last edited by Ilia Goro; 26th March 2013 at 06:51 PM.)
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Mar 2013
Quote:
Originally Posted by soupmagnet View Post
It would be very helpful to know exactly what error you are receiving.
assert failed:getprop ("ro.product.device") == "blaze" l l
E:unknown command {err_string}
getprop ("ro.product.device") == "blaze"
E:unknown command {err_string}
E:Error in sdcard/update.zip
Status 7
Error flashing zip /sdcard/update.zip
Updating partition details

That is exactly what I get while flashing

Im sorry for making the topic and/or wasting your time, before installing the rom I wiped every single thing possible and it succesfully nstalled.

I have no problem if you lock.
 
Runaround
Old
#4  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Nov 2010
Quote:
Originally Posted by Ilia Goro View Post
assert failed:getprop ("ro.product.device") == "blaze" l l
E:unknown command {err_string}
getprop ("ro.product.device") == "blaze"
E:unknown command {err_string}
E:Error in sdcard/update.zip
Status 7
Error flashing zip /sdcard/update.zip
Updating partition details

That is exactly what I get while flashing

Im sorry for making the topic and/or wasting your time, before installing the rom I wiped every single thing possible and it succesfully nstalled.

I have no problem if you lock.
Any update on this? I'm getting the same issue on mine.
 
philipsw
Old
#5  
Junior Member
Thanks Meter 2
Posts: 10
Join Date: May 2012
Quote:
Originally Posted by Runaround View Post
Any update on this? I'm getting the same issue on mine.
I had the same issue using TWRP 2.4.x.x. I was able to return to stock by downgrading to TWRP 2.2.2.1. Good luck.

Sent from my Nexus 7 using xda app-developers app
 
votinh
Old
#6  
votinh's Avatar
Senior Member
Thanks Meter 426
Posts: 2,204
Join Date: Jul 2011
Quote:
Originally Posted by philipsw View Post
I had the same issue using TWRP 2.4.x.x. I was able to return to stock by downgrading to TWRP 2.2.2.1. Good luck.

Sent from my Nexus 7 using xda app-developers app
By any chance, can you please give me the link to the TWRP 2.2.2.1?
TIA.
Official CM10.1 Nightly @ 1000MHz NOOKcolor
Offiical CM11 KK Nightly on Kindle Fire 1st-Gen
Rooted Kindle Fire HD 8.9" w/ Nova Launcher
Virgin JB 4.3 on Sony Xperia Tablet Z
Rooted stock-ROM KK 4.4.2 on LG-D800

Virgin Samsung Galaxy Tab 2 10.1 - LOST
Slimbean 8.1 on Galaxy S2 i777 - LOST
 
philipsw
Old
#7  
Junior Member
Thanks Meter 2
Posts: 10
Join Date: May 2012
Quote:
Originally Posted by votinh View Post
By any chance, can you please give me the link to the TWRP 2.2.2.1?
TIA.
http://www.teamw.in/project/twrp2/79

Sent from my Nexus 7 using xda app-developers app
 
votinh
Old
#8  
votinh's Avatar
Senior Member
Thanks Meter 426
Posts: 2,204
Join Date: Jul 2011
Quote:
Originally Posted by philipsw View Post
http://www.teamw.in/project/twrp2/79

Sent from my Nexus 7 using xda app-developers app
Thanks philipsw, I found the 2.2.2.1 flashable zip file too.
Official CM10.1 Nightly @ 1000MHz NOOKcolor
Offiical CM11 KK Nightly on Kindle Fire 1st-Gen
Rooted Kindle Fire HD 8.9" w/ Nova Launcher
Virgin JB 4.3 on Sony Xperia Tablet Z
Rooted stock-ROM KK 4.4.2 on LG-D800

Virgin Samsung Galaxy Tab 2 10.1 - LOST
Slimbean 8.1 on Galaxy S2 i777 - LOST
 
tec_rat
Old
#9  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Jan 2014
Default 2.2.2.1 zip?

Quote:
Originally Posted by votinh View Post
Thanks philipsw, I found the 2.2.2.1 flashable zip file too.
where did you find the zip file?
 
lj50036
Old
#10  
lj50036's Avatar
Recognized Contributor
Thanks Meter 1,407
Posts: 1,720
Join Date: Feb 2013
Location: Muti-Verse

 
DONATE TO ME
Default TWRP

You need TWRP 2.6.3.1 too install KitKat Roms here is the link for your first gen fires you need the otter.img

TWRP

The Following User Says Thank You to lj50036 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes