Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Optimus L9 Wi-Fi problem .

OP brckf5

16th January 2013, 03:11 PM   |  #1  
OP Junior Member
Flag New Delhi
Thanks Meter: 0
 
8 posts
Join Date:Joined: Jan 2013
More
I have an LG Optimus L9 P765 (Indian variant) with Stock ROM v10d on it.
WiFi on my set seems to be misbehaving. It connects to my network and works fine for sometime, but when I leave it unused for about say 5 minutes the mobile does not connects with my WiFi network.
In notification bar it shows that it is connected but actually there is no data transfer occurring.
Its very irritating as I don't get instant emails, whatsapp chats etc.
Is anybody else facing the same problem ? Please suggest any remedy for this problem.
16th January 2013, 08:27 PM   |  #2  
Junior Member
Flag Mumbai
Thanks Meter: 4
 
4 posts
Join Date:Joined: Jan 2013
More
Yeah, same problem here.
I've got an Indian P765 with V10d stock ROM as well. If left idle for sometime, the wi-fi seems to be connected but no data transfer occurs.
The small upward pointing triangle is shown on the wi-fi icon in the notification area, but the data transfer LED of the wi-fi modem doesn't blink, and so no webpage loads.
But if the wi-fi is being used continously, the problem doesn't occur.
Looking forward to a solution, thanks.

Edit: Reduced the Beacon Interval of the Wi-Fi modem to 100ms. The data connection is maintained now.
Problem solved. The phone's working fine afterall.
Last edited by dz007; 17th January 2013 at 05:30 AM. Reason: Found a solution.
The Following User Says Thank You to dz007 For This Useful Post: [ View ]
17th January 2013, 06:38 AM   |  #3  
alienngp's Avatar
Senior Member
Flag Laurel, MS
Thanks Meter: 59
 
236 posts
Join Date:Joined: Oct 2011
Donate to Me
More
Before that happens go into wifi settings press the menu button hot advanced and turn the wifi sleeping policy off that is all that I can suggest

Sent from my Lg Optimus L9 P769BK using xda-premium
17th January 2013, 09:10 AM   |  #4  
OP Junior Member
Flag New Delhi
Thanks Meter: 0
 
8 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by dz007

I've got an Indian P765 with V10d stock ROM as well. If left idle for sometime, the wi-fi seems to be connected but no data transfer occurs.
The small upward pointing triangle is shown on the wi-fi icon in the notification area, but the data transfer LED of the wi-fi modem doesn't blink, and so no webpage loads.
But if the wi-fi is being used continously, the problem doesn't occur.
Looking forward to a solution, thanks.

Edit: Reduced the Beacon Interval of the Wi-Fi modem to 100ms. The data connection is maintained now.
Problem solved. The phone's working fine afterall.

Beacon Interval of my WiFi modem is already 100ms.
Problem still persists.
Any solution anybody.

The only solution for now is to change WiFi sleep policy to Never instead of Always in WiFi settings.
But that turns on Mobile data or 3G (which ever you have) which is more battery consuming.
And there's no point of keeping a smartphone offline by disabling either WiFi or Mobile data.
18th January 2013, 02:56 PM   |  #5  
kevev's Avatar
Senior Member
Thanks Meter: 229
 
1,176 posts
Join Date:Joined: May 2006
P769BK has a different wifi issue. All 6 of mine have had this same issue.

Enable wifi and use if for a few hours.If wifi router looses internet access and you try to download an MMS it fails.
Disable wifi and try downloading MMS via cellular network it fails. Airplane mode toggle does not work.
A reboot is required to fix this. Very irritating when connected to a wifi network that has a bad connection.
Don't even get me started with wifi-calling. It just plain sucks on 4.x ROMs.
21st January 2013, 12:54 PM   |  #6  
cmahendra's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 4,293
 
3,552 posts
Join Date:Joined: Jan 2012
Donate to Me
More
I use WidgetSoid which gives WIFI and 3G icon (also called power switches) on Home Screen and reconnecting is just a HALF SECOND deal for me. Its even quickly re-connectable from WiFi PowerSwitch in Notification Panel.

By the way, I did not notice this issue on my P765 (india) L9. Works well with Vodafone Mumbai 3G, and WiFi always connected even after idle time upto 2 hours mostly at home. Like they always say, results may vary.
Last edited by cmahendra; 22nd January 2013 at 09:48 PM.
13th December 2013, 09:07 PM   |  #7  
Junior Member
Flag Ingolstadt
Thanks Meter: 2
 
7 posts
Join Date:Joined: Dec 2013
More
Problem: WiFi is not useable
Hey Guys,
i've got a huge problem. I can't switch my WiFi on. The problem exists since a few months and I've tried to fix that by myself but my knowledge about programming is quite small. Please help me. WiFi is one of the most important functions. Is sendng it to LG-Support the only way to get that fixed?
Pls Pls Pls HELP ME!

qkdfler
13th February 2014, 04:30 PM   |  #8  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2014
hi friend,
You already managed to solve your problem?. I have a similar problem, did the bootload and installed cyanongenmod 10.2 for P760 and everything worked perfectly, after I turn off my smartphone realized I was not connecting the wifi and even tapping the power button it does not turn on, put your smartphone in order factory original and still the problem continues.

Can someone help me?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes