5,599,911 Members 45,944 Now Online
XDA Developers Android and Mobile Development Forum

Optimus L9 Wi-Fi problem .

Tip us?
 
brckf5
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Jan 2013
Location: New Delhi
Default Optimus L9 Wi-Fi problem .

I have an LG Optimus L9 P765 (Indian variant) with Stock ROM v10d on it.
WiFi on my set seems to be misbehaving. It connects to my network and works fine for sometime, but when I leave it unused for about say 5 minutes the mobile does not connects with my WiFi network.
In notification bar it shows that it is connected but actually there is no data transfer occurring.
Its very irritating as I don't get instant emails, whatsapp chats etc.
Is anybody else facing the same problem ? Please suggest any remedy for this problem.
 
dz007
Old
(Last edited by dz007; 17th January 2013 at 04:30 AM.) Reason: Found a solution.
#2  
Junior Member
Thanks Meter 4
Posts: 4
Join Date: Jan 2013
Location: Mumbai
Default Yeah, same problem here.

I've got an Indian P765 with V10d stock ROM as well. If left idle for sometime, the wi-fi seems to be connected but no data transfer occurs.
The small upward pointing triangle is shown on the wi-fi icon in the notification area, but the data transfer LED of the wi-fi modem doesn't blink, and so no webpage loads.
But if the wi-fi is being used continously, the problem doesn't occur.
Looking forward to a solution, thanks.

Edit: Reduced the Beacon Interval of the Wi-Fi modem to 100ms. The data connection is maintained now.
Problem solved. The phone's working fine afterall.
The Following User Says Thank You to dz007 For This Useful Post: [ Click to Expand ]
 
alienngp
Old
#3  
alienngp's Avatar
Senior Member
Thanks Meter 49
Posts: 196
Join Date: Oct 2011
Location: Laurel, MS

 
DONATE TO ME
Before that happens go into wifi settings press the menu button hot advanced and turn the wifi sleeping policy off that is all that I can suggest

Sent from my Lg Optimus L9 P769BK using xda-premium
Samsung Galaxy S III White
Rom: 4.3
Status: Stock
Recovery: Stock
Micro SD: Class 10 PNY 16GB
Kernal: Stock

Toshiba Excite Pure at15-a
Status: Stock
Rom: 4.2.1.401072420.01
Nividia Tegra 3

Samsung Galaxy S III (Pebble Blue)
Rom: 4.1.2
Status: Blazer 4.1.2
Kernal: KT474
Recovery: TWRP 2.6.3.0
MicroSD: Class 10 PNY 16gb
 
brckf5
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Jan 2013
Location: New Delhi
Quote:
Originally Posted by dz007 View Post
I've got an Indian P765 with V10d stock ROM as well. If left idle for sometime, the wi-fi seems to be connected but no data transfer occurs.
The small upward pointing triangle is shown on the wi-fi icon in the notification area, but the data transfer LED of the wi-fi modem doesn't blink, and so no webpage loads.
But if the wi-fi is being used continously, the problem doesn't occur.
Looking forward to a solution, thanks.

Edit: Reduced the Beacon Interval of the Wi-Fi modem to 100ms. The data connection is maintained now.
Problem solved. The phone's working fine afterall.
Beacon Interval of my WiFi modem is already 100ms.
Problem still persists.
Any solution anybody.

The only solution for now is to change WiFi sleep policy to Never instead of Always in WiFi settings.
But that turns on Mobile data or 3G (which ever you have) which is more battery consuming.
And there's no point of keeping a smartphone offline by disabling either WiFi or Mobile data.
 
kevev
Old
#5  
kevev's Avatar
Senior Member
Thanks Meter 218
Posts: 1,136
Join Date: May 2006
P769BK has a different wifi issue. All 6 of mine have had this same issue.

Enable wifi and use if for a few hours.If wifi router looses internet access and you try to download an MMS it fails.
Disable wifi and try downloading MMS via cellular network it fails. Airplane mode toggle does not work.
A reboot is required to fix this. Very irritating when connected to a wifi network that has a bad connection.
Don't even get me started with wifi-calling. It just plain sucks on 4.x ROMs.
 
cmahendra
Old
(Last edited by cmahendra; 22nd January 2013 at 08:48 PM.)
#6  
cmahendra's Avatar
Senior Member
Thanks Meter 3142
Posts: 2,882
Join Date: Jan 2012
Location: Mumbai
I use WidgetSoid which gives WIFI and 3G icon (also called power switches) on Home Screen and reconnecting is just a HALF SECOND deal for me. Its even quickly re-connectable from WiFi PowerSwitch in Notification Panel.

By the way, I did not notice this issue on my P765 (india) L9. Works well with Vodafone Mumbai 3G, and WiFi always connected even after idle time upto 2 hours mostly at home. Like they always say, results may vary.
Its my "WIN" & Revenging me will just prove you loser.
List of all Roms for A116 & A117
SLD-ULTIMATE, BUGLESS Micromax A116 and A117 ROM
My son Antariksh's (16yrs) Lite+Fast SuperLuminaL LG L9
DAD-SON Rockon XDA
>FLASH LG PHONE (OFFLINE FIX METHOD)
>KDZ EXTRACTION TOOL
>FASTER Root L9 on Unlocked BL
>GUIDE2ROOT L9 with Lelus method Locked BL
>Collection LG L9 ROMS, ROOT, BB, BL
>My P765 on V20D HK with India BB
>L9 CWM Backup
Hit thanks if liked
 
qkdfler
Old
#7  
Junior Member
Thanks Meter 2
Posts: 7
Join Date: Dec 2013
Location: Munich
Default Problem: WiFi is not useable

Hey Guys,
i've got a huge problem. I can't switch my WiFi on. The problem exists since a few months and I've tried to fix that by myself but my knowledge about programming is quite small. Please help me. WiFi is one of the most important functions. Is sendng it to LG-Support the only way to get that fixed?
Pls Pls Pls HELP ME!

qkdfler
 
adriano1lp
Old
#8  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Feb 2014
hi friend,
You already managed to solve your problem?. I have a similar problem, did the bootload and installed cyanongenmod 10.2 for P760 and everything worked perfectly, after I turn off my smartphone realized I was not connecting the wifi and even tapping the power button it does not turn on, put your smartphone in order factory original and still the problem continues.

Can someone help me?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes