Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,959 Members 43,917 Now Online
XDA Developers Android and Mobile Development Forum

Where is LT30p's vibration module

Tip us?
 
klubberdrax
Old
#1  
klubberdrax's Avatar
Senior Member - OP
Thanks Meter 13
Posts: 115
Join Date: Nov 2007
Location: Timisoara
Default Where is LT30p's vibration module

Hi Guys,

My phone's vibration has becomed very annoying, it sounds like something is loose and it's making a horrible rumbling sound.
Since i don't have warranty i decided to open up the phone myself and see what's going on in there, this is where i got lost, i can't find the vibration module on my Xperia T, all i can say about it is that it's somewhere on the motherboard (i was holding in my hand and had the vibration is coming from it), and i'm guessing that it's in one of the sealed compartments... but which one?..................

Since the device is not using a traditional vibration motor i'm almost sure that this can't be fixed without a replacement.

Any ideas???
The Following User Says Thank You to klubberdrax For This Useful Post: [ Click to Expand ]
 
peetr_
Old
#2  
Recognized Contributor
Thanks Meter 2122
Posts: 2,331
Join Date: Oct 2010
It is the part on the right side of camera. It is covered by metal cap. The cap can be removed and you can try to bend the metal bars, but it won't most probably help. And you could break those plastic slots where these bars are sticked. Just like me. I've broke them. But vibration works.

Some of the parts on T are just crappy.
Vibrator, battery, rear speaker, GPU (heating), back cover and maybe I forgot something.
___________________________________

Sony Xperia T owner

The Following 2 Users Say Thank You to peetr_ For This Useful Post: [ Click to Expand ]
 
LaZiODROID
Old
#3  
LaZiODROID's Avatar
Senior Member
Thanks Meter 150
Posts: 643
Join Date: Feb 2011
Location: Toronto
Very cool. I dropped my phone some time ago and it doesn't vibrate any more. If I put the phone really close to my ear, I can hear it buzzing though... so I imagine something got loose. Thanks for that.
 
thexruss
Old
#4  
Member
Thanks Meter 3
Posts: 32
Join Date: Apr 2011
Yo guys!

I got some solution for the vibrator problems:



I repaired my own T so i havent done any photos of it..
but u have to dismantle the housing mentioned in the 2nd post
then move the "thing" with your finger, and put some drops of that hot juice called wd40 on every piece that "moves"

fixed it for me instantly!
First it just maked a sound and NO VIBRATION, i moved it for some time and then wd40 - works now like a charm!

It looks like the housing was made for keeping some fat inside or something.
this fat disappears after a waterdamage, or just after some months of using.

Hope this helps you!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

MaR-V-iN to Talk Google and Android APIs at XDA:DevCon 2014

Our international xda:devcon 14in Manchester, UK on the weekend of September … more

But First, Let Me Take a #Selfie

“Today while browsing XDA,I’m going tocheck to seeif my favorite ROM has been updated–but … more

Easily Combine Text and Manage Your Android Clipboard with StuffMerge

Android clipboard management has always been impractical without the … more