FORUMS

SuperSU Beta Updates With Minor Fix For Galaxy S6

ChainFire’s root permissions app SuperSU has updated to v.2.49 to fix audits on … more

LG G4 Day Event Coverage: Specs, Features, Design & More!

LG has been teasing us with a countdown for a while now, and today it reached … more

Xposed Modules to Modify Email – XDA Xposed Tuesday

Even though we have Dropbox and other ways to share files, people still want … more

Google Teaches You to Use Wear Gestures

Now that the Watch Urbane is out with the latest firmware, we have new information regarding the … more
Post Reply Subscribe to Thread Email Thread

[Q] Cant restore stock backups with CWM or TWRP

14th February 2014, 12:02 PM |#1  
OP Junior Member
Thanks Meter: 0
 
More
So im still pretty new to this, but im pretty technical so I pick up on this stuff pretty quick. When I first started getting into this stuff I was using CWM as I saw it used most often around the forums. After getting root and unlocking I backed up my stock rom, and then tried to restore it just to test, and it failed. I tried a few times, with different settings, and it failed everytime, so I pretty much had no choice but to go to custom roms at this point. After switching to TWRP 2.6.3, and messing around with a few CM7.2 and CM9 roms, I decided to flash the 4.5.141 sbf (came from 4.5.145), which bricked me untill i flashed the pudding file again, then flashed a 4.5.145 update fruitcake, so i was back to where I was. Backed up the stock rom again with TWRP, wiped everything just in case that was the problem before, and it still failed when I attempted to restore. Again tried different settings, restoring from the SD card, from the internal, mounted and unmounted partitions. Nothing. I flashed CM9, backed up, and it restored flawlessly. Reflashed 4.5.141, pudding, and 4.5.145 update again, repeated the backup and restore. Fail.

All partitions restore except the system partition. No errors are given in the dialog box. The last line of text is "Restoring system..." However, looking through the log, I find this at the bottom;
Code:
==> tar_extract_regfile(t=0x139110, realname="/system//etc/spellchecker/pt_BR.dic")
  ==> extracting: /system//etc/spellchecker/pt_BR.dic (file size 4581228 bytes)
FAILED RESTORE OF FILE i: /system//etc/spellchecker/pt_BR.dic
E:Unable to extract tar archive '/sdcard/TWRP/BACKUPS/TA20708E1R/4.5.145_Stock/system.ext3.win'
I:extractTarFork() process ended with ERROR=255
Whats the problem here? I flashed CM9 and it backed up and restored without a flaw. Why is it just the stock roms that are failing me?
 
 
17th February 2014, 10:57 AM |#2  
OP Junior Member
Thanks Meter: 0
 
More
BUMP

No ideas from anybody?
17th February 2014, 04:34 PM |#3  
Senior Member
Flag Córdoba
Thanks Meter: 362
 
More
Iirc, thete was an issue oreventing the correct decompression of system. On the international fruitcake thread this is discussed.

I had that trouble also, but since the stick rom is a piece of crap, just deleted the backup and installed other roms hehe

Enviado desde mi MB860 usando Tapatalk 2
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes