5,595,000 Members 39,011 Now Online
XDA Developers Android and Mobile Development Forum

[TUTORIAL] Install Flashtool 0.9.10.1 [UBUNTU]

Tip us?
 
BryanRG1996
Old
(Last edited by BryanRG1996; 13th January 2013 at 06:46 PM.) Reason: Updated to Flashtool 0.9.10.1
#1  
BryanRG1996's Avatar
Member - OP
Thanks Meter 9
Posts: 50
Join Date: Mar 2012
Location: Lázaro Cárdenas
Angry [TUTORIAL] Install Flashtool 0.9.10.1 [UBUNTU]

Download Flashtool and libusbx 1.0.14

Uncompress libusbx log into su and type this command
Code:
# ./configure
Now type this command
Code:
# make -B
Finally type this command
Code:
# make install -B
Congrats you have installed libusbx 1.0.14

Now we have to add these rules but first connect your phone and type this command
Code:
lsusb


In my case is: Bus 003 Device 002: ID 0fce:615d Sony Ericsson Mobile Communications AB

Now grab this value

Code:
Bus 00x Device 00x: ID 0fce:xxxx Sony Ericsson Mobile Communications AB
Finally we just add these rules at /etc/udev
Code:
SUBSYSTEM=="usb", ACTION=="add", SYSFS{idVendor}=="0fce", SYSFS{idProduct}=="xxxx", MODE="0777"
Name the rules as 51-flashtool.rules

Uncompress Flashtool and run it as root




Credits go to Bin4ry & Androxyde
The Following 2 Users Say Thank You to BryanRG1996 For This Useful Post: [ Click to Expand ]
 
imputazz
Old
#2  
imputazz's Avatar
Senior Member
Thanks Meter 468
Posts: 311
Join Date: Jun 2012
Location: Porto
I was having some problems in back track but now its working thanks a lot!

Sent from my R800i using xda premium
 
kessaras
Old
#3  
kessaras's Avatar
Senior Member
Thanks Meter 51
Posts: 307
Join Date: Sep 2013
Location: Athens
Quote:
Originally Posted by BryanRG1996 View Post
Code:
# make -B
in which dream did u see the make command working ? libusbx is missing.. to install it u need the dependaries first. after installing the dependaries it sais that automake command is missing. after installing automake it says that automake version is 1.13 and we need .1.13.4.
so libusbx cant be installed so flashtool is not working. reported from ubuntu 13.10. maybe u are on some very old ubuntu version ? i cant explain it in an other way....
 
LG Optimus x4 HD
-OmniRom
-iodak v8.5 kernel
Iphone 4s
-IOS 7
Desktop Operating system
-Ubuntu 13.10 x64
 
liljamjam
Old
#4  
Junior Member
Thanks Meter 4
Posts: 14
Join Date: Mar 2013
Default Confused

I can't seem to understand ANY tutorial on this. Do we add the properties to 51-flashtool or 99-android? and what do I click on to run flashtool? I don't see anything executable in the folder
 
Dilesh Perera
Old
#5  
Dilesh Perera's Avatar
Senior Member
Thanks Meter 719
Posts: 1,240
Join Date: May 2012
Location: Colombo
hi

could u tell me how to this part?? im new to ubuntu. searched but confused


inally we just add these rules at /etc/udev
Code:

SUBSYSTEM=="usb", ACTION=="add", SYSFS{idVendor}=="0fce", SYSFS{idProduct}=="xxxx", MODE="0777"

i cant figure how to add the line in etc/udev
Tags
android, flashtool, rooting, xperia play
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...