Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[CWM][PHILZ][TWRP][LB]Recoveries for Xperia SP LB [2014-07-09]

OP dssmex

16th February 2014, 03:23 AM   |  #1  
dssmex's Avatar
OP Senior Member
Flag Chihuahua
Thanks Meter: 410
 
166 posts
Join Date:Joined: Oct 2008
Donate to Me
More
Requeriments:

Locked bootloader (Unlocked bootloader can flash a custom kernel with this included).

You must be root, if you not be root do this --> http://forum.xda-developers.com/show....php?t=2783885 NEW

You need enable USB Debuging Options (go settings->about phone->compilation number and hit seven times, then go settings->developer options and Enable USB debugging..

Installation:

Quote:

1.) down CWM_SP_#.#.#.zip file.
2.) unzip it on your desktop.
3.) go to the CWM_SP_#.#.# folder
4.) run the install.bat file in windows (use others for linux or mac)
5.) select option number 1 to install.
6.) stay tuned on the phone as it calls super user permissions.
7.) Read the directions to see that everything went well.
8.) If all went well you press a key to continue and after press 3 for reboot phone or 4 to finish.

If something goes wrong, reboot your computer and phone and try again.

For new installs in recovery, i add the flashable zip in downloads section.

Operation:
Quote:

Turning on the phone will see four lights advancing (GREEN-WHITE-RED/BLUE) when the blue light show press:

Volume up -> Philz
Volume Down -> TWRP
Camera button -> CWM Touch

If you have a problem you can put your questions once they have exhausted all options and read the comments of others.

In CWM Touch the backups are stored in /data/media/clockworkmod or /storage/removable/sdcard1/clockworkmod

If you only need ClockworkMod (without philz and TWRP ) you can use a MOD made ​​by @Dark Passenger (any doubt about this release or updates, please ask him), just go to this post <<---- clic here (credits for MOD to @Dark Passenger)

Bugs:
Quote:

For now, restoring backups in 4.3 with CWM touch have troubles. Fixed!
The date in recoverys are wrong, please rename the backups. Fixed!

Changes:
Quote:

2014.07.09 ver. 4.4.1
- Improvements in product number and version number detection.

2014.07.04 ver. 4.4
- added support to CM 11 KitKat by bagyusz.
- all version are supported (4.1, 4.3 and CM 11) in same installer.


2014.06.27 ver. 4.3.8
- added sd-ext suport to backup
second partition of sdcard to all
recoverys(if exists). Needed if you
use link2sd or similar.
- CWM is default recovery (when you
do "reboot in recovery" system enter
in CWM automatically. The buttons keep
same function.

2014.06.16 ver. 4.3.7
- added linux and mac installers
- fix autocreate init.d directory
if not exist.

2014.06.09 ver. 4.3.6
- reverted enhanced ramdisk.
- fixed some bugs.

2014.05.21 ver. 4.3.5
- Updated CWM Touch to 6.0.4.7
- Updated TWRP to 2.7.0.0
- Added enhanced ramdisk.
- Added init.d support.
- Added compression to ramdisk's.
- Fixed "reboot in recovery" feature.

2014.05.16 ver. 4.3.4
- Loaded stock exfat driver.
- Added improvements.
- Fixed wipedata permissions.

2014.05.15 ver. 4.3.3
- Philz updated to 6.41.6.
- Disabled Glove mode in TWRP.
- Fixed DateTime in recoverys.
- Changed script to wipedata.
- some bugs fixed.
- support only for 4.3 Roms. (Sorry )

2014.04.04 ver. 4.3.2
- philz updated to 6.25.0.0
- CWM Touch updated.
- some bugs fixed.

2014.03.18 ver. 4.3.1
- added ZIP recovery flashable.

2014.03.11 ver. 4.3.0
- added Philz touch (thanks to @Phil3759).
- Some fixes to TWRP

2014.02.17 initial version
- added external sdcard for backup / install
- Fixed problems mounting/unmounting system partition


Credits:
@Phil3759 for PhilZ touch.
@FXP for CWM
@teamwin for TWRP
@DooMLoRD for ramdisk´s and scripts
@bagyusz for hijack ramdisk.
@KeiranFTW for hijack ramdisk.


Cheers and enjoy

Download:
Last edited by dssmex; 9th July 2014 at 09:45 PM. Reason: updated to 4.4.1
The Following 174 Users Say Thank You to dssmex For This Useful Post: [ View ]
16th February 2014, 04:32 AM   |  #2  
papawil01's Avatar
Senior Member
Flag Cabanatuan City
Thanks Meter: 24
 
266 posts
Join Date:Joined: Oct 2013
More
anyone tried this already?
The Following User Says Thank You to papawil01 For This Useful Post: [ View ]
16th February 2014, 04:51 AM   |  #3  
neXus PRIME's Avatar
Recognized Contributor
Flag Lahore, Pakistan
Thanks Meter: 4,048
 
3,255 posts
Join Date:Joined: Nov 2011
More
Im gonna try right now... Risking flashing on a Sunday... God protect me
The Following User Says Thank You to neXus PRIME For This Useful Post: [ View ]
16th February 2014, 06:53 AM   |  #4  
neXus PRIME's Avatar
Recognized Contributor
Flag Lahore, Pakistan
Thanks Meter: 4,048
 
3,255 posts
Join Date:Joined: Nov 2011
More
Works.... Tested CWM Touch.

Nice Job Man, now we dont have to reflash 4.1.2 and root and flash 4.3 again n again n again n again

Life saver.

---------- Post added at 10:53 AM ---------- Previous post was at 10:25 AM ----------

Tested All recoveries:
1. CWM works fine
2. TWRP fine
3. CWM-touch (some difficulty in navigation, but works ok)
The Following 6 Users Say Thank You to neXus PRIME For This Useful Post: [ View ]
16th February 2014, 10:00 AM   |  #5  
Member
Flag birjand
Thanks Meter: 6
 
91 posts
Join Date:Joined: Jun 2012
More
is there any way .. with out installing purerome.. .for rooting ?

i dont wanna change my stock rom....

16th February 2014, 10:09 AM   |  #6  
James2003's Avatar
Member
Flag Sofia
Thanks Meter: 35
 
33 posts
Join Date:Joined: Sep 2010
I tested it, but only TWRP make backup. CWM says "can't mount system". CWM touch says "backup completed", but there is no backup files on any of storages.I tested two others CWM mods and they also says "can't mount system".

Ohh, I found CWM Touch backup files. After I read log file, I saw this row -> "I:using /data/media for /sdcard/0/clockworkmod". Backup folder is in /data/media/clockworkmod/backup/..

There is something wrong with filesystem table. I saw several lines that say Unable to get recovery.fstab info for: /datadata, /emmc, /sdcard, /ed-ext and /external_sd.
Last edited by James2003; 16th February 2014 at 10:28 AM.
16th February 2014, 10:37 AM   |  #7  
papawil01's Avatar
Senior Member
Flag Cabanatuan City
Thanks Meter: 24
 
266 posts
Join Date:Joined: Oct 2013
More
yep. this works. haven't tried backing up yet though. thanks.
16th February 2014, 12:40 PM   |  #8  
ship puden's Avatar
Member
Flag Malang
Thanks Meter: 43
 
60 posts
Join Date:Joined: Dec 2011
More
thanks, its work.... but, why i cant mount system, its always "mount system Eror"....????
can any body help...
16th February 2014, 01:59 PM   |  #9  
kuriboo's Avatar
Senior Member
Thanks Meter: 252
 
334 posts
Join Date:Joined: Jun 2012
More
Can cwm mount sdcard0/1 and system?

Sent from my C5303 using xda premium
16th February 2014, 03:21 PM   |  #10  
Deepam7325's Avatar
Member
Thanks Meter: 3
 
31 posts
Join Date:Joined: Jun 2013
More
CWM shows "error in mounting system" when I try to mount system. As a result, can't take nandroid backup.
CWM Touch shows "error in unmounting system" when I try to unmount system. Though it can take backup, when I try restore, it shows error in unmounting system.
TWRP though not showing error, and seeming to backup correctly, when I try restore, it shows error in unmounting system.
In other words,
not working for me.
I'm on CE 4.3 stock, rooted, LB.
Last edited by Deepam7325; 16th February 2014 at 04:37 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes