Prepare Your Build Machines: Ubuntu 14.10 Utopic Unicorn Now Official

Today is an important day for any and all Linux enthusiasts. One of the … more

Track the Time You Waste on Social Media with Socials Addict

When you use your phone, you often don’t even realize how much time you … more

Document the Story of Your Social Life with 8tory

The different forms of social media are growing every day. It’s hard to imagine a day … more

Make Calling Your Loved Ones Easier and Cheaper this Diwali

Diwali, or Deepawali as some Indians call it, is the pride and joy of Indian … more
Post Reply

Question [Q] miniCM10 w/ link2sd + a2sdgui Trouble

OP migaspepino

15th February 2014, 11:02 PM   |  #1  
OP Member
Thanks Meter: 1
 
37 posts
Join Date:Joined: Nov 2010
Hi guys,

I have a Sony ericsson X10 mini pro with nAa's Kernel 2.6.32.60-nAa-05 and miniCM10-4.1.0-20130518-NIGHTLY and I also flashed:
On top of that a internal memory of 192MB and a 16GB SDHC class10 SD card.

Boring story part (with more details and links and stickie just in case I forget something ) :

So far so good until I start installing apps and noticed that with a couple the memory was full. After a little research I found link2SD was the solution,
the SD card I have is more than fit for the job.

But then starter the problems, after I partitioned, with MiniTool,
my SD card as FAT32 (~13GB) and ext-N (2, 3 & 4) (~1GB) as primary none worked (at least for long).
I had some success with Ext-3 but the 2nd time I restarted my phone, Scrips were nowhere to be seen nor any linking of some kind.

Then (after more Googling) I tried both partitions as FAT32 and there it was working cool again.

Well went to download more apps, but memory was full, how so? I added a GB to it!
Found that I would, also, need to use A2SDGUI and it's Scripts (Version 2.7.5.3 Beta 04).

Flashed the scripts and then tried to run A2SDGUI not working pop's this error window:
Quote:

Exiting A2SDGUI
Could not start for one of these reasons:

  1. Your device is not rooted
  2. A2SD scripts could not be found
  3. No EXT partition found

Now I'm in trouble because android DOES NOT mount my 2nd partition if it's filesystem is not FAT32
(perhaps this is a scripting problem instead of Filesystem support ? )

And A2SDGUI is no longer being developed/suported.


Bottom line:
I installed link2SD but it only works when my 2nd partition is also FAT32, or else it won't mount,
and the phone internal memory continues to get shorter as I install apps.
Then I installed A2SDGUI and (Flashed) it's Scripts to try to JOIN the internal memory(/data)and SD card's 2nd partition so,
android doesn't give that annoying low memory error message.

I'm having trouble making andoid think that /data is ~1.2GB.
Can someone help me out on this? How can I "make" a "bigger" internal memory?
I searched Google but I couldn't find any GOOD answer to my question.
17th February 2014, 04:41 AM   |  #2  
OP Member
Thanks Meter: 1
 
37 posts
Join Date:Joined: Nov 2010
Service
Shaameless self bump
Last edited by migaspepino; 19th February 2014 at 01:41 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes