Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,384 Members 43,887 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Unable to boot Stock based ROMS [D800]

Tip us?
 
vish9
Old
#1  
Junior Member - OP
Thanks Meter 4
Posts: 20
Join Date: Mar 2013
Default [Q] Unable to boot Stock based ROMS [D800]

Hey everyone, sorry if this question has been answered already. I have sifted through pages and pages in this forum and haven't found a solution for my D800.

My G2 is rooted, with TWRP installed. I was successful in flashing Paranoid Android v4 beta 4, and 5. The problem arises when I try to flash LG Stock based ROMS. After TWRP says flashing was successful and I try to reboot, the screen shows LG logo for a second and turns blank!! That's it just a clear black screen, and the ROM doesn't boot at all.

The ROMs I tried and failed to boot:

1. Aeon
2. Korean stock based rom
3. Scott's CleanROM
4. Rayglobe 3.2
5. Rayglobe Flex ROM v4

Now, I know that sometime ROMs take time to boot on the first run, so I even tried leaving it at the blank screen for 15-20 mins with no result. Since it has been the same result for multiple ROMs, it definitely isn't a bad install or a bad ROM download either. I hope not

Is there anything I am missing in the steps? All ROMs were installed after factory resetting through TWRP (no dirty flash). I am baffled with this, please let me know if I need to revert to software version "d" for these ROMs to work?

TIA
 
joebob296
Old
#2  
Senior Member
Thanks Meter 21
Posts: 235
Join Date: Aug 2010
Quote:
Originally Posted by vish9 View Post
Hey everyone, sorry if this question has been answered already. I have sifted through pages and pages in this forum and haven't found a solution for my D800.

My G2 is rooted, with TWRP installed. I was successful in flashing Paranoid Android v4 beta 4, and 5. The problem arises when I try to flash LG Stock based ROMS. After TWRP says flashing was successful and I try to reboot, the screen shows LG logo for a second and turns blank!! That's it just a clear black screen, and the ROM doesn't boot at all.

The ROMs I tried and failed to boot:

1. Aeon
2. Korean stock based rom
3. Scott's CleanROM
4. Rayglobe 3.2
5. Rayglobe Flex ROM v4

Now, I know that sometime ROMs take time to boot on the first run, so I even tried leaving it at the blank screen for 15-20 mins with no result. Since it has been the same result for multiple ROMs, it definitely isn't a bad install or a bad ROM download either. I hope not

Is there anything I am missing in the steps? All ROMs were installed after factory resetting through TWRP (no dirty flash). I am baffled with this, please let me know if I need to revert to software version "d" for these ROMs to work?

TIA
Did you factory reset after as well? If I recall correctly Paranoid Android is AOSP. What kernel are you running?
 
rquiett
Old
#3  
rquiett's Avatar
Recognized Contributor
Thanks Meter 1403
Posts: 1,592
Join Date: Jan 2011
Location: Santa Rosa, CA

 
DONATE TO ME
sounds like you are onn the 10o update. You will need to flash back to stock 10d with lg flash tool and then root and install recovery again. Then you should be good to go on flashing roms. I know that some of the newest versions of TWRP and Philz have issues flashing some roms too so that may also be the cause. If you downgrade the recovery you have to the version right before it may fix your issue also

"The flames of freedom. How lovely. How just. Ahh, my precious anarchy... "
 
vish9
Old
#4  
Junior Member - OP
Thanks Meter 4
Posts: 20
Join Date: Mar 2013
Quote:
Originally Posted by joebob296 View Post
Did you factory reset after as well? If I recall correctly Paranoid Android is AOSP. What kernel are you running?
Exactly, AOSP ROMs are booting up fine but not the Stock based ones.. I am not flashing any kernels, just the ROM, so I'm assuming it will run on either the stock kernel or the kernel included in the ROM zip?
Have you been successful in installing such ROMs? Am I missing something in the wiping part? Only been doing the factory reset in TWRP before installing any ROM.
 
joebob296
Old
#5  
Senior Member
Thanks Meter 21
Posts: 235
Join Date: Aug 2010
Check m
And make sure that you are running the stock kernel. Are you on the 10o update?

Sent from my LG-D801 using Tapatalk
 
vish9
Old
#6  
Junior Member - OP
Thanks Meter 4
Posts: 20
Join Date: Mar 2013
Quote:
Originally Posted by rquiett View Post
sounds like you are onn the 10o update. You will need to flash back to stock 10d with lg flash tool and then root and install recovery again. Then you should be good to go on flashing roms. I know that some of the newest versions of TWRP and Philz have issues flashing some roms too so that may also be the cause. If you downgrade the recovery you have to the version right before it may fix your issue also
Oh, I hadn't thought about anything being wrong with the recovery.. Always assumed it gets the work done
How do I find previous versions of TWRP compatible with D800?
 
vish9
Old
#7  
Junior Member - OP
Thanks Meter 4
Posts: 20
Join Date: Mar 2013
Quote:
Originally Posted by joebob296 View Post
Check m
And make sure that you are running the stock kernel. Are you on the 10o update?

Sent from my LG-D801 using Tapatalk
Yes I am on 10o.. Does it have issues with installing other Stock ROMs? If yes, I'll try to follow the thread on using LGFlash tools, I've never done that before. Hopefully its not much difficult to follow the instructions.
 
joebob296
Old
(Last edited by joebob296; 18th February 2014 at 01:54 AM.)
#8  
Senior Member
Thanks Meter 21
Posts: 235
Join Date: Aug 2010
That is one of the easiest guides to follow. Be sure to follow the correct set of instructions(depends on carrier) and download the the 10d version.

Sent from my LG-D801 using Tapatalk
 
vish9
Old
#9  
Junior Member - OP
Thanks Meter 4
Posts: 20
Join Date: Mar 2013
Quote:
Originally Posted by joebob296 View Post
That is one of the easiest guides to follow. Me sure to follow the correct set of instructions(depends on carrier) and download the the 10d version.

Sent from my LG-D801 using Tapatalk
Thanks.. I'll try to do it tonight and post my results here.
 
vish9
Old
#10  
Junior Member - OP
Thanks Meter 4
Posts: 20
Join Date: Mar 2013
Quote:
Originally Posted by joebob296 View Post
Be sure to follow the correct set of instructions(depends on carrier) and download the the 10d version.

Sent from my LG-D801 using Tapatalk
I'm stuck in the process! Can't change the com port number to 41. The guide is pretty easy to understand. But when I put my phone is download mode and try to change the com port number, it says I don't have the write privileges for this device's setting. I've tried it on both Win 7 and Win 8 laptops, with LG mobility drivers installed.
Is there something in the phone settings I need to enable so that I get the write privileges to change com port number?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Remove Unnecessary WhatsApp Elements with Xposed

In modern life, you can’t underestimate the power ofthe dark sidemessaging … more

MaR-V-iN to Talk Google and Android APIs at XDA:DevCon 2014

Our international xda:devcon 14in Manchester, UK on the weekend of September … more