Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,761 Members 41,776 Now Online
XDA Developers Android and Mobile Development Forum

[TUT][CM7]How to put sound with bootanimation

Tip us?
 
nims11
Old
(Last edited by nims11; 11th October 2011 at 01:22 PM.)
#1  
Recognized Contributor / Recognized Developer - OP
Thanks Meter 4252
Posts: 1,824
Join Date: Aug 2011
Location: Ahmedabad

 
DONATE TO ME
Wink [TUT][CM7]How to put sound with bootanimation

This is tutorial for how to put sound with boot animation

first download attached file bootsound.zip
then extract it
you find two files
one is bootsnd.sh put this file directly in sdcard
second file is soundatboot.zip it is cwm flashable zip so in cwm mount system and sdcard then install this zip file
then reboot

now open terminal eluminator
then type following(after each command push enter)

su
cd /sdcard (there is space after cd )
sh bootsnd.sh
reboot


now when reboot there is music with bootanimation

when want to change music rename your desire sound to android_audio.mp3 and copy to system/media/
then reboot
Attached Files
File Type: zip bootsound.zip - [Click for QR Code] (606.8 KB, 4613 views)
The Following 24 Users Say Thank You to nims11 For This Useful Post: [ Click to Expand ]
 
rsgarcia888
Old
(Last edited by rsgarcia888; 11th October 2011 at 12:54 PM.)
#2  
Senior Member
Thanks Meter 15
Posts: 264
Join Date: Apr 2011
i have this error in terminal emulator:

cd /sdcard: not found

edited: now ok!!!! (there should be space after cd )
 
AlterJack
Old
#3  
AlterJack's Avatar
Senior Member
Thanks Meter 47
Posts: 114
Join Date: Sep 2011
Location: Panama
Hold on: first, clean up the article a little more, I can't understand you very well.
Second, explain a little bit more about that script your using; what it does and whatnot.
I may know what is going on in here but what about the newbs? C'mon, do it better mate Thanks!
If I said something that helped you, don't hesitate to press the little "Thanks!" button!


Thanks RobertsAccount for the awesome siggie!
 
nims11
Old
#4  
Recognized Contributor / Recognized Developer - OP
Thanks Meter 4252
Posts: 1,824
Join Date: Aug 2011
Location: Ahmedabad

 
DONATE TO ME
Quote:
Originally Posted by AlterJack View Post
Hold on: first, clean up the article a little more, I can't understand you very well.
Second, explain a little bit more about that script your using; what it does and whatnot.
I may know what is going on in here but what about the newbs? C'mon, do it better mate Thanks!
In which part you not understand tell ill make more clear
first you installed soundatboot.zip by cwm?
And put bootsnd.sh file in sdcard?
 
rsgarcia888
Old
#5  
Senior Member
Thanks Meter 15
Posts: 264
Join Date: Apr 2011
Quote:
Originally Posted by AlterJack View Post
Hold on: first, clean up the article a little more, I can't understand you very well.
Second, explain a little bit more about that script your using; what it does and whatnot.
I may know what is going on in here but what about the newbs? C'mon, do it better mate Thanks!
if uve done flashing ur device to CM7, more or less u have an idea how to do it
 
febriantosaka1
Old
#6  
febriantosaka1's Avatar
Senior Member
Thanks Meter 20
Posts: 102
Join Date: Nov 2010
Location: Gotham
it works ! thanks...
I'M USING
Cobrato Miui 2.3.2 (GB 2.3.7) (bb71)
DooMKernel V6




Thank's To All Devs and Mods on XDA Xperia X10
 
uman01
Old
(Last edited by uman01; 13th October 2011 at 01:09 AM.)
#7  
uman01's Avatar
Member
Thanks Meter 5
Posts: 44
Join Date: Mar 2011
Location: DKI jakarta
hello, i already followed your guide without error, but i still couldn't get any sound when booting, im using cm7 kaang beta2,
i also changed my boot animation from THIS thread.

should i change the bootanimation back to the stock animation from cm7?

oh yeah, i also tested it by putting mp3 files in the /system/media where the bootanimation also exists, still,no luck so far,

don't know where it go wrong, since i didn't get any error when running the command in terminal, and when installing the soundaboot.zip, i didn't get any error message either in the cmw
 
nims11
Old
#8  
Recognized Contributor / Recognized Developer - OP
Thanks Meter 4252
Posts: 1,824
Join Date: Aug 2011
Location: Ahmedabad

 
DONATE TO ME
Quote:
Originally Posted by uman01 View Post
hello, i already followed your guide without error, but i still couldn't get any sound when booting, im using cm7 kaang beta2,
i also changed my boot animation from THIS thread.

should i change the bootanimation back to the stock animation from cm7?

oh yeah, i also tested it by putting mp3 files in the /system/media where the bootanimation also exists, still,no luck so far,

don't know where it go wrong, since i didn't get any error when running the command in terminal, and when installing the soundaboot.zip, i didn't get any error message either in the cmw
First in cwm mount system
then install soundatboot.zip
then reboot
then in terminal elumilator write commands
it works
 
pico.marco
Old
#9  
Junior Member
Thanks Meter 2
Posts: 25
Join Date: May 2011
It works (Cyanogenmod). Many thanks!
 
rsgarcia888
Old
#10  
Senior Member
Thanks Meter 15
Posts: 264
Join Date: Apr 2011
how about shutdown sound?

please help...thanks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes