5,604,367 Members 48,819 Now Online
XDA Developers Android and Mobile Development Forum

[Q] No rule to make target libtime_genoff.so

Tip us?
 
gakio12
Old
#1  
gakio12's Avatar
Senior Member - OP
Thanks Meter 98
Posts: 169
Join Date: Dec 2011

 
DONATE TO ME
Default [Q] No rule to make target libtime_genoff.so

I am trying to build CM-11 but I keep getting stopped on
Code:
make: *** No rule to make target `/home/gakio12/cm11/out/target/product/hlte/obj/lib/libtime_genoff.so', needed by `/home/gakio12/cm11/out/target/product/hlte/obj/SHARED_LIBRARIES/libandroid_runtime_intermediates/LINKED/libandroid_runtime.so'.  Stop.
 '
Everything was changed from hlte-common to hlte in device/samsung, but in vendor/samsung, it remains hlte-common. I'm not sure if this is the problem, but renaming the directory to 'hlte' did nothing.

This is in my hlte-common-vendor.mk file in vendor/samsung/hlte-common:
Code:
PRODUCT_PACKAGES += libtime_genoff

$(call inherit-product, vendor/samsung/hlte-common/hlte-common-vendor-blobs.mk)
Does anyone know how I can start to diagnose the problem? libtime_genoff.so is in vendor/samsung/hlte-common, but I have a feeling it is supposed to be elsewhere now that the devices are 'unified'.
 
mrjaydee82
Old
#2  
mrjaydee82's Avatar
Senior Member
Thanks Meter 5700
Posts: 4,123
Join Date: Apr 2010
Location: Naples, FL

 
DONATE TO ME
Quote:
Originally Posted by gakio12 View Post
I am trying to build CM-11 but I keep getting stopped on
Code:
make: *** No rule to make target `/home/gakio12/cm11/out/target/product/hlte/obj/lib/libtime_genoff.so', needed by `/home/gakio12/cm11/out/target/product/hlte/obj/SHARED_LIBRARIES/libandroid_runtime_intermediates/LINKED/libandroid_runtime.so'.  Stop.
 '
Everything was changed from hlte-common to hlte in device/samsung, but in vendor/samsung, it remains hlte-common. I'm not sure if this is the problem, but renaming the directory to 'hlte' did nothing.

This is in my hlte-common-vendor.mk file in vendor/samsung/hlte-common:
Code:
PRODUCT_PACKAGES += libtime_genoff

$(call inherit-product, vendor/samsung/hlte-common/hlte-common-vendor-blobs.mk)
Does anyone know how I can start to diagnose the problem? libtime_genoff.so is in vendor/samsung/hlte-common, but I have a feeling it is supposed to be elsewhere now that the devices are 'unified'.
I'm trying to figure out the same issue as you
 
gakio12
Old
#3  
gakio12's Avatar
Senior Member - OP
Thanks Meter 98
Posts: 169
Join Date: Dec 2011

 
DONATE TO ME
I figured out the problem; make sure you have revision="wip" at the end of the kernel and TheMuppets lines of your local_manifest.xml.
The Following User Says Thank You to gakio12 For This Useful Post: [ Click to Expand ]
 
mrjaydee82
Old
#4  
mrjaydee82's Avatar
Senior Member
Thanks Meter 5700
Posts: 4,123
Join Date: Apr 2010
Location: Naples, FL

 
DONATE TO ME
Quote:
Originally Posted by gakio12 View Post
I figured out the problem; make sure you have revision="wip" at the end of the kernel and TheMuppets lines of your local_manifest.xml.
Awesome that worked
 
ZION959
Old
(Last edited by ZION959; 19th February 2014 at 07:09 AM.)
#5  
ZION959's Avatar
Senior Member
Thanks Meter 331
Posts: 302
Join Date: Jun 2012
Location: Phoenix

 
DONATE TO ME
Quote:
Originally Posted by gakio12 View Post
I figured out the problem; make sure you have revision="wip" at the end of the kernel and TheMuppets lines of your local_manifest.xml.
Hi I'm a noob, Can you please give me a little bit more details how to fix this problem please. I'm still learning. Thanks


HI thanks for give me some hints. Just figure it out.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes