Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Help making OTG cable with power (solved)

OP ITW2

14th February 2014, 08:26 PM   |  #1  
OP Member
Thanks Meter: 1
 
43 posts
Join Date:Joined: Aug 2009
Hi

Iv'e tried a lot of the guides on how to make the OTG cable with power but I can't get it to work.


What I tried:

The OTG cable I have from before, but I need it to deliver power.
Every thing works with no power connected, but as soon as i apply power it wont work.

I've been trying to cut the cable in the middle only the red and the black wire, and than ad power to those cables from an usb adapter but as soon as I add power the OTG stops working, and my nexus is not charging.

Iv'e tried adding double the power, cut the black and red wire in the OTG cable, than add 2 USB adapters one sending power to the female USB and one sending power to the micro USB for the Nexus, still nothing.

Tried adding power to black going to both devices and red only to nexus, still nothing.

What am I doing wrong?
Last edited by ITW2; 15th February 2014 at 01:48 PM.
14th February 2014, 11:20 PM   |  #2  
Junior Member
Thanks Meter: 4
 
25 posts
Join Date:Joined: Dec 2012
Are you using a kernel that supports USB OTG charging? To get mine to charge I have to plug the power into the OTG cable and then plug it into my device.
14th February 2014, 11:26 PM   |  #3  
OP Member
Thanks Meter: 1
 
43 posts
Join Date:Joined: Aug 2009
Hi
Im using timurs kernel seence im going to install it in my car
15th February 2014, 03:26 AM   |  #4  
Senior Member
Thanks Meter: 104
 
172 posts
Join Date:Joined: Jul 2012
isn't there a sequence to how you connect it, even with timurs?
like otg first then plugging in the charging USB.
15th February 2014, 12:12 PM   |  #5  
OP Member
Thanks Meter: 1
 
43 posts
Join Date:Joined: Aug 2009
Quote:
Originally Posted by dilldoe

isn't there a sequence to how you connect it, even with timurs?
like otg first then plugging in the charging USB.

I think i tried them all.
Bit also when its mounted inn The car i cant do an sequence every time i start The car
15th February 2014, 01:46 PM   |  #6  
OP Member
Thanks Meter: 1
 
43 posts
Join Date:Joined: Aug 2009
I found the problem.
The people making the OTG cable have had some fun and used white cable for power and red for data, no wounder I couldn't get it to work
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes