Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

USB cable issues...

OP wil2bm

19th February 2014, 06:15 PM   |  #1  
OP Member
Thanks Meter: 1
 
57 posts
Join Date:Joined: Aug 2011
So Ive looked around to see if people are having the same problem I'm Having and can't find **** so please help! I've tried 3 cables and one would hold the charge But not charge it and the other 2 take over 6 hours to charge the phone. Have used 2 of the 3 on my s3 and had no issues. The only cable I can get to work right is the one it came with. Have tried other wall chargers as well. Any suggestions?
19th February 2014, 06:48 PM   |  #2  
cazman420's Avatar
Member
Thanks Meter: 1
 
46 posts
Join Date:Joined: Dec 2010
Use galaxy charging current app. It will tell you how many milliards your cable and charger put out. As cords get older they won't put out as much. Sounds odd but true. Went thru all my cables including the official Samsung cable. Which only allowed 800 to 1100 m.a. my new nexus cable allowed the full 1800 m.a. y.m.m.v.

Sent from my SCH-I605 using XDA Premium 4 mobile app
19th February 2014, 07:29 PM   |  #3  
OP Member
Thanks Meter: 1
 
57 posts
Join Date:Joined: Aug 2011
Will try that but two of the cords were brand new and the other one a few months maybe? And they seem to work fine with other phones.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes