Default [Q] cannot install cynagenmod on p920 with ics 4.0.4. Currently using p-vlad's rom

i am currently using ics 4.0.4. i cannot install cynagenmod 10.1 on my phone. it aborts anytime i try. neither can i install bernies new rom. Currently using p-vlad's rom. please help.