Post Reply

Exclamation [Q] Problems with flashing LG firmware

OP BauhausPen

23rd September 2013, 01:59 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Apr 2012
Hello. I've searched the forums and looked at guides and people with similar problems previously.
I've soft bricked my phone, stuck at:

Secure booting Error!
Cause : boot certification verify.


I rooted it using the E980 universal rooting tool from giantpune from ballshanglow's post. I then unlocked it using FreeGee 1.10, installed TWRP 2.6.1.0.

Upon reboot, the phone was stuck with the above error. I have downloaded the relevant .kdz for my phone, installed the USB drivers and the LG flashing tool. I have uninstalled and reinstalled the drivers (trying out different versions) and also tried various versions of the LG flashing tool (KDZ_FW_UPD_EN & FlashTool.1.0.54). I have also tried to use LG's provided software to recover my phone.

The furthest I've been able to go in the recovery/stock-firmware-flashing process, is the device check. Despite have 99%+ battery according to TWRP, I still get the error that my phone (in download mode) has low battery. Other times, the flashing tool freezes up and becomes not-responding after I get an extract error, or after I click 'Reading phone information'.

I've tried everything I could find. I've also attempted to flash a custom rom, but I get:
Assert failed: getpropr("ro.product.device") == "geefhd_att_us" ||
getprop("ro.build.product") == "geefhd_att_us"
E:Error executing updater binary in zip.


I'M F***ING STUCK. I'VE TRIED POSITIVELY EVERYTHING I COULD FIND.
Is there anything you guys can suggest I try before I send it to LG to have it returned to stock?

Thank you very much, and sorry I'm a noob. I tried.
23rd September 2013, 02:04 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Apr 2012
My phone's model name is E988, firmware version E98810A_00
23rd September 2013, 03:45 PM   |  #3  
Member
Thanks Meter: 6
 
31 posts
Join Date:Joined: Jan 2011
Unhappy
Quote:
Originally Posted by BauhausPen

My phone's model name is E988, firmware version E98810A_00


I experienced exactly the same with my E986: bootloader unlock+installing CWM recovery with "freeGee".

It seems their bootloader unlock is not good.

Flahing with r&D tool is interrupted with this "low battery" message.

help!
The Following User Says Thank You to xifizurk For This Useful Post: [ View ]
23rd September 2013, 04:57 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by xifizurk

I experienced exactly the same with my E986: bootloader unlock+installing CWM recovery with "freeGee".

It seems their bootloader unlock is not good.

Flahing with r&D tool is interrupted with this "low battery" message.

help!

Dude. I fixed it. Apparently, I just didn't leave my phone to be connected to the computer long enough before beginning the recovery/restoration process. Connect your phone to your computer in download mode for 3 minutes and LEAVE IT.

You can check Printers and Devices to see if your computer has recognised your phone. That's all I can say.

GOOD LUCK.
24th September 2013, 12:27 AM   |  #5  
Member
Thanks Meter: 6
 
31 posts
Join Date:Joined: Jan 2011
still problem with "UpTestEX.exe" r&d test tool
still no luck for me.
In download mode the phone appears to be properly recognised by my win7 pc.
waited more than 3 minutes before proceeding
all the same the flashing process exits with the "unsufficient battery level" message.

here the last lines of the "R&D test tool"log before it exits:


23:53:50 : *****Get ESN / IMEI / MEID Start*****
23:53:50 : ESN/IMEI/MEID : xxxxxxxxxxxxxxx
23:53:53 : Check Backup and Restore model
23:53:53 : Phone type Compare start
23:53:53 : *****Start _GetBatteryLevel*****
23:53:53 : ******************************
23:53:53 : Battery(1)
23:53:53 : You can't continue the process due to lack of battery power.\nRecharge the phone battery fully and retry.
23:53:56 : ~~~~~~~~~~~~~~~~~~~~
23:53:56 : !pUpgrade->StartProcessing ... PostMsg STEP_TYPE_ENV_ERROR
23:53:56 : Page_Error 부분입니다
23:53:56 : OnStepMsg STEP_TYPE_ENV_ERROR delete m_pLGCyonUpdate

(being quite sure there is enough charge in the battery)

very thankful for any hints
Last edited by xifizurk; 24th September 2013 at 12:32 AM.
24th September 2013, 04:36 AM   |  #6  
Senior Member
Thanks Meter: 38
 
178 posts
Join Date:Joined: Mar 2008
Quote:
Originally Posted by xifizurk

still no luck for me.
In download mode the phone appears to be properly recognised by my win7 pc.
waited more than 3 minutes before proceeding
all the same the flashing process exits with the "unsufficient battery level" message.

here the last lines of the "R&D test tool"log before it exits:



23:53:50 : *****Get ESN / IMEI / MEID Start*****
23:53:50 : ESN/IMEI/MEID : xxxxxxxxxxxxxxx
23:53:53 : Check Backup and Restore model
23:53:53 : Phone type Compare start
23:53:53 : *****Start _GetBatteryLevel*****
23:53:53 : ******************************
23:53:53 : Battery(1)
23:53:53 : You can't continue the process due to lack of battery power.\nRecharge the phone battery fully and retry.
23:53:56 : ~~~~~~~~~~~~~~~~~~~~
23:53:56 : !pUpgrade->StartProcessing ... PostMsg STEP_TYPE_ENV_ERROR
23:53:56 : Page_Error 부분입니다
23:53:56 : OnStepMsg STEP_TYPE_ENV_ERROR delete m_pLGCyonUpdate

(being quite sure there is enough charge in the battery)

very thankful for any hints

If you run it on windows 7, just right click on "UpTestEX.exe", choose "properties", choose "Compatibility", on tab "Compatibility mode" tick "Run this Program in compatibility mode for" and choose " Windows 7", after that, Apply and Ok.
So the issue is gone.
Goodluck.
25th September 2013, 10:26 PM   |  #7  
Member
Thanks Meter: 6
 
31 posts
Join Date:Joined: Jan 2011
Battery Low Sorry Guys,
(It was indeed a battery problem)
sorry this was a premature conclusion
Last edited by xifizurk; 26th January 2014 at 08:44 PM.
27th September 2013, 01:35 PM   |  #8  
Member
Thanks Meter: 6
 
31 posts
Join Date:Joined: Jan 2011
but please take care with "uptest.exe"...
Quote:
Originally Posted by xifizurk

It was indeed a battery problem

tried again to flash the original .kdz with a running cyanogen mod 4.3 on the phone and with more than enough battery ...and i couldn't.
Again interrupted with the "low-battery" warning.
hm...
would be nice to have something easier and less tricky!
27th September 2013, 02:59 PM   |  #9  
Senior Member
Thanks Meter: 38
 
178 posts
Join Date:Joined: Mar 2008
Quote:
Originally Posted by xifizurk

tried again to flash the original .kdz with a running cyanogen mod 4.3 on the phone and with more than enough battery ...and i couldn't.
Again interrupted with the "low-battery" warning.
hm...
would be nice to have something easier and less tricky!

If you are running Windows 7, right click on Up TestEX.exe in flash tool 1.0.5.4 folder, choose Properties, choose Compatibility, tick "Run this program in compatibility mode for" and choose "Windows 7", choose "Apply" and choose "OK".
After all, run "Up TestEX.exe" again, it doesn't ask about your battery.
Googluck.
28th September 2013, 07:14 AM   |  #10  
Jammol's Avatar
Senior Member
Flag Fort Collins
Thanks Meter: 319
 
1,193 posts
Join Date:Joined: Apr 2012
Donate to Me
More
Charge the phone all the way, then it'll work.

Sent from my LG-E980 using XDA Premium 4 mobile app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Optimus G Pro Q&A, Help & Troubleshooting by ThreadRank