Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Disable hardware buttons

OP DerGreeny

26th February 2014, 09:12 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Feb 2014
Hi,
I would like to disable the hardware buttons from my Galaxy Tab 3 7.0 since I already made the softkeys visible by changing the /system/build.prop file.

I found HowTo's for other Samsung devices. All of them proposed a modification of the /system/usr/keylayout/Generic.kl file by deactivating the mappings for the keys 139, 158 and 172 (see this thread). Unfortunately, this isn't working for my Tab 3.

Can someone give my advice in this topic?

Thanks in advance,
Greeny
LiquidSmokeX64
27th February 2014, 12:52 AM   |  #2  
Guest
Thanks Meter: 0
 
n/a posts
Im curious what edit you made to enable the soft keys

Sent from my SM-T217S using XDA Premium 4 mobile app
27th February 2014, 01:52 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Feb 2014
I added qemu.hw.mainkeys=0 to the end of /system/build.prop. If you are interested in the source I could post a link, even if I'm not sure whether external links are accepted.
27th February 2014, 11:15 PM   |  #4  
Member
Thanks Meter: 11
 
63 posts
Join Date:Joined: Apr 2009
I've got mine disabled and all you do is put # in front of the key mappings.

What I want to know is how to switch the back key (which defaults to the right) and the menu key (which defaults to the left). It's a pain to have the back key on the right.

Anyone know how to swap them, I've tried different steps for galaxy devices and nothing's working.
28th February 2014, 09:04 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Feb 2014
Thanks for your answer, but this isn't working for me. I prepended the 3 lines with a # and rebooted the device. But the three hardware buttons are still working
28th February 2014, 09:57 AM   |  #6  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by linkboy

I've got mine disabled and all you do is put # in front of the key mappings.

Do you talk about the mappings in the Generic.kl file? I just opened the other *.kl files and noticed keymappings for the same keys in many other files, like vnc-kbd.kl
28th February 2014, 11:31 AM   |  #7  
Member
Thanks Meter: 11
 
63 posts
Join Date:Joined: Apr 2009
Quote:
Originally Posted by DerGreeny

Do you talk about the mappings in the Generic.kl file? I just opened the other *.kl files and noticed keymappings for the same keys in many other files, like vnc-kbd.kl

Open up sec_touchscreen.kl and place a # in front of key 139 MENU and key 158 BACK.

This will disable the Samsung buttons.
28th February 2014, 12:35 PM   |  #8  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by linkboy

Open up sec_touchscreen.kl and place a # in front of key 139 MENU and key 158 BACK.

This will disable the Samsung buttons.

Thank you! The back button is disabled but the center Home button is still working. Any advice for this?
28th February 2014, 12:47 PM   |  #9  
Recognized Developer
Flag Bekasi
Thanks Meter: 9,405
 
3,542 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Quote:
Originally Posted by DerGreeny

Thank you! The back button is disabled but the center Home button is still working. Any advice for this?

Comment out HOME button in gpio-keys.kl
28th February 2014, 01:53 PM   |  #10  
OP Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by ketut.kumajaya

Comment out HOME button in gpio-keys.kl

Thank you! That solved it!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes