Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

S-Note/Scrapbook/Action Memo on Rooted S4

OP shaji_ka_71

18th September 2013, 03:58 PM   |  #1  
shaji_ka_71's Avatar
OP Senior Member
Flag Navi Mumbai
Thanks Meter: 201
 
253 posts
Join Date:Joined: Jan 2012
More
Update 24
Updated 4.4.2 files
http://forum.xda-developers.com/show...&postcount=819


Magazine Fix --> http://forum.xda-developers.com/show...&postcount=823


************************************************** ************************************
Update 23
Multiwindow - add features Check the posts below.
http://forum.xda-developers.com/show...&postcount=643
http://forum.xda-developers.com/show...&postcount=646

************************************************** ************************************************** ************
Update 22
OneHand Feature
Link to File --> https://www.mediafire.com/?sccd66a49vj4d4n
Link to details of how to setup -->http://forum.xda-developers.com/show...&postcount=586

************************************************** ************************************************** ************
MediaFire Link to download the files till Update 21 for S4 version 4.3. Posted on Mediafire as Hotfile has shutdown
http://www.mediafire.com/download/ec...9f/SKA_Dev.zip

************************************************** ***********************************
Update 21
Galaxy Finder
http://forum.xda-developers.com/show...&postcount=456
************************************************** ********************************************
Update 20
Screenwrite/Flash Annotate
http://forum.xda-developers.com/show...&postcount=455
************************************************** *********************************************
Update 19
Thanks to Leeomendes, we have a flashable zip that is working on i9500 and i9505 for Android 4.3

This has all the functionality ported so far - SNote, ScrapBook, SnameCard, ActionMemo and MyMagazine.

http://forum.xda-developers.com/show...&postcount=444
************************************************** **************************************************
Update 18
Action Memo Save FC fixed for 4.3

Unzip the file, delete the three original files from the mobiles system/app directory, if possible clear cache and reboot and then copy over these to the system/app directory. Fix permissions and reboot.
https://hotfile.com/dl/256442066/351..._Memo.zip.html

Link to details of how it was fixed --> http://forum.xda-developers.com/show...&postcount=418
************************************************** *******************************************
Update 17 - Found an additional utility in the note 3 rom --> SNameCard (Utility to read the visiting card and recognize the data in it)

Link --->https://hotfile.com/dl/255716519/7b4...eCard.zip.html

Copy the apk to System/app
Copy the .so files to the system/lib
Fix permissions on all the copied files to rw-r--r--
You can use this in Contacts when you add a person a small icon for SnameCard appears, use it to read the visiting cards and convert the data in it.
************************************************** *********
Update 16
Link for a new version of Scrapbook. This has the memo taking feature that was crashing due to check on Chinese Language that I have disabled to have it working.
Copy the APK to the System Directory.
The Contents of MUL to System/VODB/MUL
and the .lib files if not existing already to the system/lib

Link --> https://hotfile.com/dl/255128094/c51...board.zip.html

For People who have issues with images not getting copied in scrapbook after installing the latest update, try adding the additional smartclip files from the post
http://forum.xda-developers.com/show...&postcount=387


*************************************************
Update 15
Thanks to Leeomendes we have a flashable zip for the 4.3 Action Memo and SNote. So no need to manually copy and fix permissions. Check his post below for the download link
http://forum.xda-developers.com/show...&postcount=289
************************************************** *******************
Update 14:
With the release of 4.3 I have been re-checking the files used and have tried all over again with the latest files for Note 3 on S4.
I have been successful. I will be updating the files shortly. These files will ensure that we have the latest SNote and Action Memo files and SNote's all the features are functioning including that of Magic chart and maps as well.


Will post the link shortly---> Check Post 241 -->http://forum.xda-developers.com/show...&postcount=241

MagazineHome --> http://forum.xda-developers.com/show...&postcount=261
************************************************** ******************************************

Update 13 - Action Memo is in progress, working well except while saving it FC's but saves the memo. Still testing and figuring out how I managed to get it working. Had Copied and Deleted so many files.. Will post once confirmed.
Check Screenshots on my post in 213.
----------------------------------------------------- -------------
THE UPDATES ABOVE ARE FOR 4.3
THE UPDATES BELOW ARE FOR 4.2.2
************************************************** ***********************************************
Update 12 - Reboot Force Close in S-Note got fixed (Accidently). Check details in my post in the page 17 of this thread link given below
http://forum.xda-developers.com/show...449311&page=17

Update 11
Fixed some additional issues found in Scrapbook. This is the Pinboard main APK file and only this needs to be copied. The Other supporting files have not been modified at all.
https://hotfile.com/dl/249126479/de2...-Key1.apk.html

Check the conversations on Page 16 of this thread if scrapbook is crashing and should help you all to fix the issues.

This file below was potentially missing in the earlier uploaded zip. Pls copy to system\app and set permission and reboot in case Scrapbook crashes on starting.
https://hotfile.com/dl/249096606/32f...vider.apk.html

Update 10 Scrapbook
Use this file instead of the main Scrapbook File from the update 9 zip file to rectify issues with Videos &Youtube links in Scrapbook.
https://hotfile.com/dl/249073254/946...d-Key.apk.html
I found that in the scrapbook while editing and adding a drawing to a picture, it crashes. Reason is a missing notes file in the System\VODB\MUL
Find attached below the link to the zip of the mul directory from one of the recent note 3 rom. Extracting and copying the files from the zip to the MUL directory and fixing the permissions is now saving the drawings to the pictures in the scrapbook contents
https://hotfile.com/dl/249073493/0c5640d/mul1.zip.html

************************************************** ************************
Update 9 (Scrapbook)
ScrapBook has been fixed.
Link --> https://hotfile.com/dl/249044414/53a...pBook.zip.html

Unzip File and copy to following directories and fix permission and re-boot
Pin-SignKey.apk --> System\App
SmartClipService.apk -->System\App
LibSmartClipEffect.so --->System\Lib


************************************************** ************************************************** ***********************
Update 8 - Some good news on maps
I have been successfull in activating the maps function in snote. As this requires a key to authenticate and potentially google can charge the key owner in case of excessive usage of maps, hence I am not in a position to publish the apk file I managed to generate. Hope you all respect this decision of mine.
I would suggest that you try and generate if interested the keys and activate the maps. Pls note the "Capture functionality is still not fixed in maps"
There are a few activities to be done to activate the maps.
1) Create your own keys. There are lot's of documentation out there on google that you can search for, here is a sample ---> http://jmlinnik.blogspot.in/2011/12/keystores.html
2) Once the keys are created you can register at the below google site for the maps API Key. This is a great tutorial for the same --> http://www.vogella.com/articles/Andr...s/article.html ( Pls note you need the SHA1 hash of the keys and the package name. keep the package name as it is. Package name can be found in the file below (AndroidManifest.xml)
3) Sign the APK file with your own private and public keys. Use the latest Snote3.xxx.apk file from my posts and run apktool (Using apktool guide --> http://forum.xda-developers.com/show....php?t=1891686) and convert the same into smali files.
Before you convert it back to the apk again with apktool, pls edit the AndroidManifest.xml file and replace the android value below ith the API Key you got from google

4)the apk file would be created in the dist folder. Now all you need to do is to sign it with your keys.
below is the command line option replace the "testkey.x509.pem" & "testkey.pk8" with the names of the files you generated in step 1. File.apk is the apk file name you want to sign and File-Signed.apk is the signed file you want to create.
java -Xmx1024m -jar signapk.jar -w testkey.x509.pem testkey.pk8 FILE.apk FILE-signed.apk
Signapk.jar can be downloaded. Pls search using google
Once Successful, copy the signed apk file into system\app and re-boot and you should be able to get the maps active now on the S Note.
My special thanks to all the authors of the above links
***********************************************
Update 7 - Maps. (Bad News)
Unfortunately, google gives an API Key for access of the google maps application and as we have been changing the APK and signing it with a key different from what Samsung uses, there is an authentication failure.
https://developers.google.com/maps/d...e_maps_api_key
Don't think we can solve this as long as we use a different key to sign the app.
Any Ideas from any one will be appreciated.
************************************************** ***********************
Update 6

IdeaSketch Fixed
https://hotfile.com/dl/247601284/373...s-Fix.apk.html

Note: - the files in Update 6 and Update 5 are APKs for IdeaSketch and Magic Chart and needs to be copied into the System\App directory. Permissions needs to be fixed and re-start. As usual after re-start don't forget to install the SPenSdk3.apk
Also pls note that I have copied the files that Arsaw had extracted from from Note 3 into the VODB Directory. I had copied the contents of the VODB\Lib from his extract to my System\VODB\Lib and fixed permissions. Pls do this also in case the IdeaSketch or MagicChart fails. In case of doubt pls ask any of the senior members and do not mess around with any other Lib directories

************************
Update 5
Magic Chart File has been fixed ...thanks all for the help.. Magic chart is sheer magic!

https://hotfile.com/dl/247593406/b16...b-Sig.apk.html

Update - Some Minor Errors still persists.. but many of the Magic chart Functions are now active
What works - Editing charts, modifying the Chart template and editing the chart data in it, making tables and creating chart from the tables etc.
Directly creating the Charts from the menu seems to crash at the moment after we draw the lines manually.
************************************************** ****************
New Download Links due to drop box suspension
https://hotfile.com/dl/247208157/176....Art1.apk.html
https://hotfile.com/dl/247209485/f8f...nSdk3.apk.html

*********************************************
Update 4 -> Clipart Fixed

Download Link --> https://dl.dropboxusercontent.com/u/...note3.Art1.apk
************************************************** ************************************************** *********************************************
Update 3
Youtube Video Issue Fixed.
Download Link --> https://dl.dropboxusercontent.com/u/...Snote3YouT.apk

Note All new fixes carry the old fixes too. So pls download the file in the latest update. You can rename the downloaded file to any name you want. I am just naming it based on the latest issue fixed.
************************************************** ************************************************** ************************************
Update 2
This should fix the Issue of Illustration --> Shape.
https://dl.dropboxusercontent.com/u/...FixedShape.apk
************************************************** ************************************************** **********************************************
Update 1: I managed to modify the SNote3.Apk and seem to have resolved the issue of app crash on saving document. Need Volunteers to test

Delete the old file from System\App using root explorer. Copy the new file, fix permission, reboot. Then install the SPenSDK3.apk
file and then try opening/creating new notes and saving. Seems to be working fine for me. Saves the document then goes to display mode of the saved note.

Download Link --> https://dl.dropboxusercontent.com/u/...e3FixedSig.apk

Download of SPenSDK3 --> https://dl.dropboxusercontent.com/u/...5/SPenSdk3.apk (Unmodified, no need to download if the old one is there with you)

Please test and inform
************************************************** ************************************************** ***************************
Attached Thumbnails
Click image for larger version

Name:	S-Note Widget.JPG
Views:	15338
Size:	69.2 KB
ID:	2266330   Click image for larger version

Name:	SNote.JPG
Views:	12552
Size:	44.1 KB
ID:	2266331  
Last edited by shaji_ka_71; 14th March 2014 at 06:23 AM.
The Following 35 Users Say Thank You to shaji_ka_71 For This Useful Post: [ View ]
18th September 2013, 05:20 PM   |  #2  
lancem71's Avatar
Senior Member
Flag Olathe, KS
Thanks Meter: 81
 
406 posts
Join Date:Joined: Sep 2008
Can you post those apks please?

Sent from my SCH-I545 using Tapatalk 4
18th September 2013, 05:49 PM   |  #3  
shaji_ka_71's Avatar
OP Senior Member
Flag Navi Mumbai
Thanks Meter: 201
 
253 posts
Join Date:Joined: Jan 2012
More
Attachment Links
Quote:
Originally Posted by lancem71

Can you post those apks please?

Sent from my SCH-I545 using Tapatalk 4

I am uploading to dropbox the two files. Will update once done

Pls note that while testing I found that after re-boot the S-Note once opened crashes, but can be fixed by re-installing the SPenSdk3 apk. Also during saving the notes created, though the notes get saved. Logcat gives the following error

E/AndroidRuntime( 5948): FATAL EXCEPTION: main

E/AndroidRuntime( 5948): java.lang.NoClassDefFoundError: com.samsung.android.secretmode.SecretModeManager

E/AndroidRuntime( 5948): at com.samsung.android.snote.control.core.filemanager .secretbox.SecretService.getSecretDir(SecretServic e.java:134)

E/AndroidRuntime( 5948): at com.samsung.android.snote.control.core.filemanager .secretbox.SecretBoxReceiver.onReceive(SecretBoxRe ceiver.java:39)
18th September 2013, 06:09 PM   |  #4  
shaji_ka_71's Avatar
OP Senior Member
Flag Navi Mumbai
Thanks Meter: 201
 
253 posts
Join Date:Joined: Jan 2012
More
Thumbs up Link to Download the two files
Quote:
Originally Posted by lancem71

Can you post those apks please?

Sent from my SCH-I545 using Tapatalk 4

https://dl.dropboxusercontent.com/u/53085065/S-Note.zip
Attached Thumbnails
Click image for larger version

Name:	S-Note Widget.JPG
Views:	4464
Size:	69.2 KB
ID:	2266313   Click image for larger version

Name:	SNote.JPG
Views:	4323
Size:	44.1 KB
ID:	2266314  
Last edited by shaji_ka_71; 18th September 2013 at 06:55 PM. Reason: Screenshots
18th September 2013, 07:20 PM   |  #5  
Senior Member
Flag Moscow
Thanks Meter: 26
 
179 posts
Join Date:Joined: Oct 2012
More
Does adding maps to a note work?
18th September 2013, 07:55 PM   |  #6  
shaji_ka_71's Avatar
OP Senior Member
Flag Navi Mumbai
Thanks Meter: 201
 
253 posts
Join Date:Joined: Jan 2012
More
Re:
Quote:
Originally Posted by DenethorLenwion

Does adding maps to a note work?

I find that there are some Note templates like "Travel" where there are fields called "Locations" that can use the map facility.
When I use that I find that the physical location gets picked up correctly though the map as such is showing blank.

Not sure if you were asking about the same thing or not
18th September 2013, 08:04 PM   |  #7  
shaji_ka_71's Avatar
OP Senior Member
Flag Navi Mumbai
Thanks Meter: 201
 
253 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by DenethorLenwion

Does adding maps to a note work?



Sorry ignore my previous message, I had enabled Droidwall and had enabled only a few apps access to internet. I forgot to enable SNote the access.

Now I have enabled it and SNote works fine. I can see the maps getting updated correctly
Attached Screen shots of the facility
Attached Thumbnails
Click image for larger version

Name:	Maps.JPG
Views:	3904
Size:	36.2 KB
ID:	2266503   Click image for larger version

Name:	Travel.JPG
Views:	4001
Size:	34.7 KB
ID:	2266504  
The Following User Says Thank You to shaji_ka_71 For This Useful Post: [ View ]
18th September 2013, 09:29 PM   |  #8  
Member
Thanks Meter: 2
 
48 posts
Join Date:Joined: Aug 2010
Great... downloading now..

Sent from my GT-I9500 using xda app-developers app
19th September 2013, 02:17 AM   |  #9  
Senior Member
Flag Washington, DC
Thanks Meter: 22
 
334 posts
Join Date:Joined: Dec 2005
More
Link now down
19th September 2013, 03:00 AM   |  #10  
shaji_ka_71's Avatar
OP Senior Member
Flag Navi Mumbai
Thanks Meter: 201
 
253 posts
Join Date:Joined: Jan 2012
More
Thumbs up
Quote:
Originally Posted by djide

Link now down

The Link https://dl.dropboxusercontent.com/u/53085065/S-Note.zip now seems to be ok. Pls check

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes