Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,064 Members 41,016 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] Home Button and WAKE BEHAVIOR issue

Tip us?
 
luisblop
Old
(Last edited by luisblop; 25th April 2014 at 05:03 PM.)
#1  
Member - OP
Thanks Meter 2
Posts: 62
Join Date: Feb 2014
Question [SOLVED] Home Button and WAKE BEHAVIOR issue

Hi, everyone

Recently I started using the Cover Lockscreen on my samsung S Advance which is a great alternative to the stock lockscreen. However I got this annoying behavior when waking up my phone with the home button because systematically I get back to the home screen bypassing the screen off state and losing my last position.

After searching in the forum I found that other users (Note2 and S3) are reporting the same behavior about the home button when waking the phone up with a lockscreen. And I tried the next advised solution:
  • First with R/W root permission, one should open the file /system/usr/keylayout/gpio-keys.kl
  • Then inside the gpio-keys.kl the last line must be edited to change from "key 172 HOME WAKE" to "key 172 HOME WAKE_DROPPED"

In theory this should fix the problem but in fact on my S Advance it doesn't work. Then I wanted to ask if anyone has a better solution or any clue to solve this frustrating behavior.

At the moment my single solution is to deactivate the home button while the screen is off. This can be done if the last line in the gpio-keys.kl doesn't include the "HOME" word. This means that I can only wake my phone with the Power button which it is still not very ergonomic to my taste.

INFO: I'm using a stock Jelly Bean ROM 4.1.2 (XXLQE), the Co-core 8.2 Kernel and LightJB.

I hope you can help to figure out how to fix it.

Thanks in advance
 
luisblop
Old
(Last edited by luisblop; 27th April 2014 at 08:44 PM.)
#2  
Member - OP
Thanks Meter 2
Posts: 62
Join Date: Feb 2014
Lightbulb SOLUTION: Xposed Additions Module

The fix can be done using the Xposed Additions Module.

Actually it's pretty easy:
-Install / Enable the Adittions Module inside Xposed Framework and Reboot.
-Open Xposed Additions and go to the last menu option "Buttons"
-Remap [HOME] and choose the condition "Screen Off / Disable Click Action". Voila! you're done.

I thoughtI I had to live forever with that issue. Thanks and all the credit to the developer.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Automate Your Device with Sfen

Changing the profile of yourdevice manually is now long forgotten. Since the advent of Android automation … more

Galaxy Photo Screen Lock Displays a Photo Slideshow on Your Lock Screen

Being the most often looked at part of our devices UI, the lock … more

Boost the LG G3 Speaker and Headphone Volume

It seems like OEMs are stepping up their game, with regards to thequality of their devices sound … more

Forums Added for the HTC Desire 610 and LG G3 US Carrier Variants

We recently added two new sets of forums here on XDA. The first … more