5,599,033 Members 32,181 Now Online
XDA Developers Android and Mobile Development Forum

Battery not charging

Tip us?
 
Die Bruine
Old
#1  
Die Bruine's Avatar
Senior Member - OP
Thanks Meter 20
Posts: 486
Join Date: Jan 2008
Location: The Hague
Default Battery not charging

Nope not a problem (anymore) but just something I wanted to share with you. I bought an XT894 of Ebay, apparently from an XDA member. The phone is unable to register the SIM. So I thought of buying a new daughter board and swap it out. Then I thought of just swapping it with mine just to be sure. I did, but to no avail. While testing I accidentally used my battery in the Ebay Droid. After the swap I placed the batteries back. The phones kept on working. But one of the batteries wouldn't charge (my own Droid with the battery I accidentally put in the Ebay Droiid). When I plugged in the charger, the phone started charging from 5% to 100% in 5sec. But the phone wouldn't boot. I left it on the charger for a night, also didn't help. Then I thought of soldering a factory cable and SBF the SOB. Yep, that also did not work. The same thing happened, you plug in the charger and it goes from 5% to 100% in 5sec. After that I just ordered another XT894 with a cracked screen. The mainboard can be used to fix the one I bought of Ebay. The battery can probably fix my own Droid.

Yesterday I decided to swap batteries again. I was hesitant because of the risk of killing both batteries. But for some reason Battery A works in Droid B an battery B works in Droid A. I charged both, drained both 'till they turned off. And now both are on their second charge. In short, both Droids seem to be working well after I swapped the batteries. I searched everywhere but could find no report of this. That's why I'm posting it. As you can see I tried everything I could think of. Nothing, noooothing helped.

The next step would be swapping the batteries back again. But I won't be doing that. I had to go through 4 days without a working phone.

Just thought I'd share. An apparently dead battery isn't always dead. Even when the factory cable doesn't seem to work.
Lost my first ID
Canary/Voyager/Magician/Typhoon/Vox/Elf/Raphael/Rhodium/A853/U20i/A953/sk17i/XT894/XT897/HOX+/XT925
Currently XT897/XT925
The Following 2 Users Say Thank You to Die Bruine For This Useful Post: [ Click to Expand ]
 
KrellaKrentoshi
Old
#2  
Member
Thanks Meter 1
Posts: 30
Join Date: Jul 2012
Red face same thing is happening to me

Quote:
Originally Posted by Die Bruine View Post
Nope not a problem (anymore) but just something I wanted to share with you. I bought an XT894 of Ebay, apparently from an XDA member. The phone is unable to register the SIM. So I thought of buying a new daughter board and swap it out. Then I thought of just swapping it with mine just to be sure. I did, but to no avail. While testing I accidentally used my battery in the Ebay Droid. After the swap I placed the batteries back. The phones kept on working. But one of the batteries wouldn't charge (my own Droid with the battery I accidentally put in the Ebay Droiid). When I plugged in the charger, the phone started charging from 5% to 100% in 5sec. But the phone wouldn't boot. I left it on the charger for a night, also didn't help. Then I thought of soldering a factory cable and SBF the SOB. Yep, that also did not work. The same thing happened, you plug in the charger and it goes from 5% to 100% in 5sec. After that I just ordered another XT894 with a cracked screen. The mainboard can be used to fix the one I bought of Ebay. The battery can probably fix my own Droid.

Yesterday I decided to swap batteries again. I was hesitant because of the risk of killing both batteries. But for some reason Battery A works in Droid B an battery B works in Droid A. I charged both, drained both 'till they turned off. And now both are on their second charge. In short, both Droids seem to be working well after I swapped the batteries. I searched everywhere but could find no report of this. That's why I'm posting it. As you can see I tried everything I could think of. Nothing, noooothing helped.

The next step would be swapping the batteries back again. But I won't be doing that. I had to go through 4 days without a working phone.

Just thought I'd share. An apparently dead battery isn't always dead. Even when the factory cable doesn't seem to work.
I bought an ebay d4 to fix my d4. All seemed to be ok, but now I am having the above mentioned problem. Why wont my d4 recognize its own battery? I know the battery is charged, I charged it just fine before I took it apart, now it wont do anything unless its plugged in and its jumping from 0% to 5% then 2 seconds later, 100%. I can't get it boot. I will try the battery swap mentioned above, but the ebay d4s battery overheated, and when i got it and booted it, it had to exit `cooldown mode`. So im concerned about using that battery. Is there any way to get my d4 and its phone to talk to each other again?

---------- Post added at 11:02 PM ---------- Previous post was at 10:41 PM ----------

So, I tried the fix above, it didn't work either. As I was replacing the original battery, I remembered how the battery flopped out cuz the adhesive wasn't stuck to anything. So I took that cable that screws the phone to the battery and bent it down. Phone powered on wonderfully !!!! Im so happy! Thank you to everyone on here for sharing your repair knowledge so freely love y'all!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes