5,593,458 Members 36,726 Now Online
XDA Developers Android and Mobile Development Forum

SW 2 Bluetooth Problem?

Tip us?
 
sidofido
Old
#1  
Member - OP
Thanks Meter 0
Posts: 38
Join Date: May 2012
Thumbs down SW 2 Bluetooth Problem?

Hi,
I've got yesterday sw2. It is really cool, but sometimes i have problem with bluetooth. Sw2 seems to be connected with phone, but when i start some app, it is loading, but this app don't start. I must restart my watch and then everything works fine, but then when i don't use it for a while it didn't want start against. I am using nexus 5 with custom rom. Where can be a problem?
 
Gryx
Old
#2  
Member
Thanks Meter 5
Posts: 72
Join Date: Oct 2010
I am having the same problem. Also a nexus 5 with custom rom. Maybe this is a nexus issue?

Which kernel are you running on the phone.
 
sidofido
Old
#3  
Member - OP
Thanks Meter 0
Posts: 38
Join Date: May 2012
I am using latest Droidkang rom with stock cm kernel.
 
aseeme555076
Old
#4  
Member
Thanks Meter 11
Posts: 44
Join Date: Jun 2013
Location: Taipei
Some times I will clear phone's RAM to temporarily resolve this problem.
 
ingrim
Old
#5  
ingrim's Avatar
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Aug 2006
Location: Hannover
Any ideas anyone? I have the same problem on stock 4.3 on HTC One Max. It drives me nuts ^^
Wer die Freiheit aufgibt, um Sicherheit zu gewinnen, wird am Ende beides verlieren.
- Benjamin Franklin

Si vis pacem, para bellum!
 
mcnob
Old
#6  
Senior Member
Thanks Meter 18
Posts: 415
Join Date: Aug 2010
Location: Suffolk
Stock Nexus 5 has no such issue so I'd start with the kernel /ROM bluetooth compatability. Certain apps seem to lose their state occasionally I've noticed. They generally just need to be closed and reopened though. No reboot has been necessary.



Sent via telepathy
Posted from either:

Nexus 5
Nexus 7 (2013)
Acer C720 Chromebook.....................(How much of a Google fanboy am I ?)
 
noviomagum
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jul 2013
Location: Nijmegen
Default Difficulty with MediaTek devices

I have a Wiko Stairway, which is built on MediaTek platform. Pairing is difficult but possible. I don't know whose fault it is, MediaTek or Sony or both?
Still I find it awkard that I have to install 10MB of Sony software just to establish a faulty connection.

My workaround:
  1. Pair the devices without installing the Smart Connect suite
  2. Install Smart Connect and restart watch
  3. Start Smart Connect and wait a while. It should now find the watch and prompt for installing the add-on
  4. Turn bluetooth off and on on both devices
  5. It should now work

Problem is that every now and then the connection is dropped and you may have to toggle bluetooth on either watch or phone or both. Even sometimes a restart is required.
 
kill_dano
Old
#8  
kill_dano's Avatar
Senior Member
Thanks Meter 15
Posts: 108
Join Date: Oct 2007
A work around might be to see if force closing the app 'bluetooth share' temporary resolves the issue. If that's the case you could set up a tasker task to kill bluetooth share every 8 hours or so. You might need a plug-in to properly kill bluetooth share with tasker.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Prevent Unwanted Butt Dialing with Smart Pocket Guard

You may recall that back in August of last year, we took a look atAir SwiperbyXDA … more

Google ATAP Details Project Ara in Developers’ Conference

Earlier today, the Google ATAP teamkicked offits first ever Project Ara … more

HTC Sense 6 Ported to the Nexus 5

The Google Nexus 5 is regarded as having everything an Android user needs or wants: timely updates, … more