FORUMS

What Features Do You Look for in a Gallery App?

With so many different options to choose from, finding the right Gallery app may be a … more

Google Photos ‘Unlimited’ Storage Reportedly Being Capped

When Google Photos was announced, many of us thought very highly … more

Sprint Moves to Lift Video Streaming Limit for All-In

Yesterday, Sprint announced a new unlimited scheme that offered customers an … more

Xiaomi Releases Kernel Source Code For Mi4i

If you’ve been following the XDA News Portal lately, you might have noticed an … more

[GUIDE] adb and fastboot drivers for Windows

659 posts
Thanks Meter: 726
 
By shaftenberg, Senior Member on 21st November 2013, 08:04 PM
Post Reply Subscribe to Thread Email Thread
If someone has problems installing the official Motorola adb and fastboot drivers for Windows, try the following, this works for me:

1. download the UniversalADB driver from @Koush here: https://github.com/koush/UniversalAdbDriver
2. install it
3. locate the file android_winusb.inf in the folder (may vary) x:\Program Files\ClockworkMod\Universal Adb Driver\usb_driver
4. open it with any texteditor
5. add the following two lines (somewhere in the devices section) and save the file:
Code:
MotorolaADBInterface	= USB_Install, USB\VID_22B8&PID_2E76&REV_0228&MI_01
MotorolaBootLoaderInterface	= USB_Install, USB\VID_22B8&PID_2E80&REV_0100
6. let Windows install this driver from koush's directory once in adb mode and once in fastboot mode (two drivers!)
7. enjoy!
The Following 20 Users Say Thank You to shaftenberg For This Useful Post: [ View ]
 
 
24th November 2013, 09:53 AM |#2  
Benowit's Avatar
Member
Flag Amiens
Thanks Meter: 151
 
More
Work fine thanks
24th November 2013, 10:39 AM |#3  
Senior Member
Thanks Meter: 435
 
More
Is the phone recognized by RSD Lite in fastboot mode with these drivers?

I have the Motorola drivers, using Windows 7 SP1 32-bit.
With USB debugging enabled I get a "Mot Composite ADB Interface" device in device manager (Driver Version 2.0.1.0).

The phone can be seen by 'adb devices' and in fastboot by 'fastboot devices' however using RSD lite 6.1.5 no device appears.

24th November 2013, 05:44 PM |#4  
shaftenberg's Avatar
OP Senior Member
Flag Cologne
Thanks Meter: 726
 
More
Quote:
Originally Posted by t-bon3

The phone can be seen by 'adb devices' and in fastboot by 'fastboot devices' however using RSD lite 6.1.5 no device appears.

Got the same with the universal ADB/fastboot drivers damn.

[edit]
The MotoG PID is missing in PST.ini and/or sdk_common.ini, maybe we have to add it manually or wait for a new RSDlite
Last edited by shaftenberg; 24th November 2013 at 06:02 PM.
1st December 2013, 10:59 AM |#5  
Junior Member
Thanks Meter: 4
 
More
hi,
have you some newz about new RSDlite ?(maybe i'm too impatient ... )
7th January 2014, 10:40 PM |#6  
Senior Member
Flag Natal RN
Thanks Meter: 14
 
More
Worked great. Thank you
Last edited by Mrkblo; 7th January 2014 at 10:45 PM. Reason: After a reboot the phone connected properly.
7th January 2014, 11:19 PM |#7  
Senior Member
Flag Venezia
Thanks Meter: 701
 
More
Quote:
Originally Posted by maty3ux

hi,
have you some newz about new RSDlite ?(maybe i'm too impatient ... )

Not yet, last version is 6.1.6
Last edited by denzel09; 17th February 2014 at 06:20 PM.
17th February 2014, 03:42 PM |#8  
Junior Member
Thanks Meter: 0
 
More
I do not understand this instruction:

Quote:
Originally Posted by shaftenberg

let Windows install this driver from koush's directory

Windows doesn't attempt to do anything when I connect the phone in ADB mode. Device Manager lists XT1034 under Other devices and says "The drivers for this device are not installed. (Code 28)". If I do "Update Driver Software" manually and direct it to the "ClockworkMod" directory, Windows says it cannot find driver software for the device. If I right click on the "android_winusb.inf" file and choose Install, Windows says the "file doesn't support this method of installation".
20th February 2014, 02:15 AM |#9  
Senior Member
Thanks Meter: 19
 
More
Exclamation
adb devices does't see my moto g

fastboot devices yes, but adb devices only says List of devices attached.

Any help will be appreciated
20th February 2014, 06:08 AM |#10  
reversegear's Avatar
Senior Member
Thanks Meter: 1,110
 
More
The latest update of UniversalAdbDriver does not require those lines to be added. Moto G device configuration is added by default

Tested in win7 64bit.
The Following 2 Users Say Thank You to reversegear For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes