5,596,128 Members 33,344 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED] Forced Close of core (or all) apps, Internal SD removed unexpectedly...

Tip us?
 
Dipu K
Old
(Last edited by Dipu K; 14th August 2012 at 12:22 PM.)
#1  
Member - OP
Thanks Meter 36
Posts: 36
Join Date: Aug 2011
Location: Bangalore
Default [SOLVED] Forced Close of core (or all) apps, Internal SD removed unexpectedly...

Hi All,

I got errors mentioned in the title and after few searches, found that there are few Galaxy SL owners who had got into this issue.

Currently Known Root Cause:
A hardware issue possibly due to a board issue or loose attachment of internal SD card to the motherboard (Grrrrrrr SAMSUNG!)

Symptoms:
- Suddenly core applications like phone/messaging start force closing (sometimes all open apps). Only a reboot will solve the issue.
- Sudden reboot of the phone after few hours of running (or even sleeping)
- Sometimes the restart itself hanging with a yellow message "Unknown Upload Mode"
- Message in status bar "Internal SD card has been removed unexpectedly" or "Internal SD card not accessible" or something like "Damaged SD card"

Known Solution:
1. Replacement of board from Samsung Service Center (Good for you if you are within the warranty period)
2. Do some hardware hack to remove the internal SD completely (http://forum.xda-developers.com/show....php?t=1651619)

I got this issue just after I finished my warranty period, and hence, I was trying to find if I can do something about this issue by my own. What I wanted was to actually swap my internal SD storage with a proper external SD storage. This is not same as the popular "swapping the internal and external SD card" topic, but that and something more as well!! This will solve the issue of force closes and sudden reboots (may still not solve issue of reboot getting stuck, but I assume phone will not need frequent reboot after solving first 2 issues!)

Galaxy SL has 3 partitions created in the card:
1. ext3 partition for data
2. another small FAT partition - (for what? not sure)
3. Third FAT partition which acts as the normal internal SD card (which is accessible when working as USB mass storage)

Intention here is to move all the partitions to the external SD. Looking at the mount points and vold.fstab, I could not find where the 2nd partition in the above list is mounted/used (If anyone knows, please let me know). So I decided to move atleast the ext3 (data) and fat (/sdcard) to the external SD.

Following are the steps I followed for doing the same:

WARNING!!!
1. Copy these at your own risk. I am not responsible if you brick your phone or lose your data/applications/settings or if the phone goes to a boot loop!
2. Do not continue if you do not understand what is written here
3. Doing this will change the /data partition. So wiping data partition in the normal way will not work (say from CWM). You may need to do 2 steps - wipe (internal) data normally (say using CWM), wipe (external SD) data manually by disabling the script mentioned in the procedure and wiping using make_ext4fs tool (steps are given in PART 3 of this post).
4. This has been tested only on CM9 Alpha 6-11 / rooted DDLF2. Theoretically it may or may not work on other ROMs, depending on other tweaks and changes in the system, no guaranty offered!
5. In case you mess it up, most of the time (but no guarantees!), you can recover by flashing from beginning using ODIN some base versions like KPE and then come to your normal ROM, followed by a nandroid recovery (so better do a nandroid backup before you try anything .

Pre-requisites:
- Rooted Phone
- Kernel with init.d support (and preferably ext4 as well if you want that)
- Basic ADB knowledge
- A blank micro SD card with at least class 4 (class 6 or greater preferred) speed and with sufficient capacity - say 8/16/32 GB

PART 1 - PREPARING THE EXTERNAL SD
--------------------------------------------------------------------
0. !!! FIRST !!!
Do a Nandroid Backup (and also other app level backups like Titanium or MyBackup)
Backup contents of your FAT partition (mmcblk0p1) - ie, the internal SD card card
Backup contents of your external SD card

1. Download sdparted-recovery.zip from web (http://forum.cyanogenmod.com/topic/6...ternal-storage - check messages like 11 to see the basic usage) and extract the contents
2. Using ADB, copy the extracted files in sdparted directory into /system/bin, change permission for all of them to 755 using chmod
3. Put a clean external SD card into the phone
4. In an ADB shell, run /system/bin/parted giving mmcblk1 as the target. Now resize the existing FAT partition (this is the first and default partition in the card). Tips:
print gives the existing partition(s)
help gives help on various options
for resizing and creating partitions, inputs should be derived from the initial print output (which gave the first and last points)
Eg: If card is 16GB, and you want to reserve 4GB for data, then resize the first partition to 12GB
5. Create a new partition of type ext2 with remaining size (say 4G in our case). Save and quit parted.
7. (Do this only if your kernel supports ext3/ext4) Run "tune2fs -j /dev/block/mmcblk1p2" to convert ext2 to ext3
8. (Do this only if your kernel supports ext4) Using ADB, copy "make_ext4fs" (attached) to /system/bin
9. (Do this only if your kernel supports ext4) Convert ext3 partition to ext4 using make_ext4fs ("make_ext4fs /dev/block/mmcblk1p2")
10. Now the partitions are ready
- They will be visible as mmcblk1p1 (FAT) and mmcblk1p2 (ext4) when you cat the /proc/partitions
- They will be visible as partitions 1(FAT) and 2 (ext4) in the print output of parted.
Confirm the above before proceeding further.

PART 2 - SWAPPING EXTERNAL AND INTERNAL SD
---------------------------------------------------------------------------------
1. Write a script, say 00remnt similar to the attached sample file which currently I am using (If you do not follow the script, better don't proceed. Else check if things are fine for your current base ROM settings)
2. Push this into /etc/init.d/ using ADB
3. Change permissions of the file to 755
4. If you need, copy the contents of your internal SD card FAT partition (/sdcard) to the external SD card FAT partition (/sdcard/external_sd or /emmc)
5. Use the popular (relevant methods) to swap the internal and external FAT partitions (which actually changes the vold.fstab contents). Normal search in the forum will give you the available methods - some ROMs support it as options, others have mods which will accomplish the same
5. Reboot and enjoy

Voila!!! Now the system is not using internal SD card (for most purposes) at all!! And your phone can now run for days without abrupt force closes and reboot. You still may get a message like SD card is removed/damaged, (and /emmc or /sdcard/exteranal_sd may become inaccessible - so better use it only as a temporary storage!). But you can safely ignore these messages as that is the internal SD card which we are not using anyway... Enjoy...

PART 3 - WIPING DATA PARTITION (in case you need this step later)
-----------------------------------------------------------------------------------------------------------
1. Change permission of the 00remnt to 644
2. Reboot the phone (now the phone will come up with default internal SD partition for data)
3. From ADB shell, execute "make_ext4fs /dev/block/mmcblk1p2" (see PART 1 on how to get this tool)
4. Change permission of the 00remnt to 755
5. Reboot the phone to recovery, wipe the /data as normal

rgds,
Dipu.

PS: If any one knows how our phone uses the 2nd partition in the internal SD card, please let me know... I am assuming that it is not used for any critical purposes (as my phone ran successfully for few days without any issue). May be it is used in some kernel/ROM, if so, please let me know.
Attached Files
File Type: txt 00remnt - Sample.txt - [Click for QR Code] (1.1 KB, 670 views)
The Following 8 Users Say Thank You to Dipu K For This Useful Post: [ Click to Expand ]
 
loneagl
Old
#2  
loneagl's Avatar
Senior Member
Thanks Meter 301
Posts: 821
Join Date: Mar 2012
Location: lost city of Atlanta
Though i didn't understand a word(being an internee dentist) it will be useful to others.appreciate your efforts!!

Sent from my GT-I9003 using xda app-developers app
 
Skander1998
Old
#3  
Skander1998's Avatar
Senior Member
Thanks Meter 469
Posts: 1,276
Join Date: May 2012
Location: Doha

 
DONATE TO ME
This is what i call a complete and useful guide.
This should become a sticky.. now... NOW!

Current Phone:
Phone: Samsung Galaxy Note 3 (4G-LTE | N9005) @ 2.3Ghz - Jet Black
Memory: 32GB with NO Ext-Memory
ROM: Heavily modified Assassins Rom v1 (UK CSC)
ROOT: Yes - Knox 0x1
TouchWiz: S5 TouchWiz UX - Android KitKat (4.4.2)

Collecting Dust:
Phone: Samsung Galaxy S3 I-9300 @ 1.4Ghz
ROM: Stock BTU (4.3 - rooted)
--
Phone: Samsung Galaxy SL I9003 RETIRED


I will NOT answer to questions asking for help by PM unless I ask you specifically to PM me.
 
cyber9940
Old
#4  
Junior Member
Thanks Meter 3
Posts: 23
Join Date: Jan 2008
Location: The Cybersphere
+1 for sticky, superb info.
Galaxy SIII - Returned to Full Stock (Thanks to Chainfire's TriangleAway v2.50) (Never leaves home... too expensive)
Galaxy SCL - RemICS v1.7 - SIII Look & Feel
Galaxy 3 - Stock with G3Mod Kernel ( My daily use phone)
Archos IT 70 - OpenAOS
SPV M600 G4 - IPL: 2.15.001 - SPL:2.G4.4PDA -WM6.1 Korand WWE 3.1
 
cukierkas
Old
#5  
cukierkas's Avatar
Senior Member
Thanks Meter 220
Posts: 959
Join Date: May 2010
that would be a really nice sticky

i had the motherboard changed..
 
bfsa
Old
(Last edited by bfsa; 20th October 2012 at 11:48 AM.)
#6  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Oct 2012
Thanks Dipu K for your efforts.

I've tried this solution in my I9003, and I have only a problem: When reboot the phone, /data is copied into de Ext4 partition on SD card, but all aplications have errors because isnīt possible to unmount /data,

Here is the messaje in remnt-log (only a few lines):

Code:
...
3. Make Directory --->
4. Mount new data partition from external SD --->
5. Copy the current files in /data
6. Remove current files in /data
7. Unmount /data
umount: can't umount /data: Device or resource busy
8. Remove dir /data as a safety measure
9. Linking external sd data partition as /data
10. Final Mount status --->
...
What can I do to correct this?

Thanks
 
bfsa
Old
#7  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Oct 2012
Quote:
Originally Posted by bfsa View Post
...

What can I do to correct this?

Thanks
Finally, I've changed a line on 00remnt, and seems to work properly: busybox umount -l /data 2>> /system/remnt-log
 
mpbtejada
Old
#8  
mpbtejada's Avatar
Senior Member
Thanks Meter 64
Posts: 181
Join Date: Jan 2012
Location: Quezon City

 
DONATE TO ME
Where can I get make_ext4fs? Sadly the same case has happened to me...
 
prem.y83@gmail.com
Old
#9  
Junior Member
Thanks Meter 2
Posts: 24
Join Date: Apr 2012
Location: Bangalore
Hi Guys.
I am using alpha 4 from last one month and experience was awesome but from last 1 week I am getting lot of FC for lot of services like exchange service gapps what's up camera and lot more. I am not sure why FC issue started happening from last one week.

History :
I was using CM 10 alpha 1 then alpha 2 then alpha 3 and now on alpha 4.

I really fed up with Force close issue from last one week . I tried reboot but still 80% of apps and services getting FC. Please guide me on this .

Sent from my GT-I9003 using xda app-developers app


Sent from my GT-I9003 using xda app-developers app
 
the boy plunger
Old
#10  
Junior Member
Thanks Meter 0
Posts: 15
Join Date: Jul 2010
hi all, i have a galaxy i9003 with a corrupted or completely dead (not sure) internal memory chip. I have come to this conclusion after 3 days of trying to install custom and stock roms. I can access recovery and download mode but i cant install any ROM, the phone keeps rebooting after the SAMSUNG (whole screen black except SAMSUNG in the middle). All i have is atm this http://forum.xda-developers.com/show....php?t=1351056 installed on my phone via ODIN. I dont have knowledge about ADB, can somebody help me out with instructions more?

Tags
i9003 force close damaged removed
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes