Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Question [Q] Unrooting my S4 to send back to Verizon... please advise

OP CParker1987

25th February 2014, 12:25 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2014
So as the title says, I am unrooting my s4 to send back to Verizon. Now I saw a video on youtube that said I need to reset my binary counter. I have not flashed any custom roms or did anything else other than rooted it. I am unrooting a putting the factory firmware on my phone, do I need to reset my binary counter or is the factory firmware going to trip the counter? basically I am trying to avoid Verizon seeing I messed with the phone and make me pay 600 or so dollars for the new phone they are sending me.
25th February 2014, 12:54 AM   |  #2  
Member
Flag Goldsboro
Thanks Meter: 21
 
75 posts
Join Date:Joined: Feb 2011
More
Should just be able to Odin back to any of the builds on these forums and be good if all you did was root it

Sent from my SCH-I545 using xda app-developers app
25th February 2014, 01:11 AM   |  #3  
Member
Glendale, AZ
Thanks Meter: 15
 
48 posts
Join Date:Joined: Aug 2008
More
When I did mine Odin worked fine like jwendt said...

Sent from my Galaxy S4 on Verizon using Tapatalk
25th February 2014, 03:35 AM   |  #4  
buhohitr's Avatar
Senior Member
Thanks Meter: 1,628
 
5,447 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by CParker1987

So as the title says, I am unrooting my s4 to send back to Verizon. Now I saw a video on youtube that said I need to reset my binary counter. I have not flashed any custom roms or did anything else other than rooted it. I am unrooting a putting the factory firmware on my phone, do I need to reset my binary counter or is the factory firmware going to trip the counter? basically I am trying to avoid Verizon seeing I messed with the phone and make me pay 600 or so dollars for the new phone they are sending me.

Boot into download mode and check the counter, if firmware=official and counter=0 then you all set to return,
25th February 2014, 06:42 AM   |  #5  
Senior Member
Thanks Meter: 23
 
142 posts
Join Date:Joined: Sep 2009
With my rooted m7 all I had to do was full reset from within phone settings then let it reboot. After it was done I pulled battery, put it back in and turned it on to see no more custom screen.

Sent from my SCH-I545 using xda app-developers app
25th February 2014, 03:22 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by jhasty01

With my rooted m7 all I had to do was full reset from within phone settings then let it reboot. After it was done I pulled battery, put it back in and turned it on to see no more custom screen.

Yea I tried that the first time I was going to unroot... funny thing was when I tried to reset, it sent me to the downloading screen and got stuck there for as long as id let it stay there. but just to update... put the stock firmware on it through Odin and worked just fine. Just in case anyone else ran into this problem.
25th February 2014, 08:28 PM   |  #7  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Jan 2014
try these
http://forum.xda-developers.com/show....php?t=2578569
http://galaxys4root.com/galaxy-s4-tu...ot-completely/

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes