Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Phone [Q] Ainol Novo Elf 1 Christian Troy's CM10 - no touchscreen

OP EG0

13th October 2012, 05:59 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Nov 2010
Since I can not post here:
[rom] Unofficial CyanogenMod 10 for many AllWinner A10 tablets
because no matter I'm in IT over 15 years I have no 10 posts here, which is quite uncool from XDA, I have to ask here:

I have an Elf, started to hack from with the latest factory firmware (updated with LiveSuit).

Then I decided to have Christian Troy's JellyBean.

I had trouble to get ClockWorkMod running, for example Novotools_v1.0.apk said not enough Internal storage. Finally I managed with
Terminal Emulator_1.0.41.apk and a10_recovery.zip 3 files with these two commands:
su install-recovery.sh
su reboot-recovery.sh

After rebooting to CWM I made a full wipe, than installed these in order:
cm10_a10_20120913.zip
gapps-jb-20120726-signed.zip
elf_compatibility_1.2.0.zip

After rebooting I see the animated CyanogenMod 10 logo, than I should choose language onscreen.
Though hardware keys work (power, volume), touch screen is not responding!

Actuall I dropped it as well after the last reboot, so now I'm not sure if this touch problem is related to CM10 or the drop.

Do you have any ideas what to do?
14th October 2012, 10:56 PM   |  #2  
Senior Member
Thanks Meter: 521
 
1,488 posts
Join Date:Joined: Oct 2012
Flash back to stock to verify if your touchscreen is working. If yes, make sure you don't need to flash a different kernel for your device.

Also, try flashing like you did before, but without gapps. Possibly, your /system partition gets full, so the elf_compatibility thing fails.

-- Sent from my TouchPad using Communities
25th October 2012, 05:09 PM   |  #3  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by post-mortem

Flash back to stock to verify if your touchscreen is working. If yes, make sure you don't need to flash a different kernel for your device.

Also, try flashing like you did before, but without gapps. Possibly, your /system partition gets full, so the elf_compatibility thing fails.

-- Sent from my TouchPad using Communities

I am in the no touch screen boat too. I'm running an elf, but thought I'd try the aurora compatibility files too. Unfortunately, no dice. Flashing back to 4.0.4 stock firmware brings the touchscreen back. More installs of the cm10 for a10 don't help...

Anyone that successfully flashed Christian troy's cm10 build into Ainol Elf 1 care to say which rom they upgraded from? That would be awesome...
26th October 2012, 09:43 PM   |  #4  
Junior Member
Thanks Meter: 0
 
8 posts
Join Date:Joined: Sep 2007
Same problem here with Aurora 1 with nightly CM10: no touch
29th October 2012, 05:24 AM   |  #5  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Apr 2012
Smile Success!
Quote:
Originally Posted by jan99

Same problem here with Aurora 1 with nightly CM10: no touch

OK, managed to trouble-crash my way through to a solution - hopefully it'll help you get to where you were going too...

The first thing I did was try to find the Feiyu ICS *LIVESUIT* image dated 0429. I also downloaded the compatibility patch for the elf - Aurora users won't need this, obviously.

I'm pretty sure this gives you a big enough /system partition, even though using the latest Ainol 4.0.4 firmware allegedly gave me enough.

Anyway, boot into CWM and do a Factory reset *twice*. I then did a cache format, dalvik wipe, battery stats wipe just for good luck. Fix permissions too - who knows why, I just do these things.

I installed the earliest preview release of the ChristianTroy cm10 for a10, installed the compatibility file for the elf (1.2...) , did a cache format, dalvik wipe, reboot... and... touch screen worked! I then installed the *final* cm10 from the ChristianTroy thread.

seems pretty nice, although trebuchet keeps crashing along with lots of my apps. Might use a different launcher.

perhaps cm9 is better? I'll give it a go...

TL;DR - install the livesuit image of the Feiyu ICS rom 0429. Then flash the other things you need. Worked for me, but, as ever, YMMV
5th November 2012, 10:06 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by post-mortem

Flash back to stock to verify if your touchscreen is working. If yes, make sure you don't need to flash a different kernel for your device.
Also, try flashing like you did before, but without gapps. Possibly, your /system partition gets full, so the elf_compatibility thing fails.
-- Sent from my TouchPad using Communities

Seems like HW problem, went back to Elvish 0.4, still no touchscreen...
19th November 2012, 03:42 PM   |  #7  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by DoubleDroz

OK, managed to trouble-crash my way through to a solution - hopefully it'll help you get to where you were going too...

The first thing I did was try to find the Feiyu ICS *LIVESUIT* image dated 0429. I also downloaded the compatibility patch for the elf - Aurora users won't need this, obviously.

I'm pretty sure this gives you a big enough /system partition, even though using the latest Ainol 4.0.4 firmware allegedly gave me enough.

Anyway, boot into CWM and do a Factory reset *twice*. I then did a cache format, dalvik wipe, battery stats wipe just for good luck. Fix permissions too - who knows why, I just do these things.

I installed the earliest preview release of the ChristianTroy cm10 for a10, installed the compatibility file for the elf (1.2...) , did a cache format, dalvik wipe, reboot... and... touch screen worked! I then installed the *final* cm10 from the ChristianTroy thread.

seems pretty nice, although trebuchet keeps crashing along with lots of my apps. Might use a different launcher.

perhaps cm9 is better? I'll give it a go...

TL;DR - install the livesuit image of the Feiyu ICS rom 0429. Then flash the other things you need. Worked for me, but, as ever, YMMV

I am facing same problem with Elf1, touch not working after installing CM10. Mouse works just fine. ^^Was this on ELF1 or Aurora?
21st November 2012, 02:52 PM   |  #8  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by DoubleDroz

OK, managed to trouble-crash my way through to a solution - hopefully it'll help you get to where you were going too...

The first thing I did was try to find the Feiyu ICS *LIVESUIT* image dated 0429. I also downloaded the compatibility patch for the elf - Aurora users won't need this, obviously.

I'm pretty sure this gives you a big enough /system partition, even though using the latest Ainol 4.0.4 firmware allegedly gave me enough.

Anyway, boot into CWM and do a Factory reset *twice*. I then did a cache format, dalvik wipe, battery stats wipe just for good luck. Fix permissions too - who knows why, I just do these things.

I installed the earliest preview release of the ChristianTroy cm10 for a10, installed the compatibility file for the elf (1.2...) , did a cache format, dalvik wipe, reboot... and... touch screen worked! I then installed the *final* cm10 from the ChristianTroy thread.

seems pretty nice, although trebuchet keeps crashing along with lots of my apps. Might use a different launcher.

perhaps cm9 is better? I'll give it a go...

TL;DR - install the livesuit image of the Feiyu ICS rom 0429. Then flash the other things you need. Worked for me, but, as ever, YMMV

Would appreciate if you could share those image files that you used...
1st December 2012, 04:52 AM   |  #9  
skydeaner's Avatar
Senior Member
Flag champaign
Thanks Meter: 130
 
846 posts
Join Date:Joined: Sep 2008
More
nevermind
Last edited by skydeaner; 2nd December 2012 at 06:12 AM. Reason: nvm
4th December 2012, 05:17 PM   |  #10  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by vipulpradhan

I am facing same problem with Elf1, touch not working after installing CM10. Mouse works just fine. ^^Was this on ELF1 or Aurora?

It was the Elf 1

---------- Post added at 02:47 AM ---------- Previous post was at 02:08 AM ----------

Quote:
Originally Posted by vipulpradhan

Would appreciate if you could share those image files that you used...

The files can be found at *double u, double u, double u dot* ainol-forum.de *slash* ainol-novo-7-aurora-1-i-2-ii *slash* roms-novo-7-aurora-1-i *slash* 302-rom-aurora-v1-feiyu-mod-0429 *slash*

Don't download from the 115 links - they're all locked up. The mirrors work, however.

If you have an Elf, get the Aurora v1 rom. Get the Livesuit Version, and install using... Livesuit.

If you have an Elf, you must also download the Elf Patch, which you install using CWM once you've installed 0429 through LiveSuit.

Give it a shot.

Sorry for the delay - been doing other things!

PS I can't directly put in a link because XDA won't let me - I don't have enough posts - but I've changed it so you can pretty obviously work out the url. Okie dokes?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes