Default incompatable problems ?!

hey guys
do any one know a way just to make the games or progs that
should be working on high version of android too be working on 2.3.6 ??
any way would help hacking system files, Roms, anything !?!