Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Unhappy [Q] Charging Problems with HTC One X Phone

OP keihuang

28th January 2014, 05:04 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2014
I am having big problems with my HTC One X..it all started when I updated my phone to jellybean..I normally put my phone to charge when the battery is about on 20%..I put my phone on charging and give it atleast 2,3 continuous hours to charge itself..now when I disconnect it from charging, it shows the battery still at 20%..I discussed this problem once before on this page and someone suggested me to do a soft restart by holding down the power button for about 5 seconds..I do that and then my phone restarts and shows the correct level of battery at 80% or more..this problem has been continuously happening to me from some time now and I have made a habit of myself to charge my phone for 3 hours and then perform a soft restart in order to see the correct battery level..Today I have charged my phone for 4 hours and have performed soft restarts on my device as well but it showed my batter level still at yellow and while on charging, I unlocked the screen and a message came up "your phone is using more current than your charger is able to deliver. Please turn off the unused applications or power off your phone during charging". I opened task manager, closed all applications and put it on charge again but again I got the same message so I turned off my phone and let it charge for 2 hours..then when I started my set, it showed the battery level at 3% and then restarted unexpectedly..since then I have been trying to restart my phone but it is not even starting itself and shuts down after showing the white HTC logo screen.. anybody explain my problems with HTC One X and I hope somebody can help me..Please tell me what to do..I am not sure whether this started happening after I updated to 4.2.2 sense5 or is there some problem with my charger..I do use original charger and USB cable so I am not sure what the problem is here..please help My phone CID: HTC_Y13
28th January 2014, 05:06 PM   |  #2  
P R O's Avatar
Junior Member
Thanks Meter: 3
 
12 posts
Join Date:Joined: Jan 2014
Maybe you messed up your charging cable or smithing idk never happens to me......O the problem is... ITS A HTC ONE lol.

Sent from my SCH-I605 using xda app-developers app
29th January 2014, 08:14 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2014
anyone help me pleaseeeeee!
Last edited by keihuang; 4th February 2014 at 07:32 PM.
25th February 2014, 09:07 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2014
up!
26th February 2014, 08:27 AM   |  #5  
Recognized Contributor / Themer
Thanks Meter: 8,849
 
14,390 posts
Join Date:Joined: Sep 2011
Donate to Me
Did you try all obvious thing, like changing the charger ?

I had the same problem few weeks ago, changing the cable did the trick for me.

Is the phone rooted, custom rom ?

Sent from my HTC One X using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes